Bug 114598 - [patch] misc/mc - UTF-8 support
Summary: [patch] misc/mc - UTF-8 support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-15 11:20 UTC by Cristian KLEIN
Modified: 2008-04-09 20:40 UTC (History)
0 users

See Also:


Attachments
file.txt (95 bytes, text/plain)
2007-07-15 11:20 UTC, Cristian KLEIN
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian KLEIN 2007-07-15 11:20:02 UTC
misc/mc does not have proper UTF-8 support. More precisely, 

* mc is unable to display UTF-8 files
* mcedit is unable to edit UTF-8 files
* some l10n artifacts appear in menu bar etc.

Fix: The following patch is adapted from the Gentoo Portage tree. Apply it like this:

cd /usr/ports/misc/mc
fetch http://users.utcluj.ro/~cristiklein/patches/mc-utf8.patch
patch -p0 -E < mc-utf8.patch

NOTE: This patch adds as dependency devel/libslang2. It can just as well add devel/libslang with proper UTF-8 support. See http://www.freebsd.org/cgi/query-pr.cgi?pr=114569

BUGS: Using devel/libslang2 will disable line drawing capability in cons25. Not a big issue since the user may choose not to include UTF-8 support, if line drawing in cons25 is really desired.


Patch attached with submission follows:
How-To-Repeat: [I hope GNATS is UTF-8 compliant.]

Enter a shell using an UTF-8 capable terminal emulator. For example, if you use gnome-terminal, make sure Terminal->Encoding is set to UTF-8. Then in csh type:

setenv LANG ro_RO.UTF-8
echo "&#259;âî&#351;&#355;" > &#259;&#355;
ls -l
mc
mcedit &#259;&#355;

Expected behaviour:
* mc should show &#259;&#355; in directory listing.
* mcedit should show &#259;âî&#351;&#355;

Actual behaviour:
* mc shows ??
* mcedit shows something unreadable
Comment 1 Edwin Groothuis freebsd_committer 2007-07-15 11:20:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fjoe

Over to maintainer
Comment 2 Cristian KLEIN 2007-08-20 12:40:24 UTC
I made a typo in the section telling the user how to apply the patch:

cd /usr/ports/misc/mc
fetch http://users.utcluj.ro/~cristiklein/patches/mc-utf8.patch
patch -p1 -E < mc-utf8.patch

I also changed the patch, so the port revision would be updated to 6.

Meanwhile, other 2 servers are happily using UTF-8 compliant mc.
Comment 3 Max Khon freebsd_committer 2008-04-09 20:31:23 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 4 dfilter service freebsd_committer 2008-04-09 20:31:27 UTC
fjoe        2008-04-09 19:31:16 UTC

  FreeBSD ports repository

  Modified files:
    misc/mc              Makefile 
  Added files:
    misc/mc/files        mc-4.6.1-utf8-r2.patch 
  Log:
  - Add UTF-8 support [1]
  - Add ability to build with glib12 (though it still builds with glib2
  if it is installed) [2]
  
  PR:             114598 [1]
  Submitted by:   Cristian KLEIN [1], Alexander Zagrebin [2]
  
  Revision  Changes    Path
  1.114     +15 -3     ports/misc/mc/Makefile
  1.1       +5119 -0   ports/misc/mc/files/mc-4.6.1-utf8-r2.patch (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"