Bug 114760 - [sound] [snd_cmi] snd_cmi driver causing sporadic system hangs
Summary: [sound] [snd_cmi] snd_cmi driver causing sporadic system hangs
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 6.2-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-20 08:10 UTC by Brian O'Shea
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian O'Shea 2007-07-20 08:10:01 UTC
I am using the snd_cmi module with a CMedia CMI8738 sound card.
The device is recognized:

pcm0: <CMedia CMI8738> at io 0xd400 irq 16 kld snd_cmi (1p/1r/0v channels duplex default)

However, whenever the driver is used to play any audio, the system will
typically hang after a few seconds of play.  There is no panic message that
I can tell (nothing in syslog), and the system is completely unresponsive.
The only way to reboot is to reset the system.

How-To-Repeat: # kldload snd_cmi

Then use any audio application.
Comment 1 Remko Lodder freebsd_committer 2007-07-23 10:06:31 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-multimedia

Reassign to multimedia team
Comment 2 Brian O'Shea 2007-11-09 17:47:54 UTC
This happens with both the snd_cmi kernel module and with the
driver compiled into the kernel.  I also tried both debug and
performance builds, with the same result.

Interestingly, with the system booted in single-user mode the
problem does not happen.  I will try narrowing it down further.
Perhaps it is caused by an interaction between the driver and
other kernel modules (which would not be loaded in single-user
mode).



__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:27 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped