Bug 116241 - update games/crafty (Also solves pr ports/116163)
Summary: update games/crafty (Also solves pr ports/116163)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-09 23:40 UTC by shoemaker
Modified: 2007-09-10 02:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shoemaker 2007-09-09 23:40:01 UTC
	Crafty is an open source chess engine.  The former version is
very old, not to mention broken when compiling enormous opening books
(see pr ports/116163) This updates to the newest version, and solves
the problem as well.  Sorry about the prior pr with this topic - the
makefile had a couple typos.
	This seems to be an abandoned port.  If the maintainer is no
longer interested, I will volunteer to take over this port.

Fix: 

----------------------------------------------------------------------
Finally - A spam blocker that actually works.
http://www.bluebottle.com/tag/4--l5I6R4rnoi5EysMeoJKeA9wX1qrPsdsKgOrfSmfOs2rbNTtO
Content-Type: text/plain; name="file.shar"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.shar"

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	crafty
#	crafty/files
#	crafty/files/books-building
#	crafty/files/patch-Makefile
#	crafty/Makefile
#	crafty/distinfo
#	crafty/pkg-descr
#	crafty/pkg-plist
#	crafty/scripts
#	crafty/scripts/configure
#	crafty/pkg-message
#
echo c - crafty
mkdir -p crafty > /dev/null 2>&1
echo c - crafty/files
mkdir -p crafty/files > /dev/null 2>&1
echo x - crafty/files/books-building
sed 's/^X//' >crafty/files/books-building << 'END-of-crafty/files/books-building'
Xbooks create start.pgn 60
Xquit
END-of-crafty/files/books-building
echo x - crafty/files/patch-Makefile
sed 's/^X//' >crafty/files/patch-Makefile << 'END-of-crafty/files/patch-Makefile'
X--- Makefile.orig	Tue Jun 20 07:57:17 2006
X+++ Makefile	Sun Sep  9 10:48:25 2007
X@@ -146,10 +146,10 @@
X freebsd:
X 	$(MAKE) target=FreeBSD \
X 		CC=gcc CXX='$(CC)' \
X-		CFLAGS='$(CFLAGS) -fomit-frame-pointer -m486 -O3 -Wall' \
X-		CXFLAGS=$(CFLAGS) \
X-		LDFLAGS=$(LDFLAGS) \
X-		opt='$(opt) -DINLINE32' \
X+		CFLAGS+='-fomit-frame-pointer -mtune=i486 -O3 -Wall' \
X+		CXFLAGS+=$(CFLAGS) \
X+		LDFLAGS='$(LDFLAGS) -lstdc++' \
X+		opt='$(opt)' \
X 		crafty-make
X 
X freebsd-pgcc:
END-of-crafty/files/patch-Makefile
echo x - crafty/Makefile
sed 's/^X//' >crafty/Makefile << 'END-of-crafty/Makefile'
X# New ports collection makefile for:	crafty
X# Date created:				31 May 1998
X# Whom:					Stefan Eggers <seggers@semyam.dinoco.de>
X#
X# $FreeBSD: ports/games/crafty/Makefile,v 1.32 2005/12/21 11:03:33 garga Exp $
X#
X
XPORTNAME=	crafty
XPORTVERSION=	20.14
XCATEGORIES=	games
XMASTER_SITES=	ftp://ftp.cis.uab.edu/pub/hyatt/pgn/:data \
X		ftp://ftp.cis.uab.edu/pub/hyatt/documentation/:doc \
X		ftp://ftp.cis.uab.edu/pub/hyatt/source/:src
XDISTFILES=	crafty-${PORTVERSION}.zip:src \
X		start.pgn:data
XDIST_SUBDIR=	crafty
XEXTRACT_ONLY=	crafty-${PORTVERSION}.zip
X
XMAINTAINER=	seggers@semyam.dinoco.de
XCOMMENT=	A chess programm for playing and analyzing games
X
XUSE_ZIP=        yes
XUSE_GMAKE=	yes
X
X.if !defined(NOPORTDOCS)
XDOCFILES=	crafty.doc.ascii crafty.doc.ps
XDISTFILES+=	${DOCFILES:S/$/:doc/}
X.endif
X
XALL_TARGET=	freebsd
X
X.if !defined(WITH_BOOKDIR)
XWITH_BOOKDIR=	${PREFIX}/lib/crafty
X.endif
X.if !defined(WITH_LOGDIR)
XWITH_LOGDIR=	/tmp
X.endif
X.if !defined(WITH_RCDIR)
XWITH_RCDIR=	~/
X.endif
X.if !defined(WITH_TBDIR)
XWITH_TBDIR=	${PREFIX}/lib/crafty/TB
X.endif
X
XOPT=		-DHASHSTATS -DTRACE -DBOOKDIR=\\\"${WITH_BOOKDIR}\\\" \
X		-DLOGDIR=\\\"${WITH_LOGDIR}\\\" \
X	       	-DRCDIR=\\\"${WITH_RCDIR}\\\" \
X		-DTBDIR=\\\"${WITH_TBDIR}\\\"
X
X.if ${MACHINE_ARCH} == "i386"
XOPT+=		-DINLINE32
X# XXX Someone with ASM knowledge would have to fix the Sparc.S
X.elif ${MACHINE_ARCH} == "sparc64"
XOPT+=		-DINLINE32
XCFLAGS=		'$(CFLAGS) -D_REENTRANT -O3 -Wall \
X		-fomit-frame-pointer -funroll-all-loops \
X		-finline-functions -ffast-math' \
X.else
XOPT+=		-DFAST
X.endif
XMAKE_ENV+=	opt="${OPT}" target=${OPSYS} CXFLAGS="${CXXFLAGS}"
X
Xpost-extract:
X	${CP} ${DISTDIR}/${DIST_SUBDIR}/start.pgn ${WRKSRC}/start.pgn
X
Xpost-build:
X	(cd ${WRKSRC}; ./crafty bookpath=. <${FILESDIR}/books-building)
X
Xdo-install:
X	${INSTALL_PROGRAM} ${WRKSRC}/crafty ${PREFIX}/bin/crafty
X	${CHOWN} nobody:nogroup ${PREFIX}/bin/crafty
X	${CHMOD} 6555 ${PREFIX}/bin/crafty
X	${MKDIR} ${PREFIX}/lib/crafty
X	${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty
X	${INSTALL_DATA} ${WRKSRC}/books.bin ${PREFIX}/lib/crafty/books.bin
X	${INSTALL_DATA} ${WRKSRC}/book.lrn ${PREFIX}/lib/crafty/book.lrn
X	${INSTALL_DATA} ${WRKSRC}/position.bin ${PREFIX}/lib/crafty/position.bin
X	${INSTALL_DATA} ${WRKSRC}/position.lrn ${PREFIX}/lib/crafty/position.lrn
X	${TOUCH} ${PREFIX}/lib/crafty/book.bin
X	${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty/book*
X	${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty/position*
X	${CHMOD} 664 ${PREFIX}/lib/crafty/book*
X	${CHMOD} 664 ${PREFIX}/lib/crafty/position*
X.if !defined(NOPORTDOCS)
X	${MKDIR} ${DOCSDIR}
X	cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${DOCFILES} ${DOCSDIR}
X.endif
X
Xpost-install:
X	@${CAT} ${PKGMESSAGE}
X.include <bsd.port.mk>
END-of-crafty/Makefile
echo x - crafty/distinfo
sed 's/^X//' >crafty/distinfo << 'END-of-crafty/distinfo'
XMD5 (crafty/crafty-20.14.zip) = ab681d84fc2f01ce0789cf4f47c945f8
XSHA256 (crafty/crafty-20.14.zip) = 9e4b90bde9c156ad537d6228c678d39dcaf790a0603125ab37ed48fb4662a01a
XSIZE (crafty/crafty-20.14.zip) = 422894
XMD5 (crafty/start.pgn) = 98176af8ec13945a4ec60ad9b5959412
XSHA256 (crafty/start.pgn) = 750397385a67307bd3e565f7a86d69745476db5fed4735650af971cc94318021
XSIZE (crafty/start.pgn) = 1349
XMD5 (crafty/crafty.doc.ascii) = 5fd73027a1de1674763562e1987197ba
XSHA256 (crafty/crafty.doc.ascii) = be291c0f4c7e7d64404ec58b9e92c2455c4342d3c96c721ba21a80fce8332e83
XSIZE (crafty/crafty.doc.ascii) = 79678
XMD5 (crafty/crafty.doc.ps) = 6cef69aa2f9ea1ceb74b6c14edc8291f
XSHA256 (crafty/crafty.doc.ps) = 887eb54de05f3371ef95adc38629a0f1f2cad66d1ca1b14fc426b87f5b13a9ab
XSIZE (crafty/crafty.doc.ps) = 141725
END-of-crafty/distinfo
echo x - crafty/pkg-descr
sed 's/^X//' >crafty/pkg-descr << 'END-of-crafty/pkg-descr'
XThis is crafty - a chess programm which is not just able to play a
Xgame and tell you the best move but also can annotate PGN files.
X
XThe user interface is ASCII based.  For a graphical interface one can
Xuse xboard which interfaces very well with it.
X
X- Stefan Eggers <seggers@semyam.dinoco.de>
END-of-crafty/pkg-descr
echo x - crafty/pkg-plist
sed 's/^X//' >crafty/pkg-plist << 'END-of-crafty/pkg-plist'
Xbin/crafty
Xlib/crafty/book.bin
Xlib/crafty/book.lrn
Xlib/crafty/books.bin
Xlib/crafty/position.bin
Xlib/crafty/position.lrn
Xshare/doc/crafty/crafty.doc.ascii
Xshare/doc/crafty/crafty.doc.ps
X@dirrm share/doc/crafty
X@dirrm lib/crafty
END-of-crafty/pkg-plist
echo c - crafty/scripts
mkdir -p crafty/scripts > /dev/null 2>&1
echo x - crafty/scripts/configure
sed 's/^X//' >crafty/scripts/configure << 'END-of-crafty/scripts/configure'
X	echo ""
X	echo ""
X	echo "This port has the following tunables:"
X	echo "WITH_BOOKDIR (default: ${PREFIX}/lib/crafty"
X	echo "WITH_LOGDIR  (default: /tmp)"
X	echo "WITH_RCDIR   (default: ~/)"
X	echo "WITH_TBDIR   (default: ${PREFIX}/lib/crafty/TB)"
X	echo ""
X	echo "To alter any of these, press CTRL-C now, and "
X	echo "simply set your desired variable with one or more of:"
X	echo ""
X	echo "<setenv WITH_BOOKDIR|LOGDIR|RCDIR|TBDIR path> (csh) or"
X	echo "<export WITH_BOOKDIR|LOGDIR|RCDIR|TBDIR=path> (sh)"
X	echo ""
X	echo "Changing BOOKDIR or TBDIR is not recommended, as other"
X	echo "ports depend on these being in a standard location"
END-of-crafty/scripts/configure
echo x - crafty/pkg-message
sed 's/^X//' >crafty/pkg-message << 'END-of-crafty/pkg-message'
X
XThis package is set to allow per-user config files, and a shared
Xbooks directory.  To accomplish this, crafty is setuid nobody, and
Xthe books and learning information is owned by the user 'nobody.'
X
XThe location values are tunable, see message when make is issued.
X
END-of-crafty/pkg-message
exit
Comment 1 Edwin Groothuis freebsd_committer 2007-09-09 23:40:11 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Edwin Groothuis freebsd_committer 2007-09-10 01:04:19 UTC
I get this:

===>  Building for crafty-20.14
gmake target=FreeBSD \
                CC=gcc CXX='cc' \
                CFLAGS+='-fomit-frame-pointer -mtune=i486 -O3 -Wall' \
                CXFLAGS+=-O2 -fno-strict-aliasing -pipe  \
                LDFLAGS=' -lstdc++' \
                opt='-DHASHSTATS -DTRACE -DBOOKDIR=\"/usr/local/lib/crafty\"  -D
LOGDIR=\"/tmp\"  -DRCDIR=\"~/\"  -DTBDIR=\"/usr/local/lib/crafty/TB\" -DINLINE32
' \
                crafty-make
# GNU Make 3.81
# Copyright (C) 2006  Free Software Foundation, Inc.
# This is free software; see the source for copying conditions.
# There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
# PARTICULAR PURPOSE.

# This program built for i386-portbld-freebsd6.2
# gmake[1]: Entering directory `/var/ports/root/cvs/ports/games/crafty/work/craf
ty-20.14'
gmake[1]: no-strict-aliasing: No such file or directory
gmake[1]: *** No rule to make target `no-strict-aliasing'.  Stop.

Any ideas how to resolve it?
Comment 3 shoemaker 2007-09-10 01:40:38 UTC
I must be getting somewhat senile...  Ok.  It wasn't even passing the
CXX flags from /etc/make.conf anyway, because I left it as CXFLAGS.
Doh!

Hopefully the last one.  Please replace, yet again, patch-Makefile
with this:

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	patch-Makefile
#
echo x - patch-Makefile
sed 's/^X//' >patch-Makefile << 'END-of-patch-Makefile'
X--- Makefile.orig	Tue Jun 20 07:57:17 2006
X+++ Makefile	Sun Sep  9 18:21:28 2007
X@@ -146,10 +146,10 @@
X freebsd:
X 	$(MAKE) target=FreeBSD \
X 		CC=gcc CXX='$(CC)' \
X-		CFLAGS='$(CFLAGS) -fomit-frame-pointer -m486 -O3 -Wall' \
X-		CXFLAGS=$(CFLAGS) \
X-		LDFLAGS=$(LDFLAGS) \
X-		opt='$(opt) -DINLINE32' \
X+		CFLAGS+='-fomit-frame-pointer -mtune=i486 -O3 -Wall' \
X+		CXFLAGS+='$(CXXFLAGS)' \
X+		LDFLAGS='$(LDFLAGS) -lstdc++' \
X+		opt='$(opt)' \
X 		crafty-make
X 
X freebsd-pgcc:
END-of-patch-Makefile
exit

// J Shoemaker
-- 
If only God would give me some clear sign!
Like making a large deposit in my name at a Swiss bank.
		-- Woody Allen, "Without Feathers"

----------------------------------------------------------------------
Find out how you can get spam free email.
http://www.bluebottle.com/tag/3
Comment 4 edwin 2007-09-10 02:01:44 UTC
Confirmed that it now builds and installs cleanly.

Waiting for the maintainer to approve or to timeout (two weeks) and
then I'll ocmmit it.

Edwin

-- 
Edwin Groothuis      |            Personal website: http://www.mavetju.org
edwin@mavetju.org    |              Weblog: http://www.mavetju.org/weblog/
Comment 5 dfilter service freebsd_committer 2007-09-10 02:11:59 UTC
edwin       2007-09-10 01:11:54 UTC

  FreeBSD ports repository

  Modified files:
    games/crafty         Makefile distinfo pkg-plist 
  Added files:
    games/crafty/files   patch-Makefile 
  Removed files:
    games/crafty/files   crafty.6 patch-aa 
  Log:
  update games/crafty (Also solves pr ports/116163)
  
          Crafty is an open source chess engine. The former version is
          very old, not to mention broken when compiling enormous opening books
          (see pr ports/116163) This updates to the newest version, and solves
          the problem as well. Sorry about the prior pr with this topic - the
          makefile had a couple typos.
  
          This seems to be an abandoned port. If the maintainer is no
          longer interested, I will volunteer to take over this port.
  
  The maintainers email address bounced, so Jonathan is now the happy
  maintainer of this port.
  
  PR:             ports/116241
  Submitted by:   shoemaker@bluebottle.com (Jonathan Shoemaker)
  
  Revision  Changes    Path
  1.33      +50 -26    ports/games/crafty/Makefile
  1.32      +3 -3      ports/games/crafty/distinfo
  1.4       +0 -79     ports/games/crafty/files/crafty.6 (dead)
  1.1       +17 -0     ports/games/crafty/files/patch-Makefile (new)
  1.18      +0 -11     ports/games/crafty/files/patch-aa (dead)
  1.6       +7 -3      ports/games/crafty/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 dfilter service freebsd_committer 2007-09-10 02:12:49 UTC
edwin       2007-09-10 01:12:45 UTC

  FreeBSD ports repository

  Added files:
    games/crafty         pkg-message 
    games/crafty/scripts configure 
  Log:
  update games/crafty (Also solves pr ports/116163)
  
          Crafty is an open source chess engine. The former version is
          very old, not to mention broken when compiling enormous opening books
          (see pr ports/116163) This updates to the newest version, and solves
          the problem as well. Sorry about the prior pr with this topic - the
          makefile had a couple typos.
  
          This seems to be an abandoned port. If the maintainer is no
          longer interested, I will volunteer to take over this port.
  
  The maintainers email address bounced, so Jonathan is now the happy
  maintainer of this port.
  
  PR:             ports/116241
  Submitted by:   shoemaker@bluebottle.com (Jonathan Shoemaker)
  
  Revision  Changes    Path
  1.1       +7 -0      ports/games/crafty/pkg-message (new)
  1.1       +16 -0     ports/games/crafty/scripts/configure (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Edwin Groothuis freebsd_committer 2007-09-10 02:13:12 UTC
State Changed
From-To: feedback->closed

Committed, thanks!