Bug 116408 - devel/avr-libc is BROKEN: fails when building docs [FIX]
devel/avr-libc is BROKEN: fails when building docs [FIX]
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Joerg Wunsch
Depends on:
  Show dependency treegraph
Reported: 2007-09-17 02:40 UTC by soralx
Modified: 2007-10-30 19:00 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description soralx 2007-09-17 02:40:01 UTC
gmake[4]: Entering directory `/usr/ports/devel/avr-libc/work/avr-libc-1.4.6/doc/api/latex_src'
echo "Running latex..."
Running latex...
latex refman.tex
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.

gmake[4]: *** [refman.dvi] Error 1
gmake[4]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.4.6/doc/api/latex_src'
gmake[3]: *** [avr-libc-user-manual.ps] Error 2
gmake[3]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.4.6/doc/api'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.4.6/doc'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.4.6'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/devel/avr-libc.


The snag is because 'latex' exits with error code 1, but actually it produces all the needed files. To fix this properly, one would need to investigate what is going on with latex, or at least change the Makefile so that make overrides the error. I've no idea how to do that. But one can build the port by hand: just cd to work/avr-libc-1.4.6/doc/api/latex_src, remove the 'clean' target from 'all:', then go through the steps of building 'refman.dvi' by hand. For a final touch, `cd work/avr-libc-1.4.6/doc/api/latex-pdf_src`, rinse, laher, repeat.
Comment 1 Edwin Groothuis freebsd_committer 2007-09-17 02:40:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->joerg

Over to maintainer
Comment 2 j 2007-10-05 20:14:23 UTC
Finally, I understood the issue as well as how to fix it.

This has been caused by doxygen moving internally completely to UTF-8.
Thus it is (mis)interpreting the ISO8859-1 input characters that have
always been there historically as UTF-8, and then LaTeX's inputenc
eventually complains about unknown UTF-8 characters.

The fix is to change doxygen's input encoding (back) to ISO8859-1 (in
doxyfile), plus fix a couple of non-ISO8859-1 characters that sneaked
into the documentation without anyone noticing before.  This will be
part of the next avr-libc release.  In order to process the generated
LaTeX code correctly, the port will also have to depend on
print/latex-urc in addition to the current prerequisites.

cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)
Comment 3 Joerg Wunsch freebsd_committer 2007-10-30 11:32:46 UTC
State Changed
From-To: open->closed

Fixed by upgrading to avr-libc 1.4.7.
Comment 4 dfilter freebsd_committer 2007-10-30 18:58:58 UTC
joerg       2007-10-30 11:32:27 UTC

  FreeBSD ports repository

  Modified files:
    devel/avr-libc       Makefile distinfo pkg-plist 
  Upgrade to version 1.4.7.  This also unbreaks the port.
  PR:             ports/116408
  Revision  Changes    Path
  1.62      +1 -4      ports/devel/avr-libc/Makefile
  1.33      +3 -3      ports/devel/avr-libc/distinfo
  1.28      +31 -0     ports/devel/avr-libc/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"