Bug 117068 - [patch] ports/net/citrix_ica - wfcmgr hangs
Summary: [patch] ports/net/citrix_ica - wfcmgr hangs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Thomas Abthorpe
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-10 14:10 UTC by Helge Oldach
Modified: 2008-01-03 20:26 UTC (History)
0 users

See Also:


Attachments
file.diff (396 bytes, patch)
2007-10-10 14:10 UTC, Helge Oldach
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helge Oldach 2007-10-10 14:10:03 UTC
After installing ports/net/citrix_ica, wfcmgr just hangs, i.e. the
splash screen shows up but then it stalls.

See also: ports/106061 (already closed, although the problem was not
fixed). Mail chat with this PR reporter revealed that the trivial patch
below fixed the issue for him as well.

Fix: Create ${LINUXBASE}/dev.

See the following advice, spotted via Google:

http://monkey.org/freebsd/archive/freebsd-current/200706/msg00252.html

http://lists.freebsd.org/pipermail/freebsd-emulation/2007-June/003680.html

The patch below just unconditionally creates that directory. This is
safe as citrix_ica is dependent on a linuxolator port anyway.
Comment 1 Edwin Groothuis freebsd_committer 2007-10-10 14:10:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tabthorpe

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Thomas Abthorpe freebsd_committer 2008-01-03 20:26:06 UTC
State Changed
From-To: open->closed

Committed, with documented work around. Thanks!