Bug 117204 - devel/PAPI port fix for GCC 4.2
devel/PAPI port fix for GCC 4.2
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Martin Wilke
Depends on:
  Show dependency treegraph
Reported: 2007-10-15 12:50 UTC by redcrash
Modified: 2007-10-27 15:50 UTC (History)
0 users

See Also:

file.diff (423 bytes, patch)
2007-10-15 12:50 UTC, redcrash
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description redcrash 2007-10-15 12:50:02 UTC
I've got my port broken on AMD64/FreeBSD 7 machines (building farms, I think).
The problem is related with the name of the fortran compiler (gfortran42), which is not found using the configure script. 
As a suggestion in the ports@freebsd.org, I've added a new line into the Makefile port in order to solve this.

I'm attaching the fix in diff -U format.

Thank you!
Comment 1 Martin Wilke freebsd_committer 2007-10-15 13:24:01 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2007-10-17 10:33:54 UTC
State Changed
From-To: open->feedback

Build Failed, 
Comment 3 dfilter freebsd_committer 2007-10-27 15:49:57 UTC
miwi        2007-10-27 14:49:53 UTC

  FreeBSD ports repository

  Modified files:
    devel/papi           Makefile distinfo pkg-plist 
  - Fix build with gcc 4.2
  PR:             117204
  Submitted by:   "Harald Servat" <redcrash@gmail.com>
  Thanks to:      nox@
  Revision  Changes    Path
  1.7       +4 -8      ports/devel/papi/Makefile
  1.3       +3 -3      ports/devel/papi/distinfo
  1.2       +1 -1      ports/devel/papi/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Martin Wilke freebsd_committer 2007-10-27 15:50:35 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!