Bug 117912 - [patch] chinese/hanzim: Fix segmentation fault caused by strcmp none exist variable
Summary: [patch] chinese/hanzim: Fix segmentation fault caused by strcmp none exist va...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Xin LI
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-08 09:20 UTC by Sunry Chen
Modified: 2007-12-11 21:10 UTC (History)
0 users

See Also:


Attachments
file.diff (1.46 KB, patch)
2007-11-08 09:20 UTC, Sunry Chen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sunry Chen 2007-11-08 09:20:01 UTC
Segmentation fault caused by strcmp none exist variable.

Fix: Judge if there's option before strcmp it.

Patch attached with submission follows:
How-To-Repeat: Just run it without any option.
Comment 1 Xin LI freebsd_committer 2007-12-11 21:03:29 UTC
Responsible Changed
From-To: freebsd-ports-bugs->delphij

Take.
Comment 2 dfilter service freebsd_committer 2007-12-11 21:08:56 UTC
delphij     2007-12-11 21:08:50 UTC

  FreeBSD ports repository

  Modified files:
    chinese/hanzim       Makefile 
    chinese/hanzim/files patch-hanzim.c 
  Log:
  Fix segmentation fault caused by strcmp() on nonexistent argv.
  
  Pass maintainership to submitter.
  
  PR:             117912
  Submitted by:   Sunry Chen <sunrychen at gmail.com>
  
  Revision  Changes    Path
  1.14      +6 -3      ports/chinese/hanzim/Makefile
  1.4       +3 -3      ports/chinese/hanzim/files/patch-hanzim.c
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Xin LI freebsd_committer 2007-12-11 21:09:03 UTC
State Changed
From-To: open->closed

Committed, thanks!