Bug 118372 - devel/STLport 5.1.4 port.
Summary: devel/STLport 5.1.4 port.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-01 15:40 UTC by Václav Haisman
Modified: 2007-12-23 17:10 UTC (History)
0 users

See Also:


Attachments
file.diff (42.62 KB, patch)
2007-12-01 15:40 UTC, Václav Haisman
no flags Details | Diff
stlport-5.1.4-port-merged.diff (46.40 KB, patch)
2007-12-08 11:13 UTC, Václav Haisman
no flags Details | Diff
patch-opencascade-LDOM_OSStream.hxx (424 bytes, text/plain)
2007-12-14 20:45 UTC, Václav Haisman
no flags Details
patch-opencascade-OSD_Environment.cxx (577 bytes, text/plain)
2007-12-14 20:45 UTC, Václav Haisman
no flags Details
patch-opencascade-Standard_MMgrOpt.cxx (718 bytes, text/plain)
2007-12-14 20:45 UTC, Václav Haisman
no flags Details
patch-opencascade-Standard_SStream.cxx (237 bytes, text/plain)
2007-12-14 20:45 UTC, Václav Haisman
no flags Details
opencascade-link-error.txt (5.36 KB, text/plain)
2007-12-14 20:45 UTC, Václav Haisman
no flags Details
stlport_PR118372.diff (45.84 KB, patch)
2007-12-17 20:29 UTC, Thierry Thomas
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Václav Haisman 2007-12-01 15:40:01 UTC
Updated STLport port.

Fix: Patch attached with submission follows:
Comment 1 Václav Haisman 2007-12-02 19:40:48 UTC
This is a multi-part message in MIME format.
Comment 2 Thierry Thomas freebsd_committer 2007-12-02 20:33:01 UTC
Hello,

I have been working on such an upgrade, with the following patch:

<http://people.freebsd.org/~thierry/ports/stlport.diff>

It includes a regression-test: target, which is running OK on i386, but
is eating all the available memory on amd64. Did you run these tests?

Regards,
-- 
Th. Thomas.
Comment 3 Václav Haisman 2007-12-02 21:32:43 UTC
Thierry Thomas wrote, On 2.12.2007 21:33:
> Hello,
> 
> I have been working on such an upgrade, with the following patch:
> 
> <http://people.freebsd.org/~thierry/ports/stlport.diff>
> 
> It includes a regression-test: target, which is running OK on i386, but
> is eating all the available memory on amd64. Did you run these tests?
> 
> Regards,
Hi,
I did run the tests but I have only i386 box to test with and I have not
noticed the behaviour you describe.

--
VH
Comment 4 Thierry Thomas freebsd_committer 2007-12-02 22:35:40 UTC
On Sun  2 dec 07 at 22:32:43 +0100, Václav Haisman <V.Haisman@sh.cvut.cz>
 wrote:

> Hi,
> I did run the tests but I have only i386 box to test with and I have not
> noticed the behaviour you describe.

Adding a regression-test: target to the port will let the tests run on
the packaging cluster for every platform.

Regards,
-- 
Th. Thomas.
Comment 5 Václav Haisman 2007-12-08 11:13:30 UTC

Thierry Thomas wrote, On 2.12.2007 23:35:
> On Sun  2 dec 07 at 22:32:43 +0100, Václav Haisman <V.Haisman@sh.cvut.cz>
>  wrote:
> 
>> Hi,
>> I did run the tests but I have only i386 box to test with and I have not
>> noticed the behaviour you describe.
> 
> Adding a regression-test: target to the port will let the tests run on
> the packaging cluster for every platform.
> 
> Regards,
I have merged regression-test and some other parts of your patch with mine.
Attached is the result.

--
VH
Comment 6 Václav Haisman 2007-12-12 07:50:25 UTC
Hi,
since the updated STLport would not work on AMD64 and there does not seem to
be anybody with the platform interested enough who could fix it, what about
create a new port devel/stlport5 instead and marking it broken on that
platform? Would this be feasible?

--
VH
Comment 7 Thierry Thomas freebsd_committer 2007-12-12 20:04:12 UTC
On Wed 12 dec 07 at 8:50:25 +0100, Václav Haisman <V.Haisman@sh.cvut.cz>
 wrote:
> Hi,

Hello,

> since the updated STLport would not work on AMD64 and there does not seem to
> be anybody with the platform interested enough who could fix it, what about
> create a new port devel/stlport5 instead and marking it broken on that
> platform? Would this be feasible?

Actually I have a problem with it even on i386: it breaks
cad/opencascade.

It needs some more investigations... I'm not sure that a repocopy to
devel/stlport5 would be a good solution, because our STLport-4.6.2 is
obsolete and unmaintained.

Best regards,
-- 
Th. Thomas.
Comment 8 Václav Haisman 2007-12-14 20:45:14 UTC

Thierry Thomas wrote, On 12.12.2007 21:04:
> On Wed 12 dec 07 at 8:50:25 +0100, Václav Haisman <V.Haisman@sh.cvut.cz>
>  wrote:
>> Hi,
> 
> Hello,
> 
>> since the updated STLport would not work on AMD64 and there does not seem to
>> be anybody with the platform interested enough who could fix it, what about
>> create a new port devel/stlport5 instead and marking it broken on that
>> platform? Would this be feasible?
> 
> Actually I have a problem with it even on i386: it breaks
> cad/opencascade.
> 
> It needs some more investigations... I'm not sure that a repocopy to
> devel/stlport5 would be a good solution, because our STLport-4.6.2 is
> obsolete and unmaintained.
> 
> Best regards,
Hi,
I investigated the Opencascade build problem and here are some patches that
get me rather far during its build. Unfortunately the build still fails, now
with a linker error. I have investigated it, too, and it seems that at some
point of compilation the _PTHREAD symbol is not defined (probably missing
-pthread on command line for GCC) and thus STLport headers use/define
stlpmtx_std namespace (STLport as not thread safe) instead of stlp_std. This
later shows as the link error because the STLport port is compiled as thread
safe.

I probably will try to fix this issue too but I am absolutely unfamiliar with
the Opencascade build process, so I would appreciate if you could look at the
issue, too.

--
VH
Comment 9 Thierry Thomas freebsd_committer 2007-12-17 20:29:58 UTC
On Sat  8 dec 07 at 12:13:30 +0100, Vaclav Haisman <V.Haisman@sh.cvut.cz>
 wrote:

> I have merged regression-test and some other parts of your patch with mine.
> Attached is the result.

Just a minor remark: the line

${TAR} -c -C "${PATCH_WRKSRC}/lib" -f - . | ${TAR} -xv -C "${PREFIX}/lib" -f -

set the ownership of ${PREFIX}/lib to the owner of the build. Then you
get the message:

===>   Running ldconfig
/sbin/ldconfig -m /usr/local/lib
ldconfig: /usr/local/lib: ignoring directory not owned by root

I propose the attched patch to fix this problem.

(Still working on OpenCascade...)

Best regards,
-- 
Th. Thomas.
Comment 10 Thierry Thomas freebsd_committer 2007-12-23 11:10:17 UTC
On Sat 15 dec 07 at 19:58:47 +0100, Thierry Thomas <thierry@FreeBSD.org>
 wrote:

> Many thanks for these patches!
> 
> I have already prepared some patches, and I'm going to merge your
> patches with mine, in order to solve this problem.


Well, finally I have a set of patches allowing to build cad/opencascade
with STLport 5.1.4 and on FreeBSD-7.

I have to add "-D_REENTRANT -D__unix" to build it against STLport 5.1.4;
since I guess that the same problem could occur with other programs, I
propose to add the following patch:

--- patch-stlport_stl_config_features.h begins here ---
--- ./stlport/stl/config/features.h.orig	2007-08-18 22:45:42.000000000 +0200
+++ ./stlport/stl/config/features.h	2007-12-23 11:18:22.000000000 +0100
@@ -218,7 +218,7 @@
 #endif
 
 /* Operating system recognition (basic) */
-#if defined (__unix) || defined (__linux__) || defined (__QNX__) || defined (_AIX)  || defined (__NetBSD__) || defined(__OpenBSD__) || defined (__Lynx__)
+#if defined (__unix) || defined (__linux__) || defined (__QNX__) || defined (_AIX)  || defined (__NetBSD__) || defined(__OpenBSD__) || defined (__Lynx__) || defined(__FreeBSD__)
 #  define _STLP_UNIX 1
 #elif defined(macintosh) || defined (_MAC)
 #  define _STLP_MAC  1
@@ -305,6 +305,7 @@
 #endif
 
 #if (defined (_REENTRANT) || defined (_THREAD_SAFE) || \
+    (defined (_POSIX_THREADS) && defined (__FreeBSD__)) && \
     (defined (_POSIX_THREADS) && defined (__OpenBSD__))) && \
     !defined (_STLP_THREADS)
 #  define _STLP_THREADS
--- patch-stlport_stl_config_features.h ends here ---

Best regards,
-- 
Th. Thomas.
Comment 11 dfilter service freebsd_committer 2007-12-23 17:00:42 UTC
thierry     2007-12-23 17:00:37 UTC

  FreeBSD ports repository

  Modified files:
    devel/stlport        Makefile distinfo pkg-descr pkg-plist 
  Added files:
    devel/stlport/files  
                         extra-patch-no-short-string-optim-user_config.h.diff 
                         extra-patch-ptr_spec-user_config.h.diff 
                         extra-patch-templ-expr-user_config.h.diff 
                         patch-stlport_stl_config_features.h 
                         patch-stlport_stl_config_host.h 
  Removed files:
    devel/stlport/files  patch-src::common_macros.mak 
                         patch-src::gcc-freebsd.mak 
                         patch-stlport::c_locale.h 
                         patch-stlport::config::stl_gcc.h 
                         patch-stlport::stdexcept 
                         patch-stlport::stl::_bvector.h 
                         patch-stlport::stl::_cwchar.h 
                         patch-stlport::stlcomp.h 
                         patch-test::eh::gcc-freebsd.mak 
                         src::icc-freebsd.mak stlport::stl_icc.h 
                         test::eh::icc-freebsd.mak 
  Log:
  Upgrade to 5.1.4 and unbreak.
  
  Changelog at
  <https://sourceforge.net/project/shownotes.php?group_id=146814&release_id=544939>
  
  PR:             ports/118372
  Submitted by:   Vaclav Haisman <v.haisman (at) sh.cvut.cz>
  
  Revision  Changes    Path
  1.43      +49 -55    ports/devel/stlport/Makefile
  1.9       +3 -3      ports/devel/stlport/distinfo
  1.1       +14 -0     ports/devel/stlport/files/extra-patch-no-short-string-optim-user_config.h.diff (new)
  1.1       +14 -0     ports/devel/stlport/files/extra-patch-ptr_spec-user_config.h.diff (new)
  1.1       +14 -0     ports/devel/stlport/files/extra-patch-templ-expr-user_config.h.diff (new)
  1.3       +0 -11     ports/devel/stlport/files/patch-src::common_macros.mak (dead)
  1.6       +0 -33     ports/devel/stlport/files/patch-src::gcc-freebsd.mak (dead)
  1.3       +0 -11     ports/devel/stlport/files/patch-stlport::c_locale.h (dead)
  1.6       +0 -43     ports/devel/stlport/files/patch-stlport::config::stl_gcc.h (dead)
  1.3       +0 -14     ports/devel/stlport/files/patch-stlport::stdexcept (dead)
  1.3       +0 -12     ports/devel/stlport/files/patch-stlport::stl::_bvector.h (dead)
  1.2       +0 -11     ports/devel/stlport/files/patch-stlport::stl::_cwchar.h (dead)
  1.3       +0 -12     ports/devel/stlport/files/patch-stlport::stlcomp.h (dead)
  1.1       +19 -0     ports/devel/stlport/files/patch-stlport_stl_config_features.h (new)
  1.1       +14 -0     ports/devel/stlport/files/patch-stlport_stl_config_host.h (new)
  1.6       +0 -27     ports/devel/stlport/files/patch-test::eh::gcc-freebsd.mak (dead)
  1.4       +0 -57     ports/devel/stlport/files/src::icc-freebsd.mak (dead)
  1.3       +0 -38     ports/devel/stlport/files/stlport::stl_icc.h (dead)
  1.4       +0 -76     ports/devel/stlport/files/test::eh::icc-freebsd.mak (dead)
  1.5       +5 -12     ports/devel/stlport/pkg-descr
  1.8       +307 -352  ports/devel/stlport/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 dfilter service freebsd_committer 2007-12-23 17:07:00 UTC
thierry     2007-12-23 17:06:55 UTC

  FreeBSD doc repository (ports committer)

  Modified files:
    en_US.ISO8859-1/articles/contributors contrib.additional.sgml 
  Log:
  Add an entry for Vaclav Haisman.
  
  PR:             ports/118372
  
  Revision  Changes    Path
  1.746     +5 -0      doc/en_US.ISO8859-1/articles/contributors/contrib.additional.sgml
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 13 Thierry Thomas freebsd_committer 2014-06-01 06:42:23 UTC
State Changed
From-To: open->feedback


I have uploaded a recapitulative patch at 
<http://people.freebsd.org/~thierry/ports/stlport.diff>. 

Do you agree with it? 



Comment 14 Thierry Thomas freebsd_committer 2014-06-01 06:42:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->thierry


Take it.
Comment 15 Thierry Thomas freebsd_committer 2014-06-01 06:42:23 UTC
State Changed
From-To: feedback->closed


Committed, thanks! 

Note: don't forget to submit the patches upstream.