Bug 118453 - Build of editors/OpenOffice.org-2 failed
Summary: Build of editors/OpenOffice.org-2 failed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-05 23:10 UTC by areilly
Modified: 2008-06-01 13:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description areilly 2007-12-05 23:10:02 UTC
	Build (using make install) stopped thusly:
/usr/ports/editors/openoffice.org-2/work/OOG680_m6/scripting/java
-------------
/usr/local/bin/ant -Dprj=.. -Dprjname=scripting -Ddebug=off -Doptimize=on  -Dtarget=scriptruntimeforjava -Dsolar.update=on -Dout=../unxfbsdx.pro -Dinpath=unxfbsdx.pro -Dproext=".pro"  -Dsolar.bin=/usr/ports/editors/openoffice.org-2/work/OOG680_m6/solver/680/unxfbsdx.pro/bin -Dsolar.jar=/usr/ports/editors/openoffice.org-2/work/OOG680_m6/solver/680/unxfbsdx.pro/bin -Dsolar.doc=/usr/ports/editors/openoffice.org-2/work/OOG680_m6/solver/680/unxfbsdx.pro/doc  -Dcommon.jar=/usr/ports/editors/openoffice.org-2/work/OOG680_m6/solver/680/unxfbsdx.pro/bin -Dcommon.doc=  -Dsolar.sourceversion=OOG680 -Dsolar.lastminor=m6  -Dsolar.build=9226 -f build.xml  -emacs
Buildfile: build.xml

BUILD FAILED
/usr/ports/editors/openoffice.org-2/work/OOG680_m6/scripting/java/build.xml:53: Syntax error in property: $(((e = $?)) && print $e\|)${USER:=$(ulimit -c 0; id -un 2>&- || \

Total time: 0 seconds
dmake:  Error code 1, while making 'ANTBUILD'
---* tg_merge.mk *---

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice.org-2/work/OOG680_m6/scripting/java
dmake:  Error code 1, while making 'build_instsetoo_native'
---*  *---
*** Error code 255

Stop in /usr/ports/editors/openoffice.org-2.

How-To-Repeat: 	Just wait for several hours after running make...
Comment 1 Edwin Groothuis freebsd_committer 2007-12-06 03:43:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 areilly 2007-12-22 06:14:40 UTC
Fixed: remove multi-line PS1 from shell environment.

build.xml:53 seems to suck in the environment, but does not seem
to take care to handle multi-line values, hence the reported
failure.  In this instance, I was running mksh (from ports),
and more-or-less the default .mkshrc, which includes a fancy,
13-line value for PS1
(see /usr/local/share/examples/mksh/dot.mkshrc from that port).

Setting PS1 to something simple allowed the build to proceed and
OpenOfice.org-2 has installed nicely.

I don't know enough about ant builds to say how this could have
been prevented in a more systematic fashion: using env -
somewhere in the build script, perhaps?

Cheers,

-- 
Andrew
Comment 3 Marcin Cieslak 2008-04-03 13:14:30 UTC
Can you check what ant version do you have?

I cannot reproduce it with ant 1.7.0_1.
-- 
              << Marcin Cieslak // saper@system.pl >>
Comment 4 areilly 2008-04-03 14:24:54 UTC
On Thu, 03 Apr 2008 14:14:30 +0200
Marcin Cieslak <saper@SYSTEM.PL> wrote:

> Can you check what ant version do you have?
> 
> I cannot reproduce it with ant 1.7.0_1.

Sorry, I have apache-ant-1.7.0_1 installed too, now, and I also
have openoffice 2.3 installed, so I suspect that this PR is well
and truly out of date.

I'll be giving it another go soon, I suspect, when the port gets
upgraded to 2.4.  I still have a hideous $PS1, so if the bug
persists, no doubt it'll bite me again.  Thank you for reminding
me, though.

Cheers,

-- 
Andrew
Comment 5 Martin Wilke freebsd_committer 2008-06-01 13:38:06 UTC
State Changed
From-To: open->closed

Close by submitter request.