Bug 118941 - sysutils/gnome-system-tools 2.20.0 won't build on FreeBSD 6.2 with GCC 3.4.6
Summary: sysutils/gnome-system-tools 2.20.0 won't build on FreeBSD 6.2 with GCC 3.4.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-21 22:40 UTC by Keith Gaughan
Modified: 2007-12-23 04:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gaughan 2007-12-21 22:40:01 UTC
[Kernel is a generic kernel with "options MSDOSFS_LARGE".]

Building fails with:

Making all in network
gmake[3]: Entering directory `/usr/ports/sysutils/gnome-system-tools/work/gnome-system-tools-2.20.0/src/network'
cc -DHAVE_CONFIG_H -I. -I../.. -D_THREAD_SAFE -DORBIT2=1 -D_REENTRANT -I/usr/local/include/gtk-2.0 -I/usr/local/lib/gtk-2.0/include -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/freetype2 -I/usr/local/include/libglade-2.0 -I/usr/local/include/libxml2 -I/usr/local/include/gconf/2 -I/usr/local/include/orbit-2.0 -I/usr/local/include/liboobs-1.0     -I../../src/common -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -DDBUS_API_SUBJECT_TO_CHANGE  -I/usr/local/include  -O2 -fno-strict-aliasing -pipe  -MT nm-integration.o -MD -MP -MF .deps/nm-integration.Tpo -c -o nm-integration.o nm-integration.c
In file included from network-tool.h:29,
                 from nm-integration.h:25,
                 from nm-integration.c:22:
locations-combo.h:53: error: syntax error before '*' token
In file included from network-tool.h:30,
                 from nm-integration.h:25,
                 from nm-integration.c:22:
connection.h:93: error: syntax error before '*' token
In file included from nm-integration.h:25,
                 from nm-integration.c:22:
network-tool.h:44: error: syntax error before "GstTool"
network-tool.h:71: error: syntax error before "GstToolClass"
network-tool.h:76: error: syntax error before '*' token
network-tool.h:76: warning: data definition has no type or storage class
gmake[3]: *** [nm-integration.o] Error 1
gmake[3]: Leaving directory `/usr/ports/sysutils/gnome-system-tools/work/gnome-system-tools-2.20.0/src/network'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/sysutils/gnome-system-tools/work/gnome-system-tools-2.20.0/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/sysutils/gnome-system-tools/work/gnome-system-tools-2.20.0'
gmake: *** [all] Error 2
*** Error code 2

Fix: 

Reading through the source, I couldn't see why it wasn't building and couldn't see any syntax errors or the reason behind any of the warnings, so I installed the gcc41 port (GCC 4.1.3), and built gnome-system-tools with it instead of the bundled version of GCC (3.4.6). This time around, it built successfully.
How-To-Repeat: cd /usr/ports/sysutils/gnome-system-tools
sudo make install
Comment 1 Edwin Groothuis freebsd_committer 2007-12-22 09:20:51 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Jeremy Messenger 2007-12-22 21:18:28 UTC
The pointyhat can't reproduce it to build with GCC 3.x. See here:

http://pointyhat.freebsd.org/errorlogs/i386-6-latest-logs/gnome-system-tools-2.20.0.log

The only difference is that pointyhat log is built on FreeBSD 6.3 while  
your is 6.2. Can you follow http://www.freebsd.org/gnome/docs/bugging.html  
? Thanks.

Cheers,
Mezz


-- 
mezz7@cox.net  -  mezz@FreeBSD.org
FreeBSD GNOME Team  -  FreeBSD Multimedia Hat (ports, not src)
http://www.FreeBSD.org/gnome/  -  gnome@FreeBSD.org
http://wiki.freebsd.org/multimedia  -  multimedia@FreeBSD.org
Comment 3 Jeremy Messenger freebsd_committer 2007-12-23 00:00:04 UTC
State Changed
From-To: open->feedback

Let me know if this patch solves your problem. 

http://people.freebsd.org/~mezz/diff/gnome-system-tools.diff
Comment 4 dfilter service freebsd_committer 2007-12-23 04:48:00 UTC
mezz        2007-12-23 04:47:50 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/gnome-system-tools Makefile 
  Added files:
    sysutils/gnome-system-tools/files patch-configure 
  Log:
  Fix the build when smalltalk (include/gst.h) is installed in system by reorder
  the -I/path/to stuff.
  
  PR:             ports/118941
  Reported by:    Keith Gaughan <keith.gaughan@gmail.com>
  
  Revision  Changes    Path
  1.27      +2 -1      ports/sysutils/gnome-system-tools/Makefile
  1.4       +11 -0     ports/sysutils/gnome-system-tools/files/patch-configure (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Jeremy Messenger freebsd_committer 2007-12-23 04:48:43 UTC
State Changed
From-To: feedback->closed

Committed a fix, thanks for report!