Bug 119674 - [new port] (resurrection) audio/paman
Summary: [new port] (resurrection) audio/paman
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Felippe de Meirelles Motta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-15 02:20 UTC by Romain Tartière
Modified: 2008-06-06 03:57 UTC (History)
0 users

See Also:


Attachments
paman.sh (1.75 KB, text/plain)
2008-01-15 02:20 UTC, Romain Tartière
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Romain Tartière 2008-01-15 02:20:01 UTC
	
On 2008-01-01, audio/paman was moved to audio/pavucontrol... But this
seems to be a mistake since these are two distinct projects [1,2]. I had
prepared a port some times ago and failed to see that paman was already
in the port tree (PR #115319).

I had pieces of that false-new-port left on my disk so I have updated it to
make it install the last paman version. I do not remember who was the
maintainer so I used my mail address as maintainer address.

Can we resurect paman?

References:
  1. http://0pointer.de/lennart/projects/paman/
  2. http://0pointer.de/lennart/projects/pavucontrol/
Comment 1 Marcelo Araujo freebsd_committer 2008-01-15 15:41:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->araujo

I'll take it.
Comment 2 araujobsdport 2008-01-20 12:30:41 UTC
Dear Romain,

We have an error in pkg-plist, can you fix it?

====================<phase 7: make package>====================
===>  Building package for paman-0.9.4
tar: paman.glade: Could not stat: No such file or directory
pkg_create: make_dist: tar command failed with code 256
Creating package /tmp/packages/All/paman-0.9.4.tbz
Registering depends: pulseaudio-0.9.8_1 libsamplerate-0.1.2_2 libsndfile-1.0.17_1 flac-1.1.2_2 libogg-1.1.3,4 gconf2-2.20.1 ORBit2-2.14.10 avahi-app-0.6.22_1 hal-0.5.8.20071224 policykit-0.1.20060514_4 libglademm-2.6.3_2 gtkmm-2.12.3 libIDL-0.8.9_1 libglade2-2.6.2 gtk-2.12.5 cairomm-1.2.4_1 libdaemon-0.12 shared-mime-info-0.23 liboil-0.3.12 libltdl-1.5.24 linc-1.0.3_6 libxml++-2.20.0 libvolume_id-0.75.0_1 dbus-glib-0.74 pango-1.18.4 fftw3-3.1.2 gcc-3.4.6_2,1 tiff-3.8.2_1 cairo-1.4.12 jpeg-6b_4 atk-1.20.0 glibmm-2.14.2,1 python25-2.5.1_1 dbus-1.0.2_2 gnomehier-2.3_10 hicolor-icon-theme-0.10_2 pciids-20080109 glib-2.14.5 gdbm-1.8.3_3 pcre-7.4 xorg-fonts-truetype-7.3 dmidecode-2.9 gnome_subr-1.0 libsigc++-2.0.18 libxml2-2.6.30 font-bh-ttf-1.0.0 font-misc-ethiopic-1.0.0 gettext-0.16.1_3 xmlcatmgr-2.2 font-misc-meltho-1.0.0_1 encodings-1.0.2,1 xorg-libraries-7.3_1 libXfont-1.3.1_1,1 libFS-1.0.0 font-util-1.0.1 libXfontcache-1.0.4 bitstream-vera-1.10_4 fontsproto-2.0.2 mkfontscale-1.0.3 libfontenc-1.0.4 fontcacheproto-0.1.2 libXft-2.1.12 mkfontdir-1.0.3 fontconfig-2.4.2_2,1 libXaw-1.0.4,1 expat-2.0.0_1 perl-5.8.8_1 libiconv-1.11_1 libXmu-1.0.3,1 libXTrap-1.0.0 libXpm-3.5.7 png-1.2.23_1 libXcomposite-0.4.0,1 libXdamage-1.1.1 libXcursor-1.1.9 libXScrnSaver-1.1.2 libXevie-1.0.2 libXprintAppUtil-1.0.1 libXprintUtil-1.0.1 libXi-1.1.3,1 libXfixes-4.0.3 libXinerama-1.0.2,1 libXp-1.0.0,1 compositeproto-0.4 fixesproto-4.0 damageproto-1.1.0_2 libXrandr-1.2.2 libxkbui-1.0.2 libXres-1.0.3_2 libXrender-0.9.4 libXtst-1.0.3 trapproto-3.4.3 libXvMC-1.0.4 libXt-1.0.5 libXv-1.0.3,1 libXxf86dga-1.0.2 libXxf86misc-1.0.1 libXxf86vm-1.0.1 libdmx-1.0.2 libXext-1.0.3,1 liboldX-1.0.1 libxkbfile-1.0.4 libX11-1.1.3,1 inputproto-1.4.2.1 libXdmcp-1.0.2 kbproto-1.0.3 libXau-1.0.3_2 libSM-1.0.3,1 pixman-0.9.6 libICE-1.0.4,1 printproto-1.0.3 randrproto-1.2.1 recordproto-1.13.2 renderproto-0.9.3 scrnsaverproto-1.1.0 freetype2-2.3.5 videoproto-2.2.2 xbitmaps-1.0.1 xextproto-7.0.2 xf86dgaproto-2.0.3 xf86miscproto-0.9.2 xf86vidmodeproto-2.2.2 xineramaproto-1.1.2 xproto-7.0.10_1 xtrans-1.0.4 pkg-config-0.22_1.
Creating bzip'd tar ball in '/tmp/packages/All/paman-0.9.4.tbz'
*** Error code 1


Best Regards,

-- 
Marcelo Araujo            (__)
araujo@FreeBSD.org     \\\'',)
http://www.FreeBSD.org   \/  \ ^
Power To Server.         .\. /_)

Comment 3 Romain Tartière 2008-01-21 13:27:35 UTC
Hello

On Sun, 20 Jan 2008 10:30:41 -0200, Marcelo Araujo wrote:
> We have an error in pkg-plist, can you fix it?

Hum... I cannot reproduce this of any of my boxes, and cannot figure out
what is going wrong :-(

paman.glade is installed in /usr/local/share/paman/paman.glade and
refered to as %%DATADIR%%/paman.glade in the pkg-plist, and that look
good AFAIK...

Can you please tell me if the file is installed where it should be? Can
you also provide a little bit more context such as the output of the
build / installation?

Thank you!

Regards,
Romain

-- 
Romain Tartière <romain@blogreen.org>        http://romain.blogreen.org/
pgp: 8DAB A124 0DA4 7024 F82A  E748 D8E9 A33F FF56 FF43 (ID: 0xFF56FF43)
(plain text =non-HTML= PGP/GPG encrypted/signed e-mail much appreciated)
Comment 4 Marcelo Araujo freebsd_committer 2008-01-27 15:22:36 UTC
State Changed
From-To: open->feedback

I spoke in private mail with Romain about the problems and I'm waiting a 
feedback.
Comment 5 Romain Tartière 2008-01-31 00:01:08 UTC
On Sun, Jan 27, 2008 at 03:22:44PM +0000, araujo@FreeBSD.org wrote :
> I spoke in private mail with Romain about the problems and I'm waiting
> a feedback.


Building this port from 5.5, 6.0, 6.1, 6.2, 6.3 tinderboxes does not
raised the previously seen error but revealed that the pkg-plist was
incomplete.

The following patch fixes the pkg-plist:

--- patch-paman-pkg-plist begins here ---
Index: paman/pkg-plist
===================================================================
--- paman/pkg-plist	(révision 40)
+++ paman/pkg-plist	(copie de travail)
@@ -2,3 +2,4 @@
 share/applications/paman.desktop
 %%DATADIR%%/paman.glade
 @dirrm %%DATADIR%%
+@dirrmtry share/applications
--- patch-paman-pkg-plist ends here ---

-- 
Romain Tartière <romain@blogreen.org>        http://romain.blogreen.org/
pgp: 8DAB A124 0DA4 7024 F82A  E748 D8E9 A33F FF56 FF43 (ID: 0xFF56FF43)
(plain text =non-HTML= PGP/GPG encrypted/signed e-mail much appreciated)
Comment 6 Marcelo Araujo freebsd_committer 2008-02-25 19:42:37 UTC
State Changed
From-To: feedback->open

Feedback received! Thanks.
Comment 7 Marcelo Araujo freebsd_committer 2008-05-09 02:10:20 UTC
Responsible Changed
From-To: araujo->lippe

Lippe would like to work in this pr. Over to lippe.
Comment 8 Felippe de Meirelles Motta freebsd_committer 2008-05-09 06:10:20 UTC
Hi all,

It seems that are an front-end to the old polypaudio, however, this
has been renamed to pulseaudio, thus I not see because we should
resuscitate this.

What you think ?

-- 
lippe@FreeBSD.org
Felippe de Meirelles Motta
Comment 9 Romain Tartière 2008-05-09 08:20:43 UTC
Hi

On Fri, May 09, 2008 at 02:10:20AM -0300, Felippe de Meirelles Motta wrote:
> It seems that are an front-end to the old polypaudio, however, this
> has been renamed to pulseaudio, thus I not see because we should
> resuscitate this.


As you can see on the paman webpage [1], "PulseAudio Manager (paman) is
a simple GTK frontend for the PulseAudio sound server". Although there
are references to PolyAudio, it is only old ChangeLog entries, when
PulseAudio was called PolyAudio: since 0.9.2, paman use PulseAudio.

Moreover, paman is listed just as pavumeter, pavucontrol and others in
PulseAudio's related software [2].

Not mentioning how useful it is when you have more than one PulseAudio
server on your network and want a quick user friendly interface to
configure and switch resources.

So, IMHO, this port is definitively a must have for the FreeBSD ports
tree :-)

Regards.
Romain

References:
  1. http://0pointer.de/lennart/projects/paman/
  2. http://www.pulseaudio.org/wiki/AboutPulseAudio#RelatedSoftware

-- 
Romain Tartière <romain@blogreen.org>        http://romain.blogreen.org/
pgp: 8DAB A124 0DA4 7024 F82A  E748 D8E9 A33F FF56 FF43 (ID: 0xFF56FF43)
(plain text =non-HTML= PGP/GPG encrypted/signed e-mail much appreciated)
Comment 10 Felippe de Meirelles Motta freebsd_committer 2008-05-09 10:57:39 UTC
Hi Submitter,

Yes, you're sure, thanks to explain us! I'll work to resuscitate him
this week, if possible.

Thanks!

-- 
lippe@FreeBSD.org
Felippe de Meirelles Motta
Comment 11 araujobsdport 2008-05-09 12:00:34 UTC
Felippe de Meirelles Motta wrote:
> Hi all,
>
> It seems that are an front-end to the old polypaudio, however, this
> has been renamed to pulseaudio, thus I not see because we should
> resuscitate this.
>
> What you think ?
>
>   
Well,

The booth projects are different.


Kind Regards,

-- 
Marcelo Araujo            (__)
araujo@FreeBSD.org     \\\'',)
http://www.FreeBSD.org   \/  \ ^
Power To Server.         .\. /_)
Comment 12 araujobsdport 2008-05-09 12:01:38 UTC
Romain Tartière wrote:
> Hi
>
> On Fri, May 09, 2008 at 02:10:20AM -0300, Felippe de Meirelles Motta wrote:
>   
>> It seems that are an front-end to the old polypaudio, however, this
>> has been renamed to pulseaudio, thus I not see because we should
>> resuscitate this.
>>     
>
> As you can see on the paman webpage [1], "PulseAudio Manager (paman) is
> a simple GTK frontend for the PulseAudio sound server". Although there
> are references to PolyAudio, it is only old ChangeLog entries, when
> PulseAudio was called PolyAudio: since 0.9.2, paman use PulseAudio.
>
> Moreover, paman is listed just as pavumeter, pavucontrol and others in
> PulseAudio's related software [2].
>
> Not mentioning how useful it is when you have more than one PulseAudio
> server on your network and want a quick user friendly interface to
> configure and switch resources.
>
> So, IMHO, this port is definitively a must have for the FreeBSD ports
> tree :-)
>
> Regards.
> Romain
>
> References:
>   1. http://0pointer.de/lennart/projects/paman/
>   2. http://www.pulseaudio.org/wiki/AboutPulseAudio#RelatedSoftware
>
>   

Hi dear Romain,

Thanks again by the explanation and sorry my late.



Best Regards,

-- 
Marcelo Araujo            (__)
araujo@FreeBSD.org     \\\'',)
http://www.FreeBSD.org   \/  \ ^
Power To Server.         .\. /_)

Comment 13 dfilter service freebsd_committer 2008-06-06 03:47:27 UTC
lippe       2008-06-06 02:47:23 UTC

  FreeBSD ports repository

  Modified files:
    .                    UPDATING MOVED 
    audio                Makefile 
  Added files:
    audio/paman          Makefile distinfo pkg-descr pkg-plist 
  Log:
  On 2008-01-01, audio/paman was moved to audio/pavucontrol. But this seems to be a mistake since these are two distinct projects.
  
  PulseAudio Manager (paman) is a simple GTK frontend for the PulseAudio sound server.
  
  WWW: http://0pointer.de/lennart/projects/paman/
  
  PR:             ports/119674
  Submitted by:   Romain Tartiere <romain@blogreen.org>
  Approved by:    gabor (mentor)
  
  Revision  Changes    Path
  1.1607    +1 -2      ports/MOVED
  1.639     +10 -1     ports/UPDATING
  1.960     +1 -0      ports/audio/Makefile
  1.10      +25 -0     ports/audio/paman/Makefile (new)
  1.4       +3 -0      ports/audio/paman/distinfo (new)
  1.3       +4 -0      ports/audio/paman/pkg-descr (new)
  1.1       +5 -0      ports/audio/paman/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 Felippe de Meirelles Motta freebsd_committer 2008-06-06 03:57:38 UTC
State Changed
From-To: open->closed

Committed. Thanks!