Bug 119809 - [virtualpc] MS Virtual PC 2007 - Install hung - Trying to mount root from ufs:/dev/md0
Summary: [virtualpc] MS Virtual PC 2007 - Install hung - Trying to mount root from ufs...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: 6.3-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-19 19:20 UTC by Michael Faklis
Modified: 2017-12-31 22:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Faklis 2008-01-19 19:20:01 UTC
I can't boot from CD (ISO image) to install 6.3 on a new virtual machine.
I hang with a message:

 Trying to mount root from ufs:/dev/md0

I've tried both the disk1 image and the bootonly image.
These are the latest images downloaded last night, with no modifications.

Researching with google, I see that some have had this problem in the past,
but I had not seen it with 6.0 or 6.2.  

How do I proceed?

Fix: 

unknown
How-To-Repeat: It's completely repeatable, following the handbook instructions on building
a virtual guest using Microsoft Virtual PC.
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2008-01-27 16:08:04 UTC
State Changed
From-To: open->feedback

How long does the machine hang for?  Have you tried waiting say 10 
minutes?  I suspect you are seeing the same problem as is in  
PR kern/91476.  Can you try disabling the floppy controller from the 
loader with 
set hint.fdc.0.disabled="1" 
and seeing if that makes any difference? 


Comment 2 Gavin Atkinson freebsd_committer freebsd_triage 2008-01-27 16:08:04 UTC
Responsible Changed
From-To: freebsd-i386->gavin

Track
Comment 3 Gavin Atkinson freebsd_committer freebsd_triage 2008-03-04 17:26:48 UTC
On Tue, 2008-03-04 at 08:43 -0800, Michael Faklis wrote:
> Hope all is going well.  I've learned so much more about FreeBSD since this
> last email, but not enough to diagnose the problem with v6.3 installing on
> Microsoft Virtual PC.  Were you able to figure what's happening with this
> problem?

Sorry, I haven't had a chance yet - I ran out of disk space aand haven't
had time to move enough stuff around to make room for a virtual machine.

If you want to have a go yourself, possibly the easiest thing to do will
be to install 6.2 onto the machine, and try to establish when the
breakage began.  With the following cvsup file:

--------------------------------------
*default host=cvsup3.freebsd.org
*default base=/usr
*default prefix=/usr
*default release=cvs tag=RELENG_6
*default delete use-rel-suffix
*default date=2007.04.01.00.40.00
src-all
-------------------------------------

update your source, recompile the kernel, and see if the new one boots.
If it does, go forward another four months and see if that one boots,
etc.  If not, go back a month or two.  Within a small number of
recompiles, you'll probably be able to narrow the change that breaks
things for you.  Depending on how much effort you want to put in, you
should be able to narrow it down to a particular 10 minute or so window
- and have a list of the commits in that time to look at.  This is
basically what I was planning on doing.

Out of interest, once hung, does capslock still work on the keyboard?
If so, you could also try compiling ddb into the kernel and when the
machine hangs, press ctrl-alt-escape to drop to the debugger.  Athough,
I'm pretty sure when I recreated the issue, the keyboard was
unresponsive.

Gavin
Comment 4 Gavin Atkinson freebsd_committer freebsd_triage 2008-03-04 17:27:02 UTC
State Changed
From-To: feedback->open

Am working with submitter on this one
Comment 5 Gavin Atkinson freebsd_committer freebsd_triage 2008-04-15 12:52:48 UTC
So I can keep track of things:
  2007.07.12.00.00.00 boots fine
  2007.09.12.00.00.00 boots fine
  2007.11.01.00.00.00 boots fine
  2007.12.01.00.00.00
Comment 6 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:37 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped