Bug 120173 - Prevent ports mail/mailman zombieing remote servers/
Summary: Prevent ports mail/mailman zombieing remote servers/
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Chris Rees
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-30 23:40 UTC by jhs
Modified: 2011-06-26 08:30 UTC (History)
1 user (show)

See Also:


Attachments
file.shar (33.13 KB, text/plain)
2008-01-30 23:40 UTC, jhs
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jhs 2008-01-30 23:40:01 UTC
	An agressive 5 minute killer python loop
	in /var/cron/tanbs/mailman has been killing my hosts for 5 years.
	I reported it before by dmesg, expired. Now heres fixes,
	further comment by others inside them.

	
	See fixes

Fix: Latest copy here
	http://berklix.com/~jhs/public_html/src/bsd/fixes/FreeBSD/ports/gen/mail/mailman/files/
But I append a shar in case anyone reading off line:
How-To-Repeat: 	
	Install mailman on a 686 300M Hz remote server, & wait for
	it to gradually become a zombie that times out ssh before
	you can get it in to fix it, if you dont notice fast enough
	the pythons strangling your server..
Comment 1 Edwin Groothuis freebsd_committer 2008-01-30 23:40:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->jmelo

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2010-06-19 05:27:56 UTC
Responsible Changed
From-To: jmelo->freebsd-ports-bugs

Maintainer was reset.
Comment 3 Wesley Shields freebsd_committer 2010-06-19 12:57:47 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wxs

I'm the new maintainer, hopefully I can work on these.
Comment 4 Chris Rees freebsd_committer 2011-06-18 14:22:14 UTC
Responsible Changed
From-To: wxs->crees

Relieve wxs of mailman
Comment 5 Chris Rees freebsd_committer 2011-06-18 14:26:54 UTC
Hey,

Can you still reproduce this?

Chris
Comment 6 Chris Rees freebsd_committer 2011-06-18 14:27:25 UTC
State Changed
From-To: open->feedback

Confirm freshness
Comment 7 jhs 2011-06-20 00:59:56 UTC
crees@FreeBSD.org wrote:
> Synopsis: Prevent ports mail/mailman zombieing remote servers/
> 
> State-Changed-From-To: open->feedback
> State-Changed-By: crees
> State-Changed-When: Sat Jun 18 13:27:25 UTC 2011
> State-Changed-Why: 
> Confirm freshness
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=120173

Hi Chris,
Thanks for this weekend (Sat Jun 18 13:22:14 UTC 2011) taking on mailman.

Reading
  http://berklix.com/~jhs/src/bsd/fixes/FreeBSD/ports/gen/mail/mailman/files/\
  patch-crontab.in.in.REL=ALL
I first saw this bug back in 2003,
	Comment out gate_news by default, to match
	the admin web page, which also has news gating off by default.

I filed bug fix 3.5 years ago, marked Priority. FreeBSD did nothing.

send-pr:
	An agressive 5 minute killer python loop in
	/var/cron/tanbs/mailman has been killing my hosts for 5
	years.  I reported it before by dmesg, expired. Now heres
	fixes, further comment by others inside them.

FreeBSD.Org never really needed my particular server to test it.  Its a
bug that's always been readable after 'make install', just not noticed
except on slower/ or loaded hardware.

My send-pr lists the problem as triggered by:
  0,5,10,15,20,25,30,35,40,45,50,55 * * * * @PYTHON@ -S @prefix@/cron/gate_news

I just (Sun 19 Jun 2011) reinstalled mailman on another host built from 
src=8.2, ports={current from a few days back}, & see the same
 /usr/ports/mail/mailman/work/mailman-2.1.14/cron/crontab.in.in
  0,5,10,15,20,25,30,35,40,45,50,55 * * * * @PYTHON@ -S @prefix@/cron/gate_news
 & /var/cron/tabs/mailman
  0,5,10,15,20,25,30,35,40,45,50,55 * * * * /usr/local/bin/python2.7 \
	 -S /usr/local/mailman/cron/gate_news
The same problem cause lurks there, 

/usr/local/share/doc/mailman/NEWS claims:
	2.0 beta 2 (07-Apr-2000) ... Rewritten gate_news cron script
	.... to avoid flooding the mailing list
Dosen't sound like the same system killer bug they rewrote to avoid,
but I don't know.

Last time it locked up my servers, mailman stole so much CPU none
was left for sshd, & being remote I couldn't reset. Now those servers
have been removed from internet & local, so safer to test, as no
chance of remote lock up, but harder to simulate problem with mail
as not on net.  I'm also not sure they have same uname -r, as back
then.  one since somewhat unreliable hardware I think,

I could in theory go to a lot of work to upgrade both hosts from
6.whatever to 8.2, just to try to crash them again, like it already
crashed from 2003 to 2008 onward, but not much incentive.

That gate_news was a system killer ... a lot of dont even use news,
(I havent in years) ... dont need gate_news on by default ...
Better we either:
-  Patch FreeBSD (& latter generic mailman) so gate_news is commented off
   by default, just as mailman admin manual apparently falsely
   claimed it was off, when it was not, way back to 2003.
- or make it every 15 mins not 5 mins
- or you could refer it to mailman generic team for comment

Cheers,
Julian
-- 
Julian Stacey, BSD Unix Linux C Sys Eng Consultants Munich http://berklix.com
 Reply below, not above;  Indent with "> ";  Cumulative like a play script.
 Format: Plain text. Not HTML, multipart/alternative, base64, quoted-printable.
Comment 8 Chris Rees freebsd_committer 2011-06-21 17:06:14 UTC
On 20 June 2011 00:59, Julian H. Stacey <jhs@berklix.com> wrote:
>
> Hi Chris,
> Thanks for this weekend (Sat Jun 18 13:22:14 UTC 2011) taking on mailman.

Hey Julian,

I hope there's not been any confusion here -- I'm afraid my intention
with mailman was just to fix the collateral that I'd created when I
converted it to USERS; my hands are full with sympa right now and I
think it's a bad idea to maintain software I don't use.

Would you like to take on maintainership of this port, and chase this
up? If not, I'll ask Guido Falsi who also seems interested....

Chris
Comment 9 jhs 2011-06-24 00:54:21 UTC
Hi Chris,
Chris Rees wrote:
> On 20 June 2011 00:59, Julian H. Stacey <jhs@berklix.com> wrote:
> >
> > Hi Chris,
> > Thanks for this weekend (Sat Jun 18 13:22:14 UTC 2011) taking on mailman.
> 
> Hey Julian,
> 
> I hope there's not been any confusion here -- I'm afraid my intention
> with mailman was just to fix the collateral that I'd created when I
> converted it to USERS; my hands are full with sympa right now and I
> think it's a bad idea to maintain software I don't use.

I've not run mailman since it locked up my servers & I filed a fix.
So I want to run mailman on berklix.org servers again.
	As majordomo is problematic for users on some of my lists,
	who don't know how to mail plain text, & don't understand
	my majordomo run lists auto discard HTML, as that usually
	drags in MIME seperators, which breaks majordomo footers,
	which tell readers how to sub/unsub (for those who dont
	know how to read headers where it's also stated)
	http://www.berklix.org/robot/majordomo/#format
	http://www.berklix.org/robot/majordomo/#terminal_mime_boundary


> Would you like to take on maintainership of this port, and chase this
> up? If not, I'll ask Guido Falsi who also seems interested....

I'm willing if need be.
But if Guido is running mailman lists already, he may be more appropriate ?  
Or as mailman is in heavy constant use by freebsd.org,
perhaps consider one of postmaster/webmaster team ?
Addreses here http://www.freebsd.org/administration.html#t-postmaster

Cheers,
Julian
-- 
Julian Stacey, BSD Unix Linux C Sys Eng Consultants Munich http://berklix.com
 Reply below, not above;  Indent with "> ";  Cumulative like a play script.
 Format: Plain text. Not HTML, multipart/alternative, base64, quoted-printable.
Comment 10 dfilter service freebsd_committer 2011-06-26 08:27:21 UTC
crees       2011-06-26 07:27:12 UTC

  FreeBSD ports repository

  Modified files:
    mail/mailman         Makefile 
  Log:
  - Disable gate news by default to prevent lockups on slower machines
  
  PR:             ports/120173
  Submitted by:   "Julian H. Stacey" <jhs@berklix.org>
  Approved by:    rene (mentor)
  
  Revision  Changes    Path
  1.92      +2 -1      ports/mail/mailman/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 Chris Rees freebsd_committer 2011-06-26 08:27:22 UTC
State Changed
From-To: feedback->closed

Committed, with minor changes. Thanks!