Bug 120381 - Update port: audio/amarok - use libvisual
Summary: Update port: audio/amarok - use libvisual
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Michael Landin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-08 02:20 UTC by Björn König
Modified: 2008-02-21 15:40 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn König 2008-02-08 02:20:00 UTC
	Compile Amarok with libvisual support optionally. Install
	graphics/libvisual04-plugins (pending PR: ports/120380)
	manually to get some example plugins.

How-To-Repeat: 
--- ports-audio-amarok.diff begins here ---
diff -ruN ports/audio/amarok.orig/Makefile ports/audio/amarok/Makefile
--- ports/audio/amarok.orig/Makefile	2008-02-05 17:44:56.000000000 +0000
+++ ports/audio/amarok/Makefile	2008-02-08 01:59:32.000000000 +0000
@@ -28,11 +28,13 @@
 USE_SDL=	sdl
 USE_RUBY=	yes
 USE_LDCONFIG=	yes
+USE_GNOME=	
 INSTALLS_ICONS=	yes
 
 OPTIONS=	GPOD "iPod support" on \
 		NJB "Creative Nomad and Dell support" on \
 		MTP "MTP device support" on \
+		VISUAL "libvisual support" off \
 		OPENGL "OpenGL support" on \
 		AMAZON "Amazon cover fetching support" on \
 		MYSQL "Use MySQL as collection backend" off \
@@ -43,8 +45,7 @@
 
 CONFIGURE_ARGS+=--without-exscalibar \
 		--with-mp4v2 \
-		--with-mp4v2-dir=${PREFIX} \
-		--without-libvisual
+		--with-mp4v2-dir=${PREFIX}
 
 .if !defined(WITH_GPOD)
 PLIST_SUB+=	GPOD="@comment "
@@ -71,6 +72,13 @@
 PLIST_SUB+=	MTP=""
 .endif
 
+.if defined(WITHOUT_LIBVISUAL)
+CONFIGURE_ARGS+=--without-libvisual
+.else
+LIB_DEPENDS+=	visual-0.4:${PORTSDIR}/graphics/libvisual04
+USE_GNOME+=	gnomelibs
+.endif
+
 .if defined(WITHOUT_OPENGL)
 CONFIGURE_ARGS+=--without-opengl
 .endif
--- ports-audio-amarok.diff ends here ---
Comment 1 Edwin Groothuis freebsd_committer 2008-02-08 02:20:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mich

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2008-02-21 10:06:32 UTC
mich        2008-02-21 10:06:25 UTC

  FreeBSD ports repository

  Modified files:
    audio/amarok         Makefile 
  Log:
  - add option to compile with libvisual support
  
  PR:             ports/120381
  Submitted by:   Björn Kön <bkoenig@alpha-tierchen.de>
  
  Revision  Changes    Path
  1.79      +10 -2     ports/audio/amarok/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Michael Landin freebsd_committer 2008-02-21 10:06:50 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 4 Robert Gogolok 2008-02-21 10:33:08 UTC
So if VISUAL support is off by default (VISUAL "libvisual support" off), you 
will need WITH_LIBVISUAL to enable it and not WITHOUT_LIBVISUAL!
Comment 5 Björn König 2008-02-21 12:17:04 UTC
> So if VISUAL support is off by default (VISUAL "libvisual support" off),
> you will need WITH_LIBVISUAL to enable it and not WITHOUT_LIBVISUAL!

The options framework defines always(!) exactly one of both: either
WITH_LIBVISUAL or WITHOUT_LIBVISUAL.

So if defined(WITHOUT_LIBVISUAL) is not true, then we know that
defined(WITH_LIBVISUAL) is true, but we don't need to check this
additionally.

Björn
Comment 6 Robert Gogolok 2008-02-21 12:38:25 UTC
On Thursday 21 February 2008 13:17:04 Bj=F6rn K=F6nig wrote:
> > So if VISUAL support is off by default (VISUAL "libvisual support" off),
> > you will need WITH_LIBVISUAL to enable it and not WITHOUT_LIBVISUAL!
>
> The options framework defines always(!) exactly one of both: either
> WITH_LIBVISUAL or WITHOUT_LIBVISUAL.
>
> So if defined(WITHOUT_LIBVISUAL) is not true, then we know that
> defined(WITH_LIBVISUAL) is true, but we don't need to check this
> additionally.
Right.
So VISUAL support is on by default in this case (and not off!).

=2DLIBVISUAL "libvisual support" off \
+LIBVISUAL "libvisual support" on \
Comment 7 Björn König 2008-02-21 13:26:18 UTC
No, it's off.

# cd /usr/ports/audio/amarok
# make rmconfig
===> Removing user-configured options for amarok-1.4.8
# make all-depends-list | grep -c libvisual
0
# make -DWITH_LIBVISUAL all-depends-list | grep -c libvisual
1

Björn
Comment 8 Michael Landin freebsd_committer 2008-02-21 13:43:01 UTC
On Feb 21, 2008, at 1:38 PM, Robert Gogolok wrote:

> On Thursday 21 February 2008 13:17:04 Bj=F6rn K=F6nig wrote:
>>> So if VISUAL support is off by default (VISUAL "libvisual support" =20=

>>> off),
>>> you will need WITH_LIBVISUAL to enable it and not WITHOUT_LIBVISUAL!
>>
>> The options framework defines always(!) exactly one of both: either
>> WITH_LIBVISUAL or WITHOUT_LIBVISUAL.
>>
>> So if defined(WITHOUT_LIBVISUAL) is not true, then we know that
>> defined(WITH_LIBVISUAL) is true, but we don't need to check this
>> additionally.
> Right.
> So VISUAL support is on by default in this case (and not off!).
>
> -LIBVISUAL "libvisual support" off \
> +LIBVISUAL "libvisual support" on \

No.

Try to run 'make' on the port - without changing the default settings:
root@mich2 ports/amarok# make showconfig
=3D=3D=3D> The following configuration options are available for =
amarok-1.4.8:
      GPOD=3Don "iPod support"
      NJB=3Don "Creative Nomad and Dell support"
      MTP=3Don "MTP device support"
      LIBVISUAL=3Doff "libvisual support"
      OPENGL=3Don "OpenGL support"
      AMAZON=3Don "Amazon cover fetching support"
      MYSQL=3Doff "Use MySQL as collection backend"
      POSTGRESQL=3Doff "Use PostgreSQL as collection backend"
      HIDEMENUBAR=3Doff "Revert the 'Hide Menubar' feature"
=3D=3D=3D> Use 'make config' to modify these settings


<snip>
  =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D
  =3D=3D=3D  Amarok - PLUGINS  =20
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D
  =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D
  =3D
  =3D The following extra functionality will NOT be included:
  =3D   - NMM-engine
  =3D   - Helix-engine
  =3D   - yauap-engine
  =3D   - libvisual Support        <---------- NOTE
  =3D   - MySql Support
  =3D   - Postgresql Support
  =3D   - iRiver iFP Support
  =3D   - Rio Karma Support
  =3D
  =3D The following extra functionality will be included:
  =3D   + xine-engine
  =3D   + Konqueror Sidebar
  =3D   + MusicBrainz Support
  =3D   + MP4/AAC Tag Write Support
  =3D   + iPod Support
  =3D   + Creative Nomad Jukebox Support
  =3D   + MTP Device Support
  =3D   + DAAP Music Sharing Support
  =3D
  =20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
</snip>



and when you enable libvisual support:

mich@mich2 ports/amarok> make showconfig
=3D=3D=3D> The following configuration options are available for =
amarok-1.4.8:
      GPOD=3Don "iPod support"
      NJB=3Don "Creative Nomad and Dell support"
      MTP=3Don "MTP device support"
      LIBVISUAL=3Don "libvisual support"
      OPENGL=3Don "OpenGL support"
      AMAZON=3Don "Amazon cover fetching support"
      MYSQL=3Doff "Use MySQL as collection backend"
      POSTGRESQL=3Doff "Use PostgreSQL as collection backend"
      HIDEMENUBAR=3Doff "Revert the 'Hide Menubar' feature"
=3D=3D=3D> Use 'make config' to modify these settings



<snip>
  =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D
  =3D=3D=3D  Amarok - PLUGINS  =20
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D
  =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D
  =3D
  =3D The following extra functionality will NOT be included:
  =3D   - NMM-engine
  =3D   - Helix-engine
  =3D   - yauap-engine
  =3D   - MySql Support
  =3D   - Postgresql Support
  =3D   - iRiver iFP Support
  =3D   - Rio Karma Support
  =3D
  =3D The following extra functionality will be included:
  =3D   + xine-engine
  =3D   + libvisual Support	 <--------------------------- NOTE
  =3D   + Konqueror Sidebar
  =3D   + MusicBrainz Support
  =3D   + MP4/AAC Tag Write Support
  =3D   + iPod Support
  =3D   + Creative Nomad Jukebox Support
  =3D   + MTP Device Support
  =3D   + DAAP Music Sharing Support
  =3D
  =20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=20
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

</snip>


This is, in my opinion, expected behavior. On another note - I do test =20=

the ports before committing, so please try to compile amarok (with and =20=

without libvisual support) before continuing this thread.

Thanks,


/mich
Comment 9 Robert Gogolok 2008-02-21 13:53:04 UTC
> This is, in my opinion, expected behavior. On another note - I do test
> the ports before committing, so please try to compile amarok (with and
> without libvisual support) before continuing this thread.
I build amarok with tinderbox.

Set
PACKAGE_BUILDING=yes
in your /etc/make.conf

Run afterwards
make all-depends-list
and you will see that libvisual is enabled as dependency although it should be 
disabled.

The logic in the Makefile is wrong!
Comment 10 Robert Gogolok 2008-02-21 13:58:54 UTC
So I will shut up and fill a PR if I have a prove. Sorry...
Comment 11 Michael Landin freebsd_committer 2008-02-21 14:32:08 UTC
On Feb 21, 2008, at 14:53, Robert Gogolok <gogo@cs.uni-sb.de> wrote:

>> This is, in my opinion, expected behavior. On another note - I do  
>> test
>> the ports before committing, so please try to compile amarok (with  
>> and
>> without libvisual support) before continuing this thread.
> I build amarok with tinderbox.
>
> Set
> PACKAGE_BUILDING=yes
> in your /etc/make.conf
>
> Run afterwards
> make all-depends-list
> and you will see that libvisual is enabled as dependency although it  
> should be
> disabled.
>
> The logic in the Makefile is wrong!
>
>

I agree it could have been done better. I will have a look and get  
back to you.

/mich
Comment 12 Robert Gogolok 2008-02-21 15:37:58 UTC
Yeah, sorry.

http://www.freebsd.org/cgi/cvsweb.cgi/doc/en_US.ISO8859-1/books/porters-handbook/book.sgml.diff?r1=1.817;r2=1.818

Checked my (broken) tinderbox setup and found several references the options 
framework works now correct.



So the problem is long gone and I'm wrong!
Sorry for the noise...