Bug 120802 - [UPDATE] devel/p5-ExtUtils-CBuilder
Summary: [UPDATE] devel/p5-ExtUtils-CBuilder
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-perl (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-18 16:30 UTC by Felippe de Meirelles Motta
Modified: 2008-02-20 02:14 UTC (History)
0 users

See Also:


Attachments
file.diff (2.11 KB, patch)
2008-02-18 16:30 UTC, Felippe de Meirelles Motta
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felippe de Meirelles Motta 2008-02-18 16:30:03 UTC
- Updated to 0.22;
- Use CPAN macro;
- Add missing deps;
- Add missing WWW to pkg-descr.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2008-02-18 16:30:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->perl

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Yen-Ming Lee freebsd_committer 2008-02-18 18:58:23 UTC
State Changed
From-To: open->feedback

Text::ParseWords was in core list of PERL since 5, (in fact, File::Spec too), and we currently support 5.6.2 and 5.8.8. 
Do we need to put them in {BUILD,RUN}_DEPENDS?
Comment 3 Felippe de Meirelles Motta 2008-02-18 22:54:14 UTC
Lars Balker Rasmussen wrote:
> On Mon, Feb 18, 2008 at 07:01:52PM +0000, leeym@FreeBSD.org wrote:
>   
>> Synopsis: [UPDATE] devel/p5-ExtUtils-CBuilder
>>
>> State-Changed-From-To: open->feedback
>> State-Changed-By: leeym
>> State-Changed-When: Mon Feb 18 18:58:23 UTC 2008
>> State-Changed-Why: 
>> Text::ParseWords was in core list of PERL since 5, (in fact, File::Spec too), and we currently support 5.6.2 and 5.8.8.
>> Do we need to put them in {BUILD,RUN}_DEPENDS?
>>
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=120802
>>     
>
> Only if the version the port requires is different than the one included in
> one of the perls supported.
>
> In ports that require 5.8+ I typically leave out Scalar::Util and Test::More
> from the requirement-lists (and make them depend on version[1]), since they're 
> already in the dist.  This doesn't hold if the port e.g. requires a newer 
> Test-Simple (like Test-WWW-Mechanize).
>
> [1] E.g.:
> .if ${PERL_LEVEL} < 500800
> BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
> RUN_DEPENDS+=   ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
> .endif
>   
Thanks for your report lars@ and leeym@.

I think that the best thing is even using the more newer version of an 
software, but if you want, can you remove these lines.

My cheers :)
Comment 4 Yen-Ming Lee freebsd_committer 2008-02-19 05:33:56 UTC
State Changed
From-To: feedback->closed

Committed, thanks.