Bug 121194 - math/arpack - Patch to use ARPACK++ on modern compilers
Summary: math/arpack - Patch to use ARPACK++ on modern compilers
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Stefan Walter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-29 00:00 UTC by Reed A. Cartwright
Modified: 2008-12-12 14:50 UTC (History)
0 users

See Also:


Attachments
patch-arpackpp (5.25 KB, text/plain; charset=us-ascii)
2008-10-26 12:19 UTC, Stefan Walter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reed A. Cartwright 2008-02-29 00:00:01 UTC
Arpack++ is written in an old dialect of C++ and does not work on modern compilers.  A patch exists to fix the problem in ARPACK++ 1.2.  Please add it to the port building process.

The patch can be found here: http://reuter.mit.edu/index.php/software/arpackpatch/

Fix: 

Apply the patch found at http://reuter.mit.edu/index.php/software/arpackpatch/
How-To-Repeat: try to compiling something using ARPACK++
Comment 1 Stefan Walter freebsd_committer 2008-10-19 13:25:56 UTC
Hi Reed,

there hasn't been an update of your problem report ports/121194 [1] for
quite a while. The port doesn't have a maintainer, and the PR is lacking a
patch that can be applied to the port and tested. Can you provide a patch,
updating the port so the patch you referenced in the report is added to
the port's distfiles and applied to the arpack++ source code before the
build?

Regards,
Stefan

[1]: http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/121194
Comment 2 Reed A. Cartwright 2008-10-19 22:26:32 UTC
Stefan,

Sorry, I don't know the ports system well enough to make a port patch. 
It'll get done quicker if someone who knows what they are doing modifies 
the port.

--
Reed A. Cartwright
Comment 3 Stefan Walter freebsd_committer 2008-10-20 11:23:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stefan

Take.
Comment 4 Stefan Walter freebsd_committer 2008-10-22 09:03:33 UTC
Reed A. Cartwright, 19.10.08, 23:26h CEST:

> Stefan,
> 
> Sorry, I don't know the ports system well enough to make a port patch. 
> It'll get done quicker if someone who knows what they are doing modifies 
> the port.

Unfortunately, noone has shown an interest in providing a patch since you
submitted the PR months ago, so your best bet might really be to try to
create a patch yourself. It's not too hard - the Porter's Handbook [1]
should be a good introduction to how it works. The people on the ports
mailing list (ports@) can also help with most problems.

Regards,
Stefan

[1]: http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/index.html
Comment 5 Stefan Walter freebsd_committer 2008-10-26 12:19:04 UTC
Hi Reed,

can you please test if the attached patch for math/arpack++ works for you
and if the resulting arpack++ does work with the compilers you need it to
work with? It integrates the patch you mentioned and (de)installation of
the port should work properly, but I am not familiar with arpack++ itself
and cannot test the software's functionality.

Regards,
Stefan
Comment 6 Reed A. Cartwright 2008-10-27 21:23:27 UTC
Stefan Walter wrote:
> Hi Reed,
> 
> can you please test if the attached patch for math/arpack++ works for you
> and if the resulting arpack++ does work with the compilers you need it to
> work with? It integrates the patch you mentioned and (de)installation of
> the port should work properly, but I am not familiar with arpack++ itself
> and cannot test the software's functionality.

Hi Stefan,

I'm not using arpack++ right now, but tried out one of the examples and 
arpack++ does compile on Freebsd 7.

I had to modify /usr/local/share/examples/arpack++/Makefile.inc, to 
remove the dependency on -lg2c.  I instead set

FORTRAN_LIBS = -L/usr/local/lib/gcc-4.2.5 -lgfortran

Also I did the following error message when the port tried to fetch the 
patch files, but a second "sudo make" went fine.

=> arpack++.tar.gz doesn't seem to exist in 
/usr/ports/distfiles/arpack++-1.2.
=> Attempting to fetch from http://www.ime.unicamp.br/%7echico/arpack++/.
arpack++.tar.gz                               100% of 3403 kB  110 kBps 
00m00s
=> arpack++1.2.patch.diff doesn't seem to exist in 
/usr/ports/distfiles/arpack++-1.2.
=> Attempting to fetch from http://reuter.mit.edu/blue/software/.
fetch: 309992: No such file or directory
fetch: 309992: No such file or directory
arpack++1.2.patch.diff                        100% of  302 kB 1650 kBps
=> Attempting to fetch from 
http://www.gdv.uni-hannover.de/~reuter/software/.
fetch: 309992: No such file or directory
fetch: 309992: No such file or directory
fetch: 
http://www.gdv.uni-hannover.de/~reuter/software/arpack++1.2.patch.diff: 
Requested Range Not Satisfiable
=> Attempting to fetch from 
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/arpack++-1.2/.
fetch: 309992: No such file or directory
fetch: 309992: No such file or directory
fetch: 
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/arpack++-1.2/arpack++1.2.patch.diff: 
File unavailable (e.g., file not found, no access)
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/arpack++-1.2 and try again.
*** Error code 1

Stop in /usr/ports/math/arpack++.


-- 
*********************************************************
Reed A. Cartwright, PhD     http://scit.us/
Comment 7 Stefan Walter freebsd_committer 2008-10-28 12:34:13 UTC
Hi Reed,

Reed A. Cartwright, 27.10.08, 22:23h CET:

> I had to modify /usr/local/share/examples/arpack++/Makefile.inc, to 
> remove the dependency on -lg2c.  I instead set
> 
> FORTRAN_LIBS = -L/usr/local/lib/gcc-4.2.5 -lgfortran

I might have a look at that later.

> Also I did the following error message when the port tried to fetch the 
> patch files, but a second "sudo make" went fine.
> 
> => arpack++.tar.gz doesn't seem to exist in 
> /usr/ports/distfiles/arpack++-1.2.
> => Attempting to fetch from http://www.ime.unicamp.br/%7echico/arpack++/.
> arpack++.tar.gz                               100% of 3403 kB  110 kBps 
> 00m00s
> => arpack++1.2.patch.diff doesn't seem to exist in 
> /usr/ports/distfiles/arpack++-1.2.
> => Attempting to fetch from http://reuter.mit.edu/blue/software/.
> fetch: 309992: No such file or directory
> fetch: 309992: No such file or directory
> arpack++1.2.patch.diff                        100% of  302 kB 1650 kBps

It seems like the size of the file to be downloaded is misinterpreted as a
file name. I couldn't reproduce it with me - I suspect it's a local
problem with your system. Is your ports tree up to date and without any
modifications (except for the patch against math/arpack++ I sent)? If this
happens with an unmodified, up-to-date ports tree and you can reproduce
it, a separate problem report about it would be nice.

Regards,
Stefan
Comment 8 Stefan Walter freebsd_committer 2008-12-10 11:06:05 UTC
Hi Reed,

sorry for the long delay, real life got in the way...

Reed A. Cartwright, 27.10.08, 22:23h CET:

> I had to modify /usr/local/share/examples/arpack++/Makefile.inc, to 
> remove the dependency on -lg2c.  I instead set
> 
> FORTRAN_LIBS = -L/usr/local/lib/gcc-4.2.5 -lgfortran

Only '-lgfortran' isn't enough to make it work? The lib directory depends
on the compiler chosen during installation, but I currently don't see how
to get that (directory).

Regards,
Stefan
Comment 9 dfilter service freebsd_committer 2008-12-12 14:40:04 UTC
stefan      2008-12-12 14:39:50 UTC

  FreeBSD ports repository

  Modified files:
    math/arpack++        Makefile distinfo 
    math/arpack++/files  patch-Makefile.inc 
  Log:
  Integrate a patch from http://reuter.mit.edu/index.php/software/arpackpatch/
  which fixes ARPACK++ 1.2 to work with g++ 4.0.2 and above.
  
  PR:             121194
  Submitted by:   "Reed A. Cartwright" <reed@scit.us>
  Patch by:       stefan
  
  Revision  Changes    Path
  1.6       +8 -2      ports/math/arpack++/Makefile
  1.4       +3 -0      ports/math/arpack++/distinfo
  1.2       +26 -27    ports/math/arpack++/files/patch-Makefile.inc
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 Stefan Walter freebsd_committer 2008-12-12 14:40:52 UTC
State Changed
From-To: open->closed

I have integrated the patch into the port. The path for the Fortran library in 
the examples' Makefile may still have to be adjusted manually - I currently 
don't see how that could be done by the port.