Bug 121624 - [em] [regression] Intel em WOL fails after upgrade to FreeBSD-6.3 (from 6.2)
Summary: [em] [regression] Intel em WOL fails after upgrade to FreeBSD-6.3 (from 6.2)
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 6.3-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: jfv
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2008-03-11 19:30 UTC by Charlie &
Modified: 2015-06-29 18:10 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie & 2008-03-11 19:30:01 UTC
I've setup my Intel em NICs to support WOL with the windows XP driver.
This runs since years with my ASUS MB. WOL runs well per magic package.
So I didn't have to "touch" the system for years. The typical sequence
(ACPI enabled) was:

  - shutdown -p now
  - From my router "wake door"
  - and so on

After upgrade from 6.2 to 6.3 this only works when I "hard" switch off the power
after "shutdown -p" and than switch th power on again. Than for one time WOL works.

All the time the NIC has physical connect to my router.

The only change to all the systems was the upgrade to FreeBSD-6.3

In the internet I've found a similar problem reported (german):

  http://www.bsdforen.de/showthread.php?t=20322
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2008-03-11 20:25:01 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Wake-on-LAN issue with em driver in 6.3, worked fine in 6.2
Comment 2 Andre Oppermann freebsd_committer 2010-08-23 19:09:50 UTC
Responsible Changed
From-To: freebsd-net->jfv

Over to maintainer.
Comment 3 Sean Bruno freebsd_committer 2015-06-29 18:10:08 UTC
This looks to have been addressed in 2010.  Please retest if possible and report back on a new ticket.