Bug 121632 - New port: comms/libsyncml - SyncML library for PIM data sync
Summary: New port: comms/libsyncml - SyncML library for PIM data sync
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Felippe de Meirelles Motta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-12 00:40 UTC by Daniel Roethlisberger
Modified: 2008-05-31 05:40 UTC (History)
1 user (show)

See Also:


Attachments
libsyncml-0.4.5.shar (5.63 KB, text/plain)
2008-03-12 00:40 UTC, Daniel Roethlisberger
no flags Details
libsyncml-0.4.5.shar.2 (5.65 KB, text/plain; charset=us-ascii)
2008-04-14 23:54 UTC, Daniel Roethlisberger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Roethlisberger 2008-03-12 00:40:00 UTC
Libsyncml is an implementation of the SyncML protocol.
It's purpose is PIM data synchronization with mobile
devices over HTTP or OBEX/Bluetooth channels.

This port is one more step towards having a functional
OpenSync environment within our ports tree.

The configure.ac patch for -lbluetooth support was
imported from pkgsrc.
Comment 1 Felippe de Meirelles Motta freebsd_committer 2008-03-21 16:15:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lippe

I'll take it.
Comment 2 Felippe de Meirelles Motta freebsd_committer 2008-04-03 17:19:01 UTC
Hi Daniel,

Your patch is broken, can you please regenerate an new patch to fix it:

http://tb3.droso.net/errors/7-lippe/libsyncml-0.4.5.log

-- 
lippe@FreeBSD.org
Felippe de Meirelles Motta
Comment 3 Felippe de Meirelles Motta freebsd_committer 2008-04-03 17:52:49 UTC
State Changed
From-To: open->feedback

Ask for maintainer fix.
Comment 4 Daniel Roethlisberger 2008-04-09 10:30:42 UTC
Felippe de Meirelles Mot <lippe@FreeBSD.org> 2008-04-03:
> Your patch is broken, can you please regenerate an new patch to fix it:
> http://tb3.droso.net/errors/7-lippe/libsyncml-0.4.5.log

It worked for me as-is when I submitted it, but I do not have direct
access to a tinderbox installation, so dependency problems are likely.
I am currently updating my port devel box to the latest ports tree and
will try to reproduce and fix the problem.

It puzzles me why the configure script does not pick up all the
libraries in the above tinderbox run.  If you could send me the
config.log of the failed run that might speed things up a bit.

-- 
Daniel Roethlisberger <daniel@roe.ch>
Comment 5 Daniel Roethlisberger 2008-04-14 23:54:05 UTC
Daniel Roethlisberger <daniel@roe.ch> 2008-04-09:
> Felippe de Meirelles Mot <lippe@FreeBSD.org> 2008-04-03:
> > Your patch is broken, can you please regenerate an new patch to fix
> > it: http://tb3.droso.net/errors/7-lippe/libsyncml-0.4.5.log

I could not reproduce the problem here, but I attempted a fix anyhow.
Please try the attached shar.  This version depends on the correct
version of libsoup and I have tweaked the autotools declaration.

If it fails again, please do provide me with the config.log, not just
the tinderbox stdout/stderr log.

-- 
Daniel Roethlisberger <daniel@roe.ch>
Comment 6 Daniel Roethlisberger 2008-05-02 13:14:08 UTC
Felippe, have you seen my feedback (new shar) of ports/121632 from over
two weeks ago?  The PR is still in feedback state.

http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/121632

-- 
Daniel Roethlisberger <daniel@roe.ch>
Comment 7 Felippe de Meirelles Motta freebsd_committer 2008-05-05 16:36:16 UTC
State Changed
From-To: feedback->open

Maintainer has fixed.
Comment 8 Felippe de Meirelles Motta freebsd_committer 2008-05-13 20:45:13 UTC
Hi Submitter,

Since KSE support was removed in FreeBSD, all ports threaded doesn't
build on < 7 versions. One of your dependencies is broken. I'll wait an
better solution to committ your port.

Thanks for your submission to the FreeBSD Project! :)

-- 
lippe@FreeBSD.org
Felippe de Meirelles Motta
Comment 9 dfilter service freebsd_committer 2008-05-31 05:30:43 UTC
lippe       2008-05-31 04:30:36 UTC

  FreeBSD ports repository

  Modified files:
    comms                Makefile 
  Added files:
    comms/libsyncml      Makefile distinfo pkg-descr pkg-plist 
    comms/libsyncml/files patch-configure.in 
                          patch-libsyncml_transports_obex_client.c 
  Log:
  Libsyncml is an implementation of the SyncML protocol.
  It's purpose is PIM data synchronization with mobile
  devices over HTTP or OBEX/Bluetooth channels.
  
          WWW: http://libsyncml.opensync.org/
  
  PR:             ports/121632
  Submitted by:   Daniel Roethlisberger <daniel@roe.ch>
  Approved by:    gabor (mentor)
  
  Revision  Changes    Path
  1.192     +1 -0      ports/comms/Makefile
  1.1       +35 -0     ports/comms/libsyncml/Makefile (new)
  1.1       +3 -0      ports/comms/libsyncml/distinfo (new)
  1.1       +37 -0     ports/comms/libsyncml/files/patch-configure.in (new)
  1.1       +16 -0     ports/comms/libsyncml/files/patch-libsyncml_transports_obex_client.c (new)
  1.1       +5 -0      ports/comms/libsyncml/pkg-descr (new)
  1.1       +30 -0     ports/comms/libsyncml/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 Felippe de Meirelles Motta freebsd_committer 2008-05-31 05:32:40 UTC
State Changed
From-To: open->closed

Committed. Thanks!