Bug 121708 - [keyboard] nforce 650i mobo w/ usb keyboard infinite key repeat hang [regression]
Summary: [keyboard] nforce 650i mobo w/ usb keyboard infinite key repeat hang [regress...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: 7.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-14 19:00 UTC by Timothy Smith
Modified: 2017-12-31 22:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Smith 2008-03-14 19:00:11 UTC
I have identical problem behavior with the following FreeBSD install ISOs:

- 5.5-RELEASE-i386-bootonly.iso
- 6.3-RELEASE-i386-bootonly.iso
- 7.0-RELEASE-i386-bootonly.iso
- 7.0-RELEASE-amd64-bootonly.iso

When I boot from the install CD, it brings me to the menu to select my
keyboard layout.  The first key I press (e.g., <ENTER> or <DownArrow>)
is repeated over and over, and no further keyboard input is possible.

E.g., if I press and release <DownArrow>, the menu scrolls down to the
very last entry and then is stuck there.  Or if I press and release
<ENTER>, it flip-flops perpetually between the main menu screen and the
sub-screen.  It behaves as if I am just holding down the first key I press.

If I boot with ACPI on, my power button does not have any effect at this
point.  If I press the RESET button, then when the GRUB menu shows the
keyboard is not functional; I have to switch the power supply off and on
to reset it.

The following work properly:

- 4.11-RELEASE-i386-miniinst.iso (FreeBSD 4.11)
- dfly-1.12.0_REL.iso (DragonFly BSD)
- BeleniX 0.6.1 (OpenSolaris distro)
- NetBSD 4.0
- Linux 2.6 kernel
- Windows XP

How-To-Repeat: The hardware:

- XFX nForce 650i motherboard
  - NVIDIA nForce 650i Ultra MCP chipset
  - Product web page: http://tinyurl.com/366hty
  - Latest BIOS update from XFX installed (650P04)
- USB keyboard (Microsoft Comfort Curve Keyboard 2000 v1.0)
- Intel Core 2 Duo E6420 CPU
- NVIDIA 7900GS video card
- 4G RAM
- 1 SATA hard drive

Boot from a FreeBSD install CD (5.5-RELEASE and higher).  At the boot
menu, the keyboard functions properly (SPACE to pause the countdown, 2
to boot without ACPI, etc.).

Wait for the first menu to show, press and release any key.

Watch it behave as if the key is being pressed repeatedly.  Notice that
no key input has any effect (including Ctrl-Alt-Del).  If ACPI is on, the
Power button has no effect.

I tried setting the BIOS USB settings to V1.1 only, and it had no effect.
I tried disabling the USB keyboard in the BIOS; at the boot menu, the
keyboard did not function at all; once the menu system came up, the same
exact problem happened.

Unfortunately I don't have a PS/2 keyboard to test with!
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2008-03-15 08:19:01 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-usb

Make a guess here and assign it to the usb mailing list.
Comment 2 Timothy Smith 2008-04-15 03:02:52 UTC
I finally got a PS/2 keyboard and hooked it up: it works (tested with
7.0-RELEASE-i386-bootonly.iso).  It seems to have a slight delay (when
I press <DownArrow> multiple times in a menu, it takes a second or so
before it finally arrives at the desired menu item), but it does work
without any keyboard hangs.

However, I was unable to test beyond the basic installer menus,
because the hard disk isn't being detected, similar to:

http://www.mail-archive.com/freebsd-hardware@freebsd.org/msg02596.html

Regards,

Timothy
-- 
If you're not part of the solution, you're part of the precipitate.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:40 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped