Bug 122037 - [patch] add rsync example for inetd.conf
Summary: [patch] add rsync example for inetd.conf
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: Daniel Ebdrup Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-24 08:10 UTC by David Yeske
Modified: 2021-02-26 19:09 UTC (History)
3 users (show)

See Also:


Attachments
file.diff (591 bytes, patch)
2008-03-24 08:10 UTC, David Yeske
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Yeske 2008-03-24 08:10:02 UTC
add rsync example to inetd.conf

Fix: see attachment

Patch attached with submission follows:
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:30 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 2 Mateusz Piotrowski freebsd_committer 2019-09-22 12:53:09 UTC
I'll take a look.
Comment 3 Daniel Ebdrup Jensen freebsd_committer 2019-09-22 13:44:27 UTC
I think this is a good example, but I do want to stress that I think it should include the phrase "for local connections only" since the rsync protocol provides no cryptographic protections against snooping on the data, and it's therefore better to pipe over ssh (or bbcp) when sending data over the internet.
Comment 4 Mateusz Piotrowski freebsd_committer 2020-06-08 00:19:57 UTC
Return the issue to the pool.
Comment 5 Daniel Ebdrup Jensen freebsd_committer 2021-02-23 10:36:41 UTC
I've added this as part of review D28882.
Comment 6 commit-hook freebsd_committer 2021-02-26 19:07:54 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=bc3bba70d834c169475302334b192bc90c17521e

commit bc3bba70d834c169475302334b192bc90c17521e
Author:     Daniel Ebdrup Jensen <debdrup@FreeBSD.org>
AuthorDate: 2021-02-26 19:05:46 +0000
Commit:     Daniel Ebdrup Jensen <debdrup@FreeBSD.org>
CommitDate: 2021-02-26 19:07:03 +0000

    inetd: Add examples from manual page and other sources

    The manual page lists a bunch of examples, some of which already exist
    in this file. Since it's both easier to remember when all examples are
    listed in the same location, move examples so they get installed into
    /etc/inetd.conf

    This also means users won't have to copy-paste, but can simply
    uncomment one or more services to use them.

    As such, it also becomes necessary to remove the examples from the
    manual page, so instead add a note explaining where the previous
    examples as well as others may be found.
    Cross-references, including to ports, have also been added where
    applicable.

    The rsync example has lived in the bug tracker for too long,
    considering how useful it can situationally be, for example when
    backup jobs on client devices are run through periodic(8) weekly.

    The microsoft-ds entry is necessary for Windows 10 compatibility
    (this can be confirmed with packet capturing, as it is not readily
    documented at time of writing).

    While here, remove two examples for which compatible daemons could not
    be found in ports.

    Submitted by:   David Yeske <dyeske at gmail.com> (in part, prev ver)
    PR:             122037
    Reviewed by:    kevans, brueffer, lwhsu, yuripv
    Differential Revision:  https://reviews.freebsd.org/D28882

 usr.sbin/inetd/inetd.8    | 88 +++++++++++++++++++++++++++++------------------
 usr.sbin/inetd/inetd.conf | 42 ++++++++++++++++------
 2 files changed, 87 insertions(+), 43 deletions(-)
Comment 7 Daniel Ebdrup Jensen freebsd_committer 2021-02-26 19:09:13 UTC
Even if it took a little while, thank you for your attention to detail. :)