Bug 122482 - [PATCH]ftp/wget: update to 1.11.1; add some OPTIONS
[PATCH]ftp/wget: update to 1.11.1; add some OPTIONS
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Vasil Dimov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 13:00 UTC by bf2006a
Modified: 2008-05-06 15:00 UTC (History)
0 users

See Also:


Attachments
file.diff (2.98 KB, patch)
2008-04-06 13:00 UTC, bf2006a
no flags Details | Diff
wget.1112.txt (3.91 KB, text/plain)
2008-05-01 11:10 UTC, bf2006a
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bf2006a 2008-04-06 13:00:08 UTC
Update to 1.11.1 (summary of changes below); use OPTIONS; permit users to disable ipv6 and choose between gnutls and openssl.

Changes:
** Interrupted downloads no longer result in renaming the file
(regression in 1.11 over 1.10.2).

** Progress bar now displays correctly in non-English locales (and a
related assertion failure was fixed).

** Wget no longer issues a GET request over HTTP for files it should
know it's not going to download (regression in 1.11 over 1.10.2).

** Added option --auth-no-challenge, to support broken pre-1.11
authentication-before-server-challenge, which turns out to still be
useful for some limited cases.

** Documentation of accept/reject lists in the manual's "Types of
Files" section now explains various aspects of their behavior that may
be surprising, and notes that they may change in the future.

** Documentation of --no-parents now explains how a trailing slash, or
lack thereof, in the specified URL, will affect behavior.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2008-04-06 13:00:22 UTC
Responsible Changed
From-To: freebsd-ports-bugs->vd

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 bf2006a 2008-05-01 11:10:16 UTC
Please consider the attached patch instead of the one
submitted earlier.  It corrects a typo in the OPTIONS,
and updates to 1.11.2.

b.



      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
Comment 3 dfilter freebsd_committer 2008-05-06 14:51:23 UTC
vd          2008-05-06 13:51:15 UTC

  FreeBSD ports repository

  Modified files:
    ftp/wget             Makefile distinfo 
    ftp/wget/files       patch-doc_Makefile.in 
  Log:
  Upgrade ftp/wget from 1.11 to 1.11.2.
  
  PR:             ports/122482 (based on)
  Submitted by:   bf <bf2006a@yahoo.com>
  
  Revision  Changes    Path
  1.86      +41 -19    ports/ftp/wget/Makefile
  1.28      +3 -3      ports/ftp/wget/distinfo
  1.2       +3 -3      ports/ftp/wget/files/patch-doc_Makefile.in
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Vasil Dimov freebsd_committer 2008-05-06 14:51:39 UTC
State Changed
From-To: open->closed

Committed with some modifications, thanks!