Bug 122831 - textproc/enchant failure due to gcc version
Summary: textproc/enchant failure due to gcc version
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-16 22:10 UTC by barbara
Modified: 2008-04-16 22:40 UTC (History)
0 users

See Also:


Attachments
file.diff (559 bytes, patch)
2008-04-16 22:10 UTC, barbara
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description barbara 2008-04-16 22:10:01 UTC
Upgrade of textproc/enchant is failing with the following error.
Looking at gcc docs, it seems that the three offending options was added in different release of the 4.x branch

 c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"enchant\" -DVERSION=\"1.4.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DHAVE_FLOCK=1 -DHAVE_LOCKF=1 -DHAVE_LOCALE_H=1 -DHAVE_LC_MESSAGES=1 -I. -I. -I../../src -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -DENCHANT_PREFIX_DIR=\"/usr/local\" -Wall -Wextra -Wsign-compare -Wpointer-arith -Wwrite-strings -Wpacked -Wswitch-enum -Wmissing-format-attribute -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -fno-strict-aliasing -DENCHANT_ISPELL_DICT_DIR=\"/usr/local/share/enchant/ispell\" -D_ENCHANT_BUILD=1 -I/usr/local/include -O2 -pipe -fno-strict-aliasing -march=athlon-mp -
 MT correct.lo -MD -MP -MF .deps/correct.Tpo -c correct.cpp  -fPIC -DPIC -o .libs/correct.o
cc1plus: error: unrecognized command line option "-Wunsafe-loop-optimizations"
cc1plus: error: unrecognized command line option "-Wno-missing-field-initializers"
cc1plus: error: unrecognized command line option "-Wno-attributes"
gmake[2]: *** [correct.lo] Error 1
gmake[2]: Leaving directory `/usr/ports/textproc/enchant/work/enchant-1.4.0/src/ispell'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/textproc/enchant/work/enchant-1.4.0/src'
gmake: *** [all-recursive] Error 1
*** Error code 2

Fix: I had the port built after applying the attached patch.
I can't test it on 7-STABLE at the moment
I'm not sure about the side effects of removing those flags :)


Patch attached with submission follows:
How-To-Repeat: build or upgrade the port on pre 7 releases (I think)
Comment 1 Edwin Groothuis freebsd_committer 2008-04-16 22:10:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Michael Johnson freebsd_committer 2008-04-16 22:39:34 UTC
State Changed
From-To: open->closed

Committed, Thanks!
Comment 3 dfilter service freebsd_committer 2008-04-16 22:39:34 UTC
ahze        2008-04-16 21:39:20 UTC

  FreeBSD ports repository

  Modified files:
    textproc/enchant     Makefile 
  Log:
  Fix build on OSVERSION < 700042
  
  PR:             ports/122831
  Submitted by:   barbara <barbara.xxx1975@libero.ot>
  
  Revision  Changes    Path
  1.25      +6 -0      ports/textproc/enchant/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"