Bug 122921 - irc/bitlbee - Bitlbee-1.2 port fails to build
Summary: irc/bitlbee - Bitlbee-1.2 port fails to build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Henrik Brix Andersen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-20 01:30 UTC by Ryan Steinmetz
Modified: 2008-04-20 23:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Steinmetz 2008-04-20 01:30:00 UTC
The Bitlbee-1.2 port fails to compile on my 7.0-RELEASE workstation with the following error:

===>  Patching for bitlbee-1.2
sed: 1: "s:^EFLAGS=:EFLAGS= -rpa ...": bad flag in substitute command: '/'
*** Error code 1

Stop in /usr/ports/irc/bitlbee.
*** Error code 1


I believe this is because LDFLAGS is set to: -rpath=/usr/lib:/usr/local/lib and sed is getting confused.


        @${REINPLACE_CMD} \
                -e "s:^EFLAGS=:EFLAGS=${LDFLAGS}:" \
                ${WRKSRC}/configure


Commenting this out from the Makefile and manually editing EFLAGS within configure results in a successful build.

How-To-Repeat: Attempt to build /usr/ports/irc/bitlbee
Comment 1 Edwin Groothuis freebsd_committer 2008-04-20 01:43:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->brix

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Ryan Steinmetz 2008-04-20 03:45:17 UTC
This error may have been caused by USE_OPENSSL=yes being defined in make.conf

-r

-- 
Ryan Steinmetz
Lead Security/Systems Administrator
Finance & Administration
Systems & Technology
Rochester Institute of Technology
585.475.5663
PGP: EF36 D45A 5CA9 28B1 A550  18CD A43C D111 7AD7 FAF2
Comment 3 dfilter service freebsd_committer 2008-04-20 23:02:01 UTC
brix        2008-04-20 22:01:56 UTC

  FreeBSD ports repository

  Modified files:
    irc/bitlbee          Makefile 
  Log:
  Fix sed(1) statement for cases where $LDFLAGS contains one or more
  colons.
  
  PR:             ports/122921
  Approved by:    pav (co-mentor)
  
  Revision  Changes    Path
  1.41      +1 -1      ports/irc/bitlbee/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Henrik Brix Andersen freebsd_committer 2008-04-20 23:02:17 UTC
State Changed
From-To: open->closed

Fixed. Thank you for reporting this.