Bug 123008 - editors/openoffice.org-2 (2.4) compilation fails: dmake: Error code 1, while making '../unxfbsdx.pro/lib/libvcl680fx.so'
Summary: editors/openoffice.org-2 (2.4) compilation fails: dmake: Error code 1, whil...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-23 10:10 UTC by O. Hartmann
Modified: 2008-04-23 11:03 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2008-04-23 10:10:01 UTC
Compiling ports/openoffice.org-2 (Version OO 2.4) on all FreeBSD 7.0-STABLE SMP boxes (either AMD64 or i386). On a UP box (FreeBSD 7.0-STABLE AMD64) OpenOffice 2.4 does compile.

Why is it a problem making a working port? As far as I know, OpenOffice ever have had problems when compiling it for my own and this is since OO 1 and since I use FreeBSD (from 2.0 on). :-(


=====

mv ../unxfbsdx.pro/lib/libvcl680fx.so ../unxfbsdx.pro/lib/check_libvcl680fx.so
/usr/ports/editors/openoffice.org-2/work/OOH680_m12/solenv/bin/checkdll.sh -L../unxfbsdx.pro/lib -L/usr/ports/editors/openoffice.org-2/work/OOH68
0_m12/solver/680/unxfbsdx.pro/lib  ../unxfbsdx.pro/lib/check_libvcl680fx.so
Checking DLL ../unxfbsdx.pro/lib/check_libvcl680fx.so ...: ERROR: ../unxfbsdx.pro/lib/check_libvcl680fx.so: Undefined symbol "_ZNK7icu_3_814LEFon
tInstance17getDynamicClassIDEv"
dmake:  Error code 1, while making '../unxfbsdx.pro/lib/libvcl680fx.so'
---* tg_merge.mk *---

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice.org-2/work/OOH680_m12/vcl/util
dmake:  Error code 1, while making 'build_instsetoo_native'
---*  *---
*** Error code 255

Stop in /usr/ports/editors/openoffice.org-2.
*** Error code 1

Stop in /usr/ports/editors/openoffice.org-2.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.9007.1 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=openoffice.org-2.3.1_1 UPG
RADE_PORT_VER=2.3.1_1 make reinstall

How-To-Repeat: Try compiling OO 2.4 from the ports on FreeBSD 7.0-STABLE with SMP and wait several hours (6h on a P4 with HT and 3.0 GHz).
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2008-04-23 10:13:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 2 Marcin Cieslak 2008-04-23 10:43:56 UTC
http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/121787 is a duplicate 
of this bug.
-- 
               << Marcin Cieslak // saper@system.pl >>
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2008-04-23 11:03:23 UTC
State Changed
From-To: open->closed

See ports/121787.