Bug 125550 - science/netcdf add regression-target
Summary: science/netcdf add regression-target
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Beech Rintoul
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-12 22:50 UTC by Pedro F. Giffuni
Modified: 2008-07-20 21:30 UTC (History)
0 users

See Also:


Attachments
file.diff (666 bytes, patch)
2008-07-12 22:50 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni 2008-07-12 22:50:01 UTC
- Add regression-target since the port recommends running the checks before installing.
- Minor cleanup to the MASTERSITE: it must be noted the main site has changed the distfiles so the distinfo doesn't match the sunpoet's mirror.
- No functional change.
Comment 1 Edwin Groothuis freebsd_committer 2008-07-12 22:50:14 UTC
Maintainer of science/netcdf,

Please note that PR ports/125550 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/125550

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2008-07-12 22:50:15 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Sunpoet Po-Chuan Hsieh 2008-07-17 20:33:38 UTC
On Sat, Jul 12, 2008 at 09:50:14PM +0000, Edwin Groothuis wrote:
> Maintainer of science/netcdf,
> 
> Please note that PR ports/125550 has just been submitted.
> 
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
> 
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/125550
> 
> -- 
> Edwin Groothuis via the GNATS Auto Assign Tool
> edwin@FreeBSD.org

Approved with minor changes.
- Bump revision for rerolled tarball.

diff -ruN /usr/ports/science/netcdf/Makefile /usr/ports/sunpoet/netcdf/Makefile
--- /usr/ports/science/netcdf/Makefile	2008-06-26 08:50:13.060267145 +0800
+++ /usr/ports/sunpoet/netcdf/Makefile	2008-07-17 16:05:59.178921352 +0800
@@ -7,10 +7,10 @@
 
 PORTNAME=	netcdf
 PORTVERSION=	3.6.3
+PORTREVISION=	1
 CATEGORIES=	science
-MASTER_SITES=	ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
+MASTER_SITES=	ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
 		http://sunpoet.net/distfiles/
-MASTER_SITE_SUBDIR=	. old
 
 MAINTAINER=	sunpoet@sunpoet.net
 COMMENT=	Library for machine-independent, array-oriented data access
@@ -40,4 +40,7 @@
 .endfor
 .endif
 
+regression-test: build
+	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
 .include <bsd.port.mk>
diff -ruN /usr/ports/science/netcdf/distinfo /usr/ports/sunpoet/netcdf/distinfo
--- /usr/ports/science/netcdf/distinfo	2008-06-26 08:50:13.060267145 +0800
+++ /usr/ports/sunpoet/netcdf/distinfo	2008-07-17 16:04:56.652262517 +0800
@@ -1,3 +1,3 @@
-MD5 (netcdf-3.6.3.tar.gz) = e03ca6eb3a0d9126162b9fe1725cfed3
-SHA256 (netcdf-3.6.3.tar.gz) = 9aacdcad88774bd6e4515196f80f73bab54557e6fde07379f6bfb2d60fe717d3
-SIZE (netcdf-3.6.3.tar.gz) = 11489734
+MD5 (netcdf-3.6.3.tar.gz) = 334e9bdc010b6cd03fd6531a45fe50ad
+SHA256 (netcdf-3.6.3.tar.gz) = afa1a0fa82b9ea33b035257b6e9662b22e135f98b2fd93d5cf030320dfc3ffa1
+SIZE (netcdf-3.6.3.tar.gz) = 11572512

-- 
                              Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2008-07-17 21:22:51 UTC
State Changed
From-To: feedback->open

Approved, with minor changes.
Comment 5 Felippe de Meirelles Motta freebsd_committer 2008-07-19 05:12:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lippe

I'll take it.
Comment 6 Beech Rintoul freebsd_committer 2008-07-20 20:19:44 UTC
Responsible Changed
From-To: lippe->beech

Pass to me
Comment 7 dfilter service freebsd_committer 2008-07-20 21:25:32 UTC
beech       2008-07-20 20:25:18 UTC

  FreeBSD ports repository

  Modified files:
    science/netcdf       Makefile distinfo 
  Log:
  - Add regression-target since the port recommends running the checks before installing.
  - Fix distinfo
  - Bump portrevision
  
  PR:             ports/125550
  Submitted by:   Pedro F. Giffuni <pfgshield-freebsd@yahoo.com>
  Approved by:    Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> (maintainer, with changes)
  
  Revision  Changes    Path
  1.31      +5 -2      ports/science/netcdf/Makefile
  1.16      +3 -3      ports/science/netcdf/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 Beech Rintoul freebsd_committer 2008-07-20 21:25:37 UTC
State Changed
From-To: open->closed

Committed (with changes), Thanks!