Bug 125592 - [hang] FreeBSD 7 server in hang
Summary: [hang] FreeBSD 7 server in hang
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: 7.0-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-14 09:50 UTC by Gian Paolo
Modified: 2017-12-31 22:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gian Paolo 2008-07-14 09:50:03 UTC
Hi, I have on my server ibm 3650  FreeBSD 7.0-STABLE and the proccess
that running are nagios-3.0.2, apache-2.2.8 and heartbeat-1.2.5_3;
random after some day machine becomes semi-dead, the ping respond but
any stack (ssh,http) don't work and heartbeat don't switch the
resources I can't loggon  and I must reboot. In the syslog there
isn't  any message for trobleshotting the problem. Any idea ? Sorry
for my english
Best Regards
Comment 1 chris 2008-09-13 23:00:42 UTC
I have exactly the same problem with 3 different servers running
7.0-RELEASE-p4 (problem happen with p3 too).

They start randomly hang during the last days.

SSH, FTP, WEB, etc don't respond but ICMP responds.

The servers come back only after a hard reboot.
Comment 2 chris 2008-09-16 09:40:40 UTC
When the server hangs, as I said I can't ssh or visit any website hosted
on this server, but I can use nmap and see that port 22,25,53,80 are all
open.
Comment 3 Remko Lodder 2008-09-16 09:46:30 UTC
On Tue, September 16, 2008 10:40 am, Chris wrote:
> The following reply was made to PR i386/125592; it has been noted by
> GNATS.
>
> From: Chris <chris@cretaforce.gr>
> To: bug-followup@FreeBSD.org, gpbuono@gmail.com
> Cc:
> Subject: Re: i386/125592: [hang] FreeBSD 7 server in hang
> Date: Tue, 16 Sep 2008 11:40:40 +0300
>
>  When the server hangs, as I said I can't ssh or visit any website hosted
>  on this server, but I can use nmap and see that port 22,25,53,80 are all
>  open.
>

So it seems the machine is still able to proces at least something, but
that it magically hangs.

As we discussed on IRC, it would be helpful if you can update to the
latest 7-STABLE version so that we can see whether the -RELEASE would also
have this problem and potentially see where this resides.

Cheers,
remko

-- 
/"\   Best regards,                      | remko@FreeBSD.org
\ /   Remko Lodder                       | remko@EFnet
 X    http://www.evilcoder.org/          |
/ \   ASCII Ribbon Campaign              | Against HTML Mail and News
Comment 4 chris 2008-09-16 09:51:29 UTC
I upgrade 10 hours ago to the 7.1-PRERELEASE and the hangs start more
often.
Comment 5 support 2008-09-16 17:02:31 UTC
Some more details:

The 4 servers (yes I had the same problem on 4 different servers, all
AMD) hang lots of times before I could close all services but bind (so I
could csup) and then the hangs disappeared (or at least from what I can
tell in the 2 hours it took me to downgrade the kernel to 7.0-RELEASE
patch 4) for each server.

The same servers had an uptime of 3 months before they start hanging.
Comment 6 chris 2008-09-22 04:25:56 UTC
I think this problem happens when you upload something using PHP.
Comment 7 chris 2008-09-22 04:28:07 UTC
Please check this one:

http://trac.lighttpd.net/trac/ticket/1602

I am 100% sure it's related to this.
Comment 9 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:12 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped