Bug 125620 - [PATCH]lang/sbcl: update to 1.0.18
Summary: [PATCH]lang/sbcl: update to 1.0.18
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Stanislav Sedov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-15 03:40 UTC by bf
Modified: 2008-07-23 08:30 UTC (History)
0 users

See Also:


Attachments
file.diff (1.16 KB, patch)
2008-07-15 03:40 UTC, bf
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bf 2008-07-15 03:40:01 UTC
"changes in sbcl-1.0.18 relative to 1.0.17:
  * minor incompatible change: SB-SPROF:WITH-PROFILING now by default
    profiles only the current thread.
  * minor incompatible change: changes to SYMBOL-VALUE of constants
    defined with DEFCONSTANT now signal an error.
  * enhancement: SB-SPROF now has support for wallclock profiling,
    and is also able to profile specific threads. REPORT output
    has also additional sorting options.
  * enhancement: better pretty-printing of DEFPACKAGE forms.  (Thanks
    to Michael Weber)
  * optimization: structure allocation has been improved
    ** constructors created by non-toplevel DEFSTRUCTs are ~40% faster.
    ** out of line constructors are ~10% faster.
    ** inline constructors are ~15% faster.
    ** inline constructors are capable of dynamic extent allocation
       (generally on x86 and x86-64, in some cases on other platforms
       as well.)
  * optimization: simple uses of HANDLER-CASE and HANDLER-BIND no
    longer cons.
  * optimization: file compiler is now able to coalesce non-circular
    lists, non-base strings, and bit-vectors. Additionally, constants
    are never referenced through SYMBOL-VALUE at runtime.
  * optimization: code defining methods on PRINT-OBJECT (and other
    generic functions in the COMMON-LISP package) now loads faster.
  * bug fix: EAI_NODATA is deprecated since RFC 3493. Stop using it
    in sb-bsd-sockets.
  * bug fix: if COMPILE-FILE aborts due to an unwind, the partial
    fasl is now deleted. (reported by Attila Lendvai)
  * bug fix: READ-LINE always returned NIL for the last line in files.
    (reported by Yoshinori Tahara)
  * bug fix: more accurate disassembly annotations of foreign function
    calls.  (thanks to Andy Hefner)
  * bug fix: trimming non-simple strings and non-string string
    designators when the there is nothing to trim works properly.
    (thanks to James Knight)
  * new feature: SB-POSIX bindings for mlockall, munlockall, and setsid.
    (thanks to Travis Cross)
  * fixed some bugs revealed by Paul Dietz' test suite:
    ** NIL is a valid function name (regression at 1.0.13.38)
    ** FILL on lists was missing its return value (regression at 1.0.12.27)
    ** STRING-TRIM, STRING-LEFT-TRIM, and STRING-RIGHT-TRIM did not respect
       fill pointers properly (regression at 1.0.12.23)
    ** STRING-TRIM, STRING-LEFT-TRIM, and STRING-RIGHT-TRIM did not respect
       displacement indices properly (regression at 1.0.12.23)"

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2008-07-15 03:40:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stas

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2008-07-23 08:23:13 UTC
stas        2008-07-23 07:23:00 UTC

  FreeBSD ports repository

  Modified files:
    lang/sbcl            Makefile distinfo 
  Log:
  - Update to 1.0.18.
  
  PR:             ports/125620
  Submitted by:   bf <bf2006a@yahoo.com>
  
  Revision  Changes    Path
  1.61      +1 -1      ports/lang/sbcl/Makefile
  1.46      +3 -3      ports/lang/sbcl/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Stanislav Sedov freebsd_committer 2008-07-23 08:25:22 UTC
State Changed
From-To: open->closed

Committed. Thanks!