Bug 125721 - [ath] Terrible throughput/high ping latency with Ubiquiti SR9/XR9
Summary: [ath] Terrible throughput/high ping latency with Ubiquiti SR9/XR9
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 7.0-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-17 17:40 UTC by Geoffrey Mainland
Modified: 2018-05-28 19:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Mainland 2008-07-17 17:40:01 UTC
I'm running 7-CURRENT on several ALIX 3c2 boards with SR9 radios and having
major performance problems: throughput on TCP streams generated by iperf often
falls to zero, and, depending on the HAL I use, I see ping latencies during one
of these iperf transfers of up to more than a *minute*. I've tried both the
0.9.30.13 HAL and the new 0.10.5.6 HAL. I see this bad behavior with both, but
the new HAL seems even worse.
 
I've documented my configuration and the test results at
http://www.eecs.harvard.edu/~mainland/freebsd/sr9/. This includes the kernel
configuration, dmesg output, pciconf output, rc.conf, statistics collected from
the ath driver, appropriate sysctl values, iperf/ping output generated by my
driver script and some plots showing the problem.
 
We are trying to deploy a bunch of these nodes outdoors, using the 900MHz radios
as a backhaul, so the drop-outs I see with SR9s are a major problem for us. I've
also run the same tests on Soekris nodes, used different SR9s, and also tried
the new XR9s on the same ALIX boards---all with similar results. We also have a
bunch of Wistrom CM9s which seem to work just fine.
 
Any idea what could be going on?

How-To-Repeat: I see this pattern of behavior with both XR9s and SR9s. It also happens on Soekris 4826 motherboards.
Comment 1 Alexander Best freebsd_committer 2010-09-07 00:05:10 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2011-04-12 00:26:02 UTC
Responsible Changed
From-To: freebsd-net->freebsd-wireless

change resp. to new mailing list
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:43:34 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.