Bug 125908 - sysutils/tclsyslog does not build on pointyhat
Summary: sysutils/tclsyslog does not build on pointyhat
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Beech Rintoul
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-23 21:40 UTC by Frank
Modified: 2008-07-24 20:50 UTC (History)
0 users

See Also:


Attachments
file.diff (559 bytes, patch)
2008-07-23 21:40 UTC, Frank
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank 2008-07-23 21:40:01 UTC
pointyhat reports the following:


====================<phase 4: make build>====================
add_pkg tcl-8.4.19,1.tbz
adding dependencies
pkg_add tcl-8.4.19,1.tbz
===>   tclsyslog-2.1 depends on shared library: tcl84 - found
===>  Configuring for tclsyslog-2.1
===>  Building for tclsyslog-2.1
cc -O2 -pipe  -fno-strict-aliasing-Wall -fPIC -I/usr/local/include/tcl8.4 -DVERSION=\"2.1\" -c tclsyslog.c
cc1: error: unrecognized command line option "-fno-strict-aliasing-Wall"
*** Error code 1

Stop in /work/a/ports/sysutils/tclsyslog/work/tclsyslog.
*** Error code 1

Stop in /a/ports/sysutils/tclsyslog.
================================================================


I am unsure, why the space between the two options is missing when pointyhat builds the port, but is in place when building this port on my 6.2 and 7.0 servers.
I attached a patch that simply adds a space in that position. I could not verify if this actually fixes the problem since I can not reproduce it.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2008-07-23 21:40:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->beech

beech@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2008-07-24 20:45:32 UTC
beech       2008-07-24 19:45:23 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/tclsyslog   Makefile 
  Log:
  - Fix reinplace CFLAGS line
  
  PR:             ports/125908
  Submitted by:   Frank Fenor <frank@fenor.de> (maintainer)
  Reported by:    pointyhat
  
  Revision  Changes    Path
  1.2       +1 -1      ports/sysutils/tclsyslog/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Beech Rintoul freebsd_committer 2008-07-24 20:45:50 UTC
State Changed
From-To: open->closed

Committed, Thanks!