Bug 125930 - [PATCH] www/awstats: install corrupted icons
Summary: [PATCH] www/awstats: install corrupted icons
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Wesley Shields
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-24 13:00 UTC by Beat Gaetzi
Modified: 2008-07-24 14:40 UTC (History)
0 users

See Also:


Attachments
awstats.patch (780 bytes, patch)
2008-07-24 13:00 UTC, Beat Gaetzi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beat Gaetzi 2008-07-24 13:00:13 UTC
	- Icons of awstats are corrupted after "make patch"
	- usage of USE_DOS2UNIX on png files causes this corrpution

How-To-Repeat: 	# make extract
	===>  Found saved configuration for awstats-6.6_1,1
	===>  Extracting for awstats-6.8,1
	=> MD5 Checksum OK for awstats-6.8.tar.gz.
	=> SHA256 Checksum OK for awstats-6.8.tar.gz.
	# file work/awstats-6.8/wwwroot/icon/other/vk.png
	work/awstats-6.8/wwwroot/icon/other/vk.png: PNG image data, 13 x 1, 4-bit colormap, non-interlaced
	# make patch
	===>  Patching for awstats-6.8,1
	===>   Converting DOS text files to UNIX text files
	===>  Applying FreeBSD patches for awstats-6.8,1
	# file work/awstats-6.8/wwwroot/icon/other/vk.png
	work/awstats-6.8/wwwroot/icon/other/vk.png: PNG image data, CORRUPTED,
Comment 1 Edwin Groothuis freebsd_committer 2008-07-24 13:00:58 UTC
Maintainer of www/awstats,

Please note that PR ports/125930 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/125930

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2008-07-24 13:01:00 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Oleksii Samorukov freebsd_committer 2008-07-24 13:18:05 UTC
i`m accepting this patch. Regression was caused by previous version dump :(
Comment 4 Wesley Shields freebsd_committer 2008-07-24 14:27:39 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wxs

I'll take it.
Comment 5 dfilter service freebsd_committer 2008-07-24 14:33:55 UTC
wxs         2008-07-24 13:33:41 UTC

  FreeBSD ports repository

  Modified files:
    www/awstats          Makefile 
  Log:
  - Avoid calling USE_DOS2UNIX on PNG files.
  
  PR:             ports/125930
  Submitted by:   "Beat Gätzi" <beat@chruetertee.ch>
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.40      +13 -1     ports/www/awstats/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Wesley Shields freebsd_committer 2008-07-24 14:34:02 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!