Bug 126848 - [usb]: USB Keyboard hangs during Installation
Summary: [usb]: USB Keyboard hangs during Installation
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-26 08:20 UTC by mercuree
Modified: 2017-12-31 22:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mercuree 2008-08-26 08:20:01 UTC
When booting from installation CD, I get to the Beastie menu and can select boot options. 

Kernel continues to boot until I get to country selection menu where my keyboard hangs ccompletely, no lights, nothing.

I have tried the following:

At the beastie menu I push 6 to enter extra commands and have entered:

set hint.atkbd.0.flags="0x1"
boot - s

as well as

set hint.atkbd.0.disabled="1"
boot

neither of these options has helped.

When the kernel is booting it detects my keyboard as an Eleen USB Keyboard on ukbd0.

I will try to find a way to output all the info it show while booting.

Sofar I have googled a couple of different search terms but nothing exactly matching this problem.

have also tried both #BSD and ##FreeBSD on irc.freenode.net and no luck either.

How-To-Repeat: According to most people I have spoken to they have never come a cross such a problem. I did not have this problem on either gentoo or ubuntu (hoary as well as hardy) on the same system. 

The keyboard functions perfectly while navigating through the bios as well as the beastie menu. 

As far as I have found most people who have this problem have it with laptops. I am using a Desktop pc with a gigabyt GA6VM7a mobo. The kb is a generic asus usb keyboard.

I have tried both freebsd 5 (couple months ago) as well as 7.0 (yesterday) both have the same problem.
Comment 1 Remko Lodder 2008-08-26 09:08:28 UTC
Hello,

can you try changing the usb port you use to connect the usb-keyboard to?
try to use the very first usb port.

thanks!
remko

-- 
/"\   Best regards,                      | remko@FreeBSD.org
\ /   Remko Lodder                       | remko@EFnet
 X    http://www.evilcoder.org/          |
/ \   ASCII Ribbon Campaign              | Against HTML Mail and News
Comment 2 Remko Lodder freebsd_committer 2008-08-27 07:33:46 UTC
State Changed
From-To: open->feedback

I asked for feedback 


Comment 3 Remko Lodder freebsd_committer 2008-08-27 07:33:46 UTC
Responsible Changed
From-To: freebsd-i386->freebsd-usb

Move to the USB team
Comment 4 tarn 2008-08-27 18:09:08 UTC
Hi. Thanks for the prompt response. I have tried both USB ports. Problem
still occures with both of them. I have noticed that htey keyboard
lights flash as the keyboard is detected and then i think that is when
it dies.
Comment 5 Artis Caune 2008-08-29 10:28:58 UTC
could you try with:
    set hint.kbdmux.0.disabled="1"




-- 
regards,
Artis Caune

<----. CCNA
<----|====================
<----' didii FreeBSD
Comment 6 info 2008-09-01 10:14:09 UTC
I will try that tonight when I get home from work and submit a follow-up
with my findings. Thanks.

 

Regards 



Tarn Alcock 






Xpress Network Solutions 
Support Department 
Email:  <mailto:info@xnets.co.za> info@xnets.co.za 
Skype: xnets_support 
Office: 0861 XNETS 1 (8am-5pm) 
After Hours: 083 232 7818 
www.xnets.co.za
Comment 7 fp 2009-01-13 03:03:22 UTC
After having this problem on a Dell Optiplex 210L with FreeBSD 6.4, I just discovered a - strange - workaround.
 
When a new kernel is compiled without the fdc device (floppy), it appears that the ukbd1 device is correctly detected.
This is the first time I succeed to get a running keyboard with FreeBSD 6.4 on that platform (no PS/2 keyboard connector)
 
It might be the same issue
Hope this might help to fix the problem

Regards

Francois Pollet
Continuity
Belgium
Comment 8 david.guedj 2009-03-08 11:44:32 UTC
I'm facing the exact same problem with 7.1 installation CD. USB Keyboard 
stop working as soon as the kernel loads. The mainboard is a Gigabyte 
GA-EP35C-DS3R. The problem is known to happen frequently on Gigabyte 
motherboards. I've tried myriad Linux distribution and none had this 
kind of problem.
I've no other fix than unplug/plug the keyboard to make it working again.
Comment 9 Gavin Atkinson freebsd_committer freebsd_triage 2009-08-24 14:21:32 UTC
State Changed
From-To: feedback->open

Feedback was received some time ago.
Comment 10 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:00 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped