Bug 127107 - [patch] Fix graphics/jogl dependencies
Summary: [patch] Fix graphics/jogl dependencies
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Edwin Groothuis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-05 10:00 UTC by Peter Jeremy
Modified: 2008-09-06 01:48 UTC (History)
0 users

See Also:


Attachments
file.diff (933 bytes, patch)
2008-09-05 10:00 UTC, Peter Jeremy
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Jeremy 2008-09-05 10:00:10 UTC
Add missing build dependencies.  No PORTREVISION bump because this is
build-time only.

Reported by:    pointyhat

Fix: Patch attached with submission follows:
How-To-Repeat: Install jogl dependencies as packages then build jogl.  It will fail to build, reporting
       [cc] In file included from /work/a/ports/graphics/jogl/work/jogl/src/native/jogl/JAWT_DrawingSurfaceInfo.c:40:
       [cc] /usr/local/jdk1.6.0/include/freebsd/jawt_md.h:13:27: error: X11/Intrinsic.h: No such file or directory

See (eg):
http://pointyhat.freebsd.org/errorlogs/i386-errorlogs/a.8.20080819154558/jogl-1.1.1.log

The problem is that build dependencies in jogl are incomplete, though this isn't apparent if java is built as a port.
Comment 1 Edwin Groothuis freebsd_committer 2008-09-05 10:56:47 UTC
State Changed
From-To: open->feedback

Can yuo please see if 

USE_XORG=       xproto xt xf86vidmodeproto
Comment 2 Edwin Groothuis freebsd_committer 2008-09-05 10:56:47 UTC
Responsible Changed
From-To: freebsd-ports-bugs->edwin

I'll trakc it.
Comment 3 dfilter service freebsd_committer 2008-09-06 01:34:05 UTC
edwin       2008-09-06 00:33:56 UTC

  FreeBSD ports repository

  Modified files:
    graphics/jogl        Makefile 
  Log:
  [patch] Fix graphics/jogl dependencies
  
  PR:             ports/127107
  Submitted by:   Peter Jeremy <peterjeremy@optushome.com.au>
  
  Revision  Changes    Path
  1.2       +5 -10     ports/graphics/jogl/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Edwin Groothuis freebsd_committer 2008-09-06 01:48:11 UTC
State Changed
From-To: feedback->closed

Committed, thanks!