Bug 127323 - [MAINTAINER] Update net-mgmt/vidalia to 0.1.9
Summary: [MAINTAINER] Update net-mgmt/vidalia to 0.1.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-12 15:30 UTC by Fabian Keil
Modified: 2008-09-30 13:10 UTC (History)
0 users

See Also:


Attachments
file.diff (1.87 KB, patch)
2008-09-12 15:30 UTC, Fabian Keil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2008-09-12 15:30:00 UTC
The attached patch updates net-mgmt/vidalia to 0.1.9.

Several versions were skipped due to cmake issues in the past.

Thanks to Henry Hu for testing with FreeBSD 7-STABLE on i386.

Vidalia works for me on 8.0-CURRENT/amd64 but dumps
core on 8.0-CURRENT/i386 right after starting it:

fk@TP51 ~ $vidalia 
terminate called after throwing an instance of '__gnu_cxx::__concurrence_lock_error'
  what():  __gnu_cxx::__concurrence_lock_error
Abort trap: 6 (core dumped)
fk@TP51 ~ $gdb `which vidalia` vidalia.core  
GNU gdb 6.1.1 [FreeBSD]
[...]
Loaded symbols for /libexec/ld-elf.so.1
#0  0x2945e5b7 in kill () from /lib/libc.so.7
[New Thread 0x8401040 (LWP 100162)]
(gdb) where
#0  0x2945e5b7 in kill () from /lib/libc.so.7
#1  0x2945e516 in raise () from /lib/libc.so.7
#2  0x2945d13a in abort () from /lib/libc.so.7
#3  0x292ceef0 in __gnu_cxx::__verbose_terminate_handler () from /usr/lib/libstdc++.so.6
#4  0x292d370a in std::set_unexpected () from /usr/lib/libstdc++.so.6
#5  0x292d3752 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0x292d364a in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0x292eac56 in __cxa_guard_acquire () from /usr/lib/libstdc++.so.6
#8  0x287d063c in loader () from /usr/local/lib/qt4/libQtGui.so.4
#9  0x287d088f in QStyleFactory::keys () from /usr/local/lib/qt4/libQtGui.so.4
#10 0x080b534a in VidaliaSettings::VidaliaSettings ()
#11 0x08100797 in Vidalia::setLanguage ()
#12 0x08101775 in Vidalia::Vidalia ()
#13 0x080fe959 in main ()

I didn't mark it as broken on 8.0-CURRENT/i386
because I haven't ruled out local problems yet.

Given that the Vidalia version currently in the
ports stopped working with recent Tor versions,
it's not a real regression anyway.

Fix: Patch attached with submission follows:
Comment 1 Martin Wilke freebsd_committer 2008-09-12 15:32:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2008-09-25 23:09:46 UTC
State Changed
From-To: open->feedback

Hi, 

Build failed on amd64 and i386, could you please take a look? 

http://i386.miwibox.org/index.php?action=describe_port&id=693 
http://amd64.miwibox.org/index.php?action=describe_port&id=719 

Thanks
Comment 3 Martin Wilke freebsd_committer 2008-09-30 13:03:34 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!
Comment 4 dfilter service freebsd_committer 2008-09-30 13:03:39 UTC
miwi        2008-09-30 12:03:25 UTC

  FreeBSD ports repository

  Modified files:
    net-mgmt/vidalia     Makefile distinfo 
  Added files:
    net-mgmt/vidalia     pkg-plist 
  Log:
  - Update to 0.1.9
  
  PR:             127323
  Submitted by:   Fabian Keil <fk@fabiankeil.de> (maintainer)
  
  Revision  Changes    Path
  1.12      +4 -18     ports/net-mgmt/vidalia/Makefile
  1.7       +3 -3      ports/net-mgmt/vidalia/distinfo
  1.1       +3 -0      ports/net-mgmt/vidalia/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"