Bug 127491 - math/octave can crash with "malloc(): error: recursive call"
math/octave can crash with "malloc(): error: recursive call"
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Maho Nakata
Depends on:
  Show dependency treegraph
Reported: 2008-09-19 06:30 UTC by stephen
Modified: 2009-05-26 03:10 UTC (History)
0 users

See Also:

file.diff (504 bytes, patch)
2008-09-19 06:30 UTC, stephen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description stephen 2008-09-19 06:30:09 UTC
octave can crash with "malloc(): error: recursive call".

This seems to happen intermittently when installing any of the octave-forge-*
ports, either using ports or packages.

The problem seems to be caused by a signal handler that invokes malloc.
My guess is that it is in octave-3.0.2/src/sighandlers.cc inside
octave_child_list::instance_ok, which is called via octave_child_list::reap
in octave_signal_handler.

Fix: First install PR ports/127490.

Then apply this patch:
How-To-Repeat: Run the script
sh -c "while true; do killall -CHLD octave-3.0.2; done"
and at the same time install some of the octave-forge-* ports, either from
ports or packages.  It will not happen every time.

I can make this happen with FreeBSD-6.x, but not with FreeBSD-8.x.  I have
only tried it with the amd64 architecture, not i386, so I don't know if it is
a problem with i386.
Comment 1 Edwin Groothuis freebsd_committer 2008-09-19 07:03:05 UTC
Responsible Changed
From-To: freebsd-ports-bugs->maho

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter freebsd_committer 2009-05-26 03:03:53 UTC
maho        2009-05-26 02:03:38 UTC

  FreeBSD ports repository

  Modified files:
    math/octave          Makefile 
  Fix a commit for prior than FBSD7.
  Original patch has been slighlty modified.
  PR:             127491
  Submitted by:   Stephen Montgomery-Smith
  Revision  Changes    Path
  1.98      +9 -0      ports/math/octave/Makefile
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Maho Nakata freebsd_committer 2009-05-26 03:04:01 UTC
State Changed
From-To: open->closed

Committed, thanks!