Bug 127946 - editors/openoffice.org-3 dictionary extension doesn't install
Summary: editors/openoffice.org-3 dictionary extension doesn't install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-08 16:50 UTC by Mike Durian
Modified: 2009-06-14 21:40 UTC (History)
0 users

See Also:


Attachments
ooextpatches.shar (4.58 KB, text/plain)
2009-03-07 13:54 UTC, hg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Durian 2008-10-08 16:50:01 UTC
	The editors/openoffice.org-3 (BEB300_m3) dictionary is not
	available in the application.  Googling tells me that the dictionary
	is now an extension in version 3.  I located the dictionary extension
	file and tried to install it manually using unopkg:

	LD_LIBRARY_PATH=/usr/local/openoffice.org-3.0.0.b2/openoffice.org/basis3.0/program:/usr/local/openoffice.org-3.0.0.b2/openoffice.org/ure/lib /usr/local/openoffice.org-3.0.0.b2/openoffice.org3/program/unopkg add ./dict-en.oxt

	I get the following error:
	ERROR: Error while adding: file:///usr/home/durian/dict-en.oxt
       		Cause: bad tranfer url

	I've located the source of this error.  It occurs in
		ucb/source/ucp/file/bc.cxx
		BaseContent::transfer()
	Specifically,
	    if( aTransferInfo.SourceURL.compareToAscii( "file:",5 ) != 0 )
	is failing.

	This doesn't make sense to me since unopkg displays
	"file:///usr/home/durian/dict-en.oxt"

	I don't have a version of unopkg with debugging symbols, so
	I haven't been able to trace this any further.

How-To-Repeat: 	See above for the unopkg command I used.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2008-10-08 23:20:27 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 2 Brodey Dover 2008-11-22 06:13:23 UTC
Hello,

I would also like to second this. I have looked for other instances of a 
TransferInfo object and I can't see any initialization of the 
aTransferInfo.SourceURL before the mentioned if-statement. I am doing 
some more attempts at fixing this and will respond if I can patch the 
issue before it is resolved.

This occurs in PC-BSD 1.5.1 and with the RC port. I haven't tested the 
devel port yet.

Regards,
Brodey
Comment 3 hg 2009-01-30 18:59:49 UTC
Nikola Lec(ic' posted instructions on a great workaround to install OO2 
dictionaries at 
http://unix.derkeiler.com/Mailing-Lists/FreeBSD/questions/2008-11/msg00454.html 
.

It's not a fix for the issue but it is a fix for a complaining user.
Comment 4 hg 2009-02-21 18:23:17 UTC
Howard Goldstein wrote on 30 Jan:
   Nikola Lec(ic' posted instructions on a great workaround to install OO2
>  dictionaries at 
>  http://unix.derkeiler.com/Mailing-Lists/FreeBSD/questions/2008-11/msg00454.html 
>  .
>  
>  It's not a fix for the issue but it is a fix for a complaining user.

UPDATE: Bad news, now even the workaround no longer works with the 
current ports tree editors/openoffice.org-3 release 
openoffice.org-3.0.1.    Same breakage in OO3-RC

This is really awful, maintainer please help.  All dictionary 
functionality in OO3 is broken and completely, totally gone :(
Comment 5 mela 2009-03-03 18:59:05 UTC
This is a severe problem. A problem that sadly forces me to switch from 
FreeBSD to Windows.
As a writing person, my daily work depends totally on dictionaries and 
some other extensions.

Isn't there the slightest hope for help?

-- 
Mela Eckenfels - Freie Autorin - Mörscher Straße 8 - 76185 Karlsruhe
eMail: mela@eckenfels.net - Web: http://mela.eckenfels.net/
Blog: http://mela.de/ -  Das LARP-Kochbuch: http://larpkochbuch.de/
Das Kochbuch für Geeks: http://www.oreilly.de/catalog/geeksckbkger/

Opinions of some Geeks - http://www.eckes.org/
Comment 6 hg 2009-03-07 13:54:47 UTC
This bug was first fixed by the OO folks at openoffice issue# 22253 but 
the fix contained an inadvertent regression "time bomb." The bug 
pertains to exception catching in the OO RTL.  It only occurs when 
building on releases >= FreeBSD7.0.

The shar has patches for openoffice.org-3 and openoffice.org-3-RC on  
i386 (tested on 7.1-STABLE) and x86-64 (untested) targets.  The patch 
depends on another of our patches, thus the naming patches-zz...     is 
important to sequence the patch applications.

A similar patch should work for the devel release.  This or a similar 
patch needs to be included in *all* future OO3 portversions releases 
until the underlying source @openoffice.org is fixed





Comment 7 petyo 2009-03-12 00:23:12 UTC
    Hello,
    I applied the patch and it fixed the problem! :) (FreeBSD 7.1 and
ports up to date) :)
    Thank you very much and keep up the good work!


    Best regards,
    Petyo Milotinov
Comment 8 JImmie James 2009-04-29 06:00:52 UTC
As of today, ed Apr 29 00:59:10 EDT 2009,  this no longer applies

FreeBSD 7.2-PRERELEASE #0: Sat Mar 21 22:34:18 EDT 2009 
jimmie@jimmiejaz.org:/usr/obj/usr/src/sys/FORTYTWO
openoffice.org-3.0.1 Integrated 
wordprocessor/dbase/spreadsheet/drawing/chart/br

[0:47:50]  jimmie@jimmiejaz <105> [0] 
/usr/ports/editors/openoffice.org-3#/bin/sh shar-1.sh
x - editors/openoffice.org-3/files/patch-zzi22253-regressed090307
shar-1.sh: cannot create 
editors/openoffice.org-3/files/patch-zzi22253-regressed090307: No such 
file or directory
x - editors/openoffice.org-3-RC/files/patch-zzi22253-regressed090307
shar-1.sh: cannot create 
editors/openoffice.org-3-RC/files/patch-zzi22253-regressed090307: No 
such file or directory


[0:51:26]  jimmie@jimmiejaz <103> [0] 
/usr/ports/editors/openoffice.org-3>ls -alR ../openoffice.org-3/
total 28
drwxr-xr-x    3 root  100    512 Apr 29 00:52 .
drwxr-xr-x  199 100   100   4608 Mar 16 09:39 ..
-rw-r--r--    1 root  100  11411 Feb  4 13:03 Makefile
-rw-r--r--    1 root  100    981 Feb  4 13:03 distinfo
drwxr-xr-x    2 root  100   1024 Apr 29 00:52 files
-rw-r--r--    1 root  100    830 Oct 18  2006 pkg-descr
-rw-r--r--    1 root  100     70 Oct 18  2006 pkg-plist
-rwxr-xr-x  1 root  100   4688 Apr 29 00:47 shar-1.sh

../openoffice.org-3/files:
total 136
drwxr-xr-x  2 root  100   1024 Apr 29 00:52 .
drwxr-xr-x  3 root  100    512 Apr 29 00:52 ..
-rw-r--r--  1 root  100   3780 Jan  6 00:11 Makefile.knobs
-rw-r--r--  1 root  100  13191 Apr 19  2008 Makefile.localized
-rw-r--r--  1 root  100   3244 Oct 14  2008 Makefile.others
-rw-r--r--  1 root  100   1417 May 27  2008 generate.pl
-rw-r--r--  1 root  100    388 Jul 14  2008 openoffice.org-wrapper
-rw-r--r--  1 root  100    416 Mar 28  2008 patch-i65514
-rw-r--r--  1 root  100    428 Sep 21  2007 patch-i65974
-rw-r--r--  1 root  100   3498 Sep 21  2007 patch-i73217
-rw-r--r--  1 root  100   4621 Apr  6  2008 patch-i75190
-rw-r--r--  1 root  100   1077 Jul 14  2008 patch-i80129
-rw-r--r--  1 root  100    485 Oct 14  2008 patch-i84549
-rw-r--r--  1 root  100   1891 Mar 28  2008 patch-i84586
-rw-r--r--  1 root  100   1729 May 27  2008 patch-i85027
-rw-r--r--  1 root  100   5301 May 27  2008 patch-i85126
-rw-r--r--  1 root  100  43668 Jul 14  2008 patch-i85127
-rw-r--r--  1 root  100   2634 Jul 14  2008 patch-i85972
-rw-r--r--  1 root  100   2098 Jul 14  2008 patch-i87583
-rw-r--r--  1 root  100    630 May 27  2008 patch-i88156
-rw-r--r--  1 root  100    704 Nov 27 11:05 patch-i91318
-rw-r--r--  1 root  100    891 Aug 16  2008 patch-i91369
-rw-r--r--  1 root  100    753 Oct 14  2008 patch-i91861
-rw-r--r--  1 root  100   4120 Aug 28  2008 patch-i93235
-rw-r--r--  1 root  100    554 Feb  1 20:13 patch-i98714
-rw-r--r--  1 root  100   1209 Jul 14  2008 pkg-message.in
-rw-r--r--  1 root  100   1899 Sep 21  2007 rtld-workaround-i66667
-rwxr-xr-x  1 root  100   4688 Apr 29 00:47 shar-1.sh
Comment 9 JImmie James 2009-05-18 04:56:05 UTC
$luser error.  Applying the patch in the wrong directory 
usr/ports/editors/openoffice.org-3 instead of /usr/ports.

Applies cleanly. Compile time now.

Thanks and sorry for the noise.

-- 
Over the years I've come to regard you as people I've met.
Comment 10 Martin Wilke freebsd_committer 2009-05-31 00:05:13 UTC
State Changed
From-To: open->closed

seems to be fixed now.
Comment 11 dfilter service freebsd_committer 2009-06-14 21:26:55 UTC
maho        2009-06-14 20:26:41 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-2 Makefile 
    editors/openoffice.org-2/files patch-i85126 
  Added files:
    editors/openoffice.org-2/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Submitted by : many
  
  Revision  Changes    Path
  1.313     +1 -1      ports/editors/openoffice.org-2/Makefile
  1.2       +26 -0     ports/editors/openoffice.org-2/files/patch-i85126
  1.1       +24 -0     ports/editors/openoffice.org-2/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 dfilter service freebsd_committer 2009-06-14 21:29:49 UTC
maho        2009-06-14 20:29:40 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-2-RC Makefile 
    editors/openoffice.org-2-RC/files patch-i85126 
  Added files:
    editors/openoffice.org-2-RC/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Submitted by : many
  
  Revision  Changes    Path
  1.348     +1 -1      ports/editors/openoffice.org-2-RC/Makefile
  1.2       +26 -0     ports/editors/openoffice.org-2-RC/files/patch-i85126
  1.1       +24 -0     ports/editors/openoffice.org-2-RC/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 13 dfilter service freebsd_committer 2009-06-14 21:30:53 UTC
maho        2009-06-14 20:30:38 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-2-devel Makefile 
    editors/openoffice.org-2-devel/files patch-i85126 
  Added files:
    editors/openoffice.org-2-devel/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Submitted by : many
  
  Revision  Changes    Path
  1.371     +1 -1      ports/editors/openoffice.org-2-devel/Makefile
  1.2       +26 -0     ports/editors/openoffice.org-2-devel/files/patch-i85126
  1.1       +24 -0     ports/editors/openoffice.org-2-devel/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 dfilter service freebsd_committer 2009-06-14 21:36:48 UTC
maho        2009-06-14 20:36:37 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-3 Makefile 
    editors/openoffice.org-3/files patch-i85126 
  Added files:
    editors/openoffice.org-3/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  bump port revision
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Revision  Changes    Path
  1.318     +1 -0      ports/editors/openoffice.org-3/Makefile
  1.3       +124 -56   ports/editors/openoffice.org-3/files/patch-i85126
  1.1       +116 -0    ports/editors/openoffice.org-3/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 15 dfilter service freebsd_committer 2009-06-14 21:37:38 UTC
maho        2009-06-14 20:37:29 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-3-RC/files patch-i85126 
  Added files:
    editors/openoffice.org-3-RC/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Submitted by : many
  
  Revision  Changes    Path
  1.3       +124 -56   ports/editors/openoffice.org-3-RC/files/patch-i85126
  1.1       +116 -0    ports/editors/openoffice.org-3-RC/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 16 dfilter service freebsd_committer 2009-06-14 21:38:18 UTC
maho        2009-06-14 20:38:09 UTC

  FreeBSD ports repository

  Modified files:
    editors/openoffice.org-3-devel/files patch-i85126 
  Added files:
    editors/openoffice.org-3-devel/files patch-i98781 
  Log:
  Fix bad transfer url when tries to add extension.
  
  PR: 127946
  see also
  http://www.openoffice.org/issues/show_bug.cgi?id=98781
  http://www.openoffice.org/issues/show_bug.cgi?id=82690
  http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
  
  Submitted by : many
  
  Revision  Changes    Path
  1.3       +124 -56   ports/editors/openoffice.org-3-devel/files/patch-i85126
  1.1       +116 -0    ports/editors/openoffice.org-3-devel/files/patch-i98781 (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"