Bug 130153 - [MAINTAINER] archivers/lzo: add self-test
Summary: [MAINTAINER] archivers/lzo: add self-test
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-04 09:50 UTC by Matthias Andree
Modified: 2009-01-07 22:20 UTC (History)
0 users

See Also:


Attachments
lzo-1.08_2,1.patch (1.37 KB, patch)
2009-01-04 09:50 UTC, Matthias Andree
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Andree 2009-01-04 09:50:04 UTC
Adds self-test as recommended by INSTALL.
Excessively long self-test runs in lzo2 (a different port) were figured
(thanks, naddy@) to be caused by "J" in /etc/malloc.conf, so we set
MALLOC_OPTIONS=jz to avoid that.

Fix whitespace (blanks, rather than TAB, on GNU_CONFIGURE line) to
please portlint.

Added file(s):
- files/patch-util-check.sh

Generated with FreeBSD Port Tools 0.77
Comment 1 Martin Wilke freebsd_committer 2009-01-04 10:47:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2009-01-07 22:17:35 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 3 dfilter service freebsd_committer 2009-01-07 22:17:50 UTC
miwi        2009-01-07 22:17:25 UTC

  FreeBSD ports repository

  Modified files:
    archivers/lzo        Makefile 
  Added files:
    archivers/lzo/files  patch-util-check.sh 
  Log:
  - Adds self-test as recommended by INSTALL.
  
  Excessively long self-test runs in lzo2 (a different port) were figured
  (thanks, naddy@) to be caused by "J" in /etc/malloc.conf, so we set
  MALLOC_OPTIONS=jz to avoid that.
  
  PR:             130153
  Submitted by:   Matthias Andree <matthias.andree@gmx.de> (maintainer)
  
  Revision  Changes    Path
  1.38      +6 -1      ports/archivers/lzo/Makefile
  1.1       +11 -0     ports/archivers/lzo/files/patch-util-check.sh (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"