Bug 130845 - [patch] lang/ocaml update to 3.11.0
[patch] lang/ocaml update to 3.11.0
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Stanislav Sedov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 22:40 UTC by umq
Modified: 2009-04-11 14:30 UTC (History)
0 users

See Also:


Attachments
file.diff (6.92 KB, patch)
2009-01-21 22:40 UTC, umq
no flags Details | Diff
ocaml-3.11.0.patch (7.51 KB, patch)
2009-02-28 03:55 UTC, umq
no flags Details | Diff
ocaml-3.11.0_2.patch (7.55 KB, patch)
2009-03-15 23:46 UTC, umq
no flags Details | Diff
ocaml-lablgtk.patch (871 bytes, patch)
2009-03-15 23:46 UTC, umq
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description umq 2009-01-21 22:40:03 UTC
	The new version of lang/ocaml 3.11.0 has been released.
	WWW: http://caml.inria.fr/ocaml/release.en.html

Fix: The patch follows:

cvs diff: Diffing .
How-To-Repeat: 	N/A
Comment 1 Edwin Groothuis freebsd_committer 2009-01-21 22:40:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stas

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 umq 2009-02-28 03:55:48 UTC
I attach an update for the patch I sent previously.
supporting the change in default version of Tcl/Tk.

-- 

	Hirohisa Yamaguchi
	  umq@ueo.co.jp
Comment 3 Stanislav Sedov freebsd_committer 2009-03-13 23:07:23 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi!

Thanks for submitted patches. I'm a bit busy currently,
so I won't probably be able to dedicate fully for working
on ocaml update for one or two weeks.

In the meantime, can you, please, look at the some issued
with new ocaml. It seems that some ports are affected by upgrade
(e.g. advi doesn't build).

Thanks!
- -- 
Stanislav Sedov
ST4096-RIPE
-----BEGIN PGP SIGNATURE-----

iEYEARECAAYFAkm65ysACgkQK/VZk+smlYGgfgCdGu3KUy1zpdL/yLblvcT8fnxq
gHQAn3j84AYxOGkxfTu5YgsSZCwHWfxs
=GhTz
-----END PGP SIGNATURE-----

!DSPAM:49bae70d967001717012672!
Comment 4 turutani 2009-03-14 12:29:56 UTC
> In the meantime, can you, please, look at the some issued
> with new ocaml. It seems that some ports are affected by upgrade
> (e.g. advi doesn't build).

print/advi can be built with the following patch (also with ocaml-3.10.2):

--- Makefile.orig	2009-03-14 20:09:05.000000000 +0900
+++ Makefile	2009-03-14 20:06:24.000000000 +0900
@@ -44,6 +44,7 @@
 		-e 's,^(X11_INCLUDES[[:space:]]*=).*,\1-I${LOCALBASE}/include,' \
 		-e 's,install -m 644,\$${BSD_INSTALL_DATA},' \
 		-e 's,install -m 755,\$${BSD_INSTALL_PROGRAM},' \
+		-e 's,^LIBRARIES = graphics,LIBRARIES =,' \
 		${WRKSRC}/Makefile

 .include <bsd.port.mk>

I tried to build advi-1.72, but it is too hard to me...
In addtion, I do not know about the other ports.
Comment 5 umq 2009-03-15 23:46:47 UTC
Hi,

I attach the revised patch that fixes a problem noted by Mr. Tsurutani;
bsd.tcl.mk was not included correctly.
And I have not mentioned that files/patch-stdlib_Makefile is dropped.


> In the meantime, can you, please, look at the some issued
> with new ocaml. It seems that some ports are affected by upgrade
> (e.g. advi doesn't build).

There seem to be approximately 50 ports ocaml dependent.
I think there're two problem with the update with this pr:

 1. camlp4 in 3.11 has change in syntax (which was introduced in 3.10
    though)
 2. Tcl/Tk version support for 8.5 (not really relevant to 3.11)

1.
  For example, x11-toolkits/ocaml-lablgtk fails to build:
  | ===>  Building for ocaml-lablgtk-nognome-noglade-1.2.7_2
  | cd src && gmake all
  | gmake[1]: Entering directory `/usr/ports/x11-toolkits/ocaml-lablgtk/work/lablgtk-1.2.7/src'
  | camlp4o pr_o.cmo -impl varcc.ml4 -o varcc.ml
  | Error: don't know what to do with pr_o.cmo
  | Use option -help for usage
  | gmake[1]: *** [varcc.ml] Error 2
  | gmake[1]: Leaving directory `/usr/ports/x11-toolkits/ocaml-lablgtk/work/lablgtk-1.2.7/src'
  | gmake: *** [all] Error 2
  | *** Error code 2
  | 
  | Stop in /usr/ports/x11-toolkits/ocaml-lablgtk.
  | *** Error code 1
  | 
  | Stop in /usr/ports/x11-toolkits/ocaml-lablgtk.

  It looks hard to find and fix the problem for all ports.

2.
  I looked for ports that have Tcl/Tk version in their skeleton.
  and sent pr ports/132678, ports/132678 as you know.

  I don't know whether other ports have Tcl/Tk version embedded in
  their source.


Regards,

-- 

	Hirohisa Yamaguchi
	  umq@ueo.co.jp
Comment 6 Stanislav Sedov freebsd_committer 2009-04-11 14:23:41 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 7 dfilter freebsd_committer 2009-04-11 14:24:05 UTC
stas        2009-04-11 13:23:05 UTC

  FreeBSD ports repository

  Modified files:
    devel/deputy/files   patch-cil-Makefile.in 
    devel/omake          Makefile distinfo pkg-plist 
    lang/cduce           Makefile distinfo 
    lang/mtasc           Makefile 
    lang/mtasc/files     patch-basepath 
    lang/ocaml           Makefile distinfo pkg-plist 
    lang/ocaml/files     mann patch-camlp4-man_Makefile 
                         patch-configure 
    lang/ocamlduce       Makefile 
    print/advi           Makefile 
  Added files:
    devel/cil/files      patch-Makefile.in 
    devel/omake/files    patch-src_exec_omake_exec.ml 
    lang/mtasc/files     patch-extc_extc_stubs.c 
                         patch-mtasc_parser.ml 
    www/geneweb/files    patch-tools_Makefile.inc.unix 
  Removed files:
    lang/cduce/files     patch-parser_cduce_curl.ml 
    lang/ocaml/files     patch-stdlib_Makefile 
  Log:
  - Update lang/ocaml to 3.11.0. [1]
  - Fix devel/cil build with 3.11.0 by using proper object file name
  - Fix devel/deputy build with 3.11.0 by using proper object file name
  - Fix lang/mtasc. Ocamlp4 syntax has changed and usage of ';' as delimiters
    is not allowed now.
  - Fix usage message in lang/mtasc.
  - Implement a FreeBSD specific code for retriving the executable path in lang/mtasc.
  - Update devel/omake to 0.9.8.5.
  - Fix devel/omake compilation with 3.11 by dropping an unused reference from the code.
  - Fix www/geneweb build with 3.11 by not emitting errors for warnings.
  - Fix print/advi build. [2]
  - Update lang/cduce to 0.5.3 (this fixes build with ocaml 3.11.0).
  
  PR:             ports/130845 [1] [2] (based on)
  Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp> [1],
                  Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp> [2]
  
  Revision  Changes    Path
  1.3       +25 -0     ports/devel/cil/files/patch-Makefile.in (new)
  1.2       +25 -2     ports/devel/deputy/files/patch-cil-Makefile.in
  1.8       +4 -5      ports/devel/omake/Makefile
  1.3       +3 -3      ports/devel/omake/distinfo
  1.1       +11 -0     ports/devel/omake/files/patch-src_exec_omake_exec.ml (new)
  1.3       +2 -0      ports/devel/omake/pkg-plist
  1.11      +2 -3      ports/lang/cduce/Makefile
  1.6       +3 -3      ports/lang/cduce/distinfo
  1.2       +0 -18     ports/lang/cduce/files/patch-parser_cduce_curl.ml (dead)
  1.3       +1 -0      ports/lang/mtasc/Makefile
  1.2       +6 -4      ports/lang/mtasc/files/patch-basepath
  1.1       +42 -0     ports/lang/mtasc/files/patch-extc_extc_stubs.c (new)
  1.1       +40 -0     ports/lang/mtasc/files/patch-mtasc_parser.ml (new)
  1.62      +7 -8      ports/lang/ocaml/Makefile
  1.24      +3 -3      ports/lang/ocaml/distinfo
  1.2       +1 -0      ports/lang/ocaml/files/mann
  1.2       +5 -5      ports/lang/ocaml/files/patch-camlp4-man_Makefile
  1.11      +10 -7     ports/lang/ocaml/files/patch-configure
  1.2       +0 -12     ports/lang/ocaml/files/patch-stdlib_Makefile (dead)
  1.32      +16 -4     ports/lang/ocaml/pkg-plist
  1.5       +1 -0      ports/lang/ocamlduce/Makefile
  1.6       +1 -0      ports/print/advi/Makefile
  1.1       +13 -0     ports/www/geneweb/files/patch-tools_Makefile.inc.unix (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"