Bug 131111 - ports-mgmt/portupgrade-devel: completely removes package on installation error
ports-mgmt/portupgrade-devel: completely removes package on installation error
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 09:20 UTC by Gabor Kovesdan
Modified: 2012-06-02 10:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kovesdan freebsd_committer 2009-01-29 09:20:01 UTC
When a new version of a port fails, portupgrade sometimes completely removes
the port. In this case it should restore the backed up package.

How-To-Repeat: 
Don't really know, it happened with ftp/proftpd, here is the output below.
Note the marked sections, where the old package is backed up properly, but
then it is removed even if the installation failed.


--->  Upgrade of ftp/proftpd started at: Thu, 29 Jan 2009 09:44:59 +0100
--->  Upgrading 'proftpd-1.3.2.r4' to 'proftpd-1.3.2.r4_1' (ftp/proftpd)
OK? [yes]
--->  Build of ftp/proftpd started at: Thu, 29 Jan 2009 09:49:05 +0100
--->  Building '/usr/ports/ftp/proftpd'
===>  Cleaning for proftpd-1.3.2.r4_1
===>  Found saved configuration for proftpd-1.3.1_11
===>  Extracting for proftpd-1.3.2.r4_1
=> MD5 Checksum OK for proftpd-1.3.2rc4.tar.bz2.
=> SHA256 Checksum OK for proftpd-1.3.2rc4.tar.bz2.
=> No MD5 checksum recorded for mod_clamav-0.10.tar.bz2.
=> No SHA256 checksum recorded for mod_clamav-0.10.tar.bz2.
=> No suitable checksum found for mod_clamav-0.10.tar.bz2.
=> No MD5 checksum recorded for mod_digest.c.
=> No SHA256 checksum recorded for mod_digest.c.
=> No suitable checksum found for mod_digest.c.
*** Error code 1

Stop in /usr/ports/ftp/proftpd.
*** Error code 1

Stop in /usr/ports/ftp/proftpd.
--->  Build of ftp/proftpd ended at: Thu, 29 Jan 2009 09:49:06 +0100 (consumed 00:00:01)
--->  Updating dependency info
--->  Uninstallation of proftpd-1.3.2.r4 started at: Thu, 29 Jan 2009 09:49:09 +0100
--->  Fixing up dependencies before creating a package
--->  Backing up the old version
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
--->  Uninstalling the old version
--->  Deinstalling 'proftpd-1.3.2.r4'
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 764 packages found (-1 +0) (...) done]
--->  Uninstallation of proftpd-1.3.2.r4 ended at: Thu, 29 Jan 2009 09:49:16 +0100 (consumed 00:00:07)
--->  Installation of ftp/proftpd started at: Thu, 29 Jan 2009 09:49:16 +0100
--->  Installing the new version via the port
===>  Found saved configuration for proftpd-1.3.1_11
===>  Extracting for proftpd-1.3.2.r4_1
=> MD5 Checksum OK for proftpd-1.3.2rc4.tar.bz2.
=> SHA256 Checksum OK for proftpd-1.3.2rc4.tar.bz2.
=> No MD5 checksum recorded for mod_clamav-0.10.tar.bz2.
=> No SHA256 checksum recorded for mod_clamav-0.10.tar.bz2.
=> No suitable checksum found for mod_clamav-0.10.tar.bz2.
=> No MD5 checksum recorded for mod_digest.c.
=> No SHA256 checksum recorded for mod_digest.c.
=> No suitable checksum found for mod_digest.c.
*** Error code 1

Stop in /usr/ports/ftp/proftpd.
*** Error code 1

Stop in /usr/ports/ftp/proftpd.
*** Error code 1

Stop in /usr/ports/ftp/proftpd.
===>  Cleaning for proftpd-1.3.2.r4_1
--->  Removing temporary files and directories
--->  Removing old package'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
--->  Installation of ftp/proftpd ended at: Thu, 29 Jan 2009 09:49:18 +0100 (consumed 00:00:02)
--->  Cleaning out obsolete shared libraries
--->  Upgrade of ftp/proftpd ended at: Thu, 29 Jan 2009 09:49:22 +0100 (consumed 00:04:23)
Comment 1 Edwin Groothuis freebsd_committer 2009-01-29 09:20:39 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sem

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Sergey Matveychuk freebsd_committer 2009-02-02 14:44:49 UTC
Yeap. Sometimes portupgrade did not see the port instalation had a 
problem. I don't know why yet.
-- 
Dixi.
Sem.
Comment 3 Mark Linimon freebsd_committer 2009-07-25 02:49:21 UTC
Responsible Changed
From-To: sem->ruby

sem@ has turned over maintainership of portupgrade to the ruby mailing list.
Comment 4 amdmi3 2010-04-30 16:31:28 UTC
Hi!

Just for the record: the similar problem appeared after Mar 2010 because
of /usr/bin/script breakage in 9-CURRENT and 8-STABLE:

http://www.freebsd.org/cgi/query-pr.cgi?pr=146189

it can't possibly be the cause of the problem in this PR, however this
info may be useful to people who run into similar problem.

-- 
Dmitry Marakasov   .   55B5 0596 FF1E 8D84 5F56  9510 D35A 80DD F9D2 F77D
amdmi3@amdmi3.ru  ..:  jabber: amdmi3@jabber.ru    http://www.amdmi3.ru
Comment 5 Philip M. Gollucci freebsd_committer 2010-09-10 00:11:09 UTC
Responsible Changed
From-To: ruby->pgollucci

I will take it
Comment 6 Philip M. Gollucci freebsd_committer 2010-09-24 07:22:06 UTC
Responsible Changed
From-To: pgollucci->freebsd-ports-bugs

going to have enotime for the next 2 weeks, sorry
Comment 7 steve freebsd_committer 2011-01-03 17:18:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ruby

Over to maintainer(s).
Comment 8 Philip M. Gollucci freebsd_committer 2012-02-22 05:23:15 UTC
State Changed
From-To: open->suspended

Over to maintainer. 


Comment 9 Philip M. Gollucci freebsd_committer 2012-02-22 05:23:15 UTC
Responsible Changed
From-To: ruby->freebsd-ports-bugs

Over to maintainer.
Comment 10 Chris Rees freebsd_committer 2012-04-12 11:02:55 UTC
State Changed
From-To: suspended->open

This should not be suspended.
Comment 11 dfilter freebsd_committer 2012-06-02 10:48:59 UTC
bapt        2012-06-02 09:48:45 UTC

  FreeBSD ports repository

  Modified files:
    ports-mgmt/portupgrade-devel Makefile distinfo pkg-descr 
                                 pkg-plist 
  Log:
  Port changes
  - Convert to new options framework
  - Sync pkg-message with devel/portupgrade
  portupgrade changes
  - portupgrade/portinstall -v now lists recursive depends [ports/137958]
  - portupgrade lists new version after upgrade in results
  - Fixed failure being seen as success due to broken script(1) [ports/147242,
    ports/131111]
  - A fixed script(1) is now included for systems < 8.1
  - Expanded pkgng support
  
  PR:             ports/168548 which fixes: ports/137958 ports/147242 ports/131111
  Submitted by:   Bryan Drewery <bryan@shatow.net>
  
  Revision  Changes    Path
  1.286     +14 -4     ports/ports-mgmt/portupgrade-devel/Makefile
  1.195     +2 -2      ports/ports-mgmt/portupgrade-devel/distinfo
  1.24      +1 -2      ports/ports-mgmt/portupgrade-devel/pkg-descr
  1.43      +3 -0      ports/ports-mgmt/portupgrade-devel/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Baptiste Daroussin freebsd_committer 2012-06-02 10:49:03 UTC
State Changed
From-To: open->closed

Fixed in portupgrade-devel