Bug 131576 - [aue] ADMtek USB To LAN Converter can't send data
Summary: [aue] ADMtek USB To LAN Converter can't send data
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: 7.1-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-11 01:20 UTC by Matheus
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matheus 2009-02-11 01:20:00 UTC
I have an aue device that detects ok, but can't send data. tcpdump can read from wire though.

the dmesg:
aue0: <ADMtek USB To LAN Converter, class 255/0, rev 1.10/2.01, addr 2> on uhub1
miibus3: <MII bus> on aue0
ukphy1: <Generic IEEE 802.3u media interface> PHY 1 on miibus3
ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
aue0: Ethernet address: 00:60:6e:00:05:d2
aue0: link state changed to DOWN
aue0: link state changed to UP
aue0: usb error on rx: IOERROR
aue0: at uhub1 port 1 (addr 2) disconnected
aue0: detached

usbdevs -v:
Controller /dev/usb0:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), VIA(0x0000), rev 1.00
 port 1 powered
 port 2 addr 2: full speed, power 160 mA, config 1, USB To LAN Converter(0x8513), ADMtek(0x07a6), rev 2.01


I read from 4.9 days in mailing lists a problem quite close to this, but on ADM8511, this is ADM8513

Fix: 

Use usb2 code.
How-To-Repeat: Just plug the adapter.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:03 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped