Bug 132327 - New port: devel/psptoolchain-newlib
Summary: New port: devel/psptoolchain-newlib
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Marcelo Araujo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-05 10:10 UTC by Tassilo Philipp
Modified: 2009-08-21 02:06 UTC (History)
0 users

See Also:


Attachments
psptoolchain-newlib.shar (338.74 KB, text/plain)
2009-03-05 10:10 UTC, Tassilo Philipp
no flags Details
psptoolchain-newlib-files-patch-newlib-libc-sys-psp-configure.diff (3.15 KB, patch)
2009-04-06 01:20 UTC, Tassilo Philipp
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tassilo Philipp 2009-03-05 10:10:04 UTC

    
Comment 1 Marcelo Araujo freebsd_committer 2009-03-11 20:54:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->araujo

I'll take it.
Comment 2 araujobsdport 2009-03-15 18:16:16 UTC
Hello Tassilo,

I tried some minutes ago to work in your ports, but I need that you build   
again two shar because there are some errors when I uncompressed it.

Error:
araujo@ponderosa new> sh 132327
c - psptoolchain-newlib
x - psptoolchain-newlib/pkg-descr
x - psptoolchain-newlib/Makefile
c - psptoolchain-newlib/files
x - psptoolchain-newlib/files/patch-configure.in
x - psptoolchain-newlib/files/patch-newlib-Makefile.in
x - psptoolchain-newlib/files/patch-newlib-libc-include-sys-config.h
132327: 136: Syntax error: Illegal eof marker for << redirection



Best Regards,

-- 
Marcelo Araujo
araujo@FreeBSD.org
http://www.FreeBSD.org
If at first you don't succeed,
blame it on your supervisor.
Comment 3 Tassilo Philipp 2009-04-03 23:33:19 UTC
Hi,

sorry, I never got your mail... so I didn't answer. Just discovered on the
FreeBSD PR database that you did write me...
I'll look at this ASAP and send you the shars again.

Cheers,
Tassilo
Comment 4 Marcelo Araujo freebsd_committer 2009-04-04 15:43:06 UTC
State Changed
From-To: open->feedback

Feedback received. Thanks!
Comment 5 Tassilo Philipp 2009-04-04 15:49:55 UTC
Hi,

well, I tried to recreate the shar, but I kept getting the same errors, so I traced that down. Seems that sh(1) doesn't like long '<< EOF' markers. IMHO, this is a sh(1) bug. Extracting the archive with ksh (or simply making the markers shorter for sh(1)) works fine for me.

So, I would suggest extracting the archives manually with ksh, I think that will be the easiest way. Please let me know if there are any other problems.

Since I didn't get your first mails, and I don't know why (I don't use a spam filter ATM), could you please cc: to t.licht@laposte.net?

Thanks!
Cheers
Tassi
Comment 6 araujobsdport 2009-04-05 01:22:42 UTC
Aloha,

Could you please take a look in these errors?
Seems that some patchs can't be applied cleanly.

Error:

===>  Patching for psptoolchain-newlib-1.15.0
===>  Applying FreeBSD patches for psptoolchain-newlib-1.15.0
patch: **** malformed patch at line 279:  VEL_0_TRUE ELIX_LEVEL_0_FALSE
ELIX_LEVEL_1_TRUE ELIX_LEVEL_1_FALSE ELIX_LEVEL_2_TRUE ELIX_LEVEL_2_FALSE
ELIX_LEVEL_3_TRUE ELIX_LEVEL_3_FALSE ELIX_LEVEL_4_TRUE ELIX_LEVEL_4_FALSE
USE_LIBTOOL_TRUE USE_LIBTOOL_FALSE OBJEXT oext aext lpfx libm_machine_dir
machine_dir sys_dir LIBOBJS LTLIBOBJS'
=> Patch patch-newlib-libc-sys-psp-configure failed to apply cleanly.
=> Patch(es) patch-config.sub patch-configure
patch-configure.inpatch-newlib-Makefile.am patch-newlib-Makefile.in
patch-newlib-configure.host patch-newlib-libc-include-machine-time.h
patch-newlib-libc-include-sys-config.h patch-newlib-libc-include-sys-types.h
patch-newlib-libc-include-time.h patch-newlib-libc-sys-configure
patch-newlib-libc-sys-configure.in patch-newlib-libc-sys-psp-Makefile.am
patch-newlib-libc-sys-psp-Makefile.in patch-newlib-libc-sys-psp-README
patch-newlib-libc-sys-psp-aclocal.m4 patch-newlib-libc-sys-psp-arpa-inet.h
patch-newlib-libc-sys-psp-confdefs.h applied cleanly.
*** Error code 1

Stop in /c/ports/updates/my/new/ports/devel/psptoolchain-newlib.


Best Regards,
-- 
Marcelo Araujo
araujo@FreeBSD.org
Comment 7 Tassilo Philipp 2009-04-06 01:20:41 UTC
I think that in the original patch, the line that results in the error is
too long. I don't know why this happens on your machine, because I can't
reproduce this error. However, from the error output you did send me, the
line seems to be clipped of. Perhaps during unpacking of the shar archive?

Well, I simply splitted this line now, and I hope that this will work.
Find attached a diff of the patch that fails to apply on your machine.

thx
Comment 8 Marcelo Araujo freebsd_committer 2009-05-11 15:52:29 UTC
State Changed
From-To: feedback->open

- Feedback received.
Comment 9 Marcelo Araujo freebsd_committer 2009-05-22 04:11:25 UTC
State Changed
From-To: open->feedback

- Ask maintainer to fix some issues.
Comment 10 araujobsdport 2009-05-22 04:14:33 UTC
On Sun, May 17, 2009 at 02:55:05PM -0500, Tassilo Philipp wrote:
> Hi,
> 
> that's great news, thanks! Thanks for working on that with me, I learned quite a few details about contributing new ports, etc.
> 
> Thanks,
> Tassilo


Hello Tassilo,

So, I tried to build and fix these ports during the few days ago, but It
doesn't build fine on Tinderbox, I can build this in my machine, but I saw
that there are many pkg-plist wrongs, but in anyway this isn't the worst
situation. However I'd like to ask you to take a look again on these ports.

I put my Tinderbox on the web and you can take a look by yourself there, I
put all ports to build again and you can see all the full log.

Tinderbox: http://200.247.114.7:8081/tb/index.php?action=latest_buildports#current

We'd like to have these ports on ports tree, check all dependencies again,
you can use to help you this tool ports-mgmt/porttools, try to use "port
test" that is included in porttools.

So, I'm waiting your reply and I'm here to do everything to help you.


Best Regards,
-- 
Marcelo Araujo
araujo@FreeBSD.org
http://www.FreeBSD.org
Forgive and remember.
Comment 11 Marcelo Araujo freebsd_committer 2009-06-07 15:27:41 UTC
State Changed
From-To: feedback->suspended

It doesn't build fine, I'm waiting a maintainer fix.
Comment 12 Marcelo Araujo freebsd_committer 2009-08-20 15:51:39 UTC
State Changed
From-To: suspended->open

- Feedback received.
Comment 13 Marcelo Araujo freebsd_committer 2009-08-21 02:06:43 UTC
State Changed
From-To: open->closed

New port added, with minor changes. Thanks!