Bug 132535 - [acpi] if ACPI enabled, i can't change brightness level on Acer Extensa 5620 laptop
Summary: [acpi] if ACPI enabled, i can't change brightness level on Acer Extensa 5620 ...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: 7.1-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 10:30 UTC by Székvölgyi Péter
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments
devinfo.out2 (13.51 KB, text/plain)
2009-03-11 17:49 UTC, Székvölgyi Péter
no flags Details
dmesg.out2 (10.42 KB, text/plain)
2009-03-11 17:49 UTC, Székvölgyi Péter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Székvölgyi Péter 2009-03-11 10:30:01 UTC
If i boot without ACPI i have brightness controll on my mashine, but i miss lot of thinks from acpi. If i started the computer with ACPI I haven't brightness control. Anything on ACPI probably work fine.

I run on XOrg the xev program and it send me keycode for the volume up/down,
brightness up/down if ACPI enabled.

My Custon kernel only:
include         GENERIC
ident           DZSYNOTE

device          atapicam

How-To-Repeat: Everytime i boot with ACPI enabled.
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2009-03-11 15:18:10 UTC
State Changed
From-To: open->feedback

To submitter: have you loaded the acpi_asus module? 


Comment 2 Gavin Atkinson freebsd_committer freebsd_triage 2009-03-11 15:18:10 UTC
Responsible Changed
From-To: freebsd-i386->gavin

Track
Comment 3 Gavin Atkinson freebsd_committer freebsd_triage 2009-03-11 17:02:59 UTC
On Wed, 2009-03-11 at 16:31 +0100, Sz=E9kv=F6lgyi P=E9ter wrote:
> gavin@FreeBSD.org wrote:
> > To submitter: have you loaded the acpi_asus module?
> >
> Yes, I tested with all notebook modell kernel modul, nothing changed.

Could you please provide the output of the "dmesg" and "devinfo -rv"
commands?
Comment 4 Székvölgyi Péter 2009-03-11 17:49:29 UTC
I booted-et without hw.acpi.osname="Windows 2001" in loaders.conf.
And i attached the dmesg and devinfo again.

Regards,
Peter

Comment 5 Székvölgyi Péter 2009-05-23 02:16:38 UTC
Gavin Atkinson wrote:
> On Wed, 2009-03-11 at 16:31 +0100, Székvölgyi Péter wrote:
>   
>> gavin@FreeBSD.org wrote:
>>     
>>> To submitter: have you loaded the acpi_asus module?
>>>
>>>       
>> Yes, I tested with all notebook modell kernel modul, nothing changed.
>>     
>
> Could you please provide the output of the "dmesg" and "devinfo -rv"
> commands?
>   
I booted my mashine with verbose mode, and if a want to change my brightness
i saw in dmesg ( brightness down with key ):
acpi: bad write to port 0x080 (32), val 0x1d
or ( brightness up with key )
acpi: bad write to port 0x080 (32), val 0x1c

I didn't load acpi_asus at this time.

I tested with other dsdt file from google acer acpi, nothing changed:
http://aceracpi.googlecode.com/svn/trunk/dsdt/acer/extensa/

If you want you can see the dmesg with verbose mode on this url:
http://phoenix.dzsy.org/~ghostp/dmesg.out
and devinfo -rv:
http://phoenix.dzsy.org/~ghostp/devinfo.out

I install FreeBSD-Current to an usb key and booted. The error is the 
same with
brightness control.

Now my system is:
FreeBSD dzsy-note.dzsy.org 7.2-STABLE FreeBSD 7.2-STABLE #0: Sat May 23 
01:25:19 CEST 2009     
root@dzsy-note.dzsy.org:/usr/obj/usr/src/sys/DZSYNOTE  i386

Thanks your help!

Best regards,
Peter
Comment 6 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:27 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped