Bug 134015 - [patch] graphics/mapnik should install library with correct name
Summary: [patch] graphics/mapnik should install library with correct name
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-26 12:20 UTC by Gleb Smirnoff
Modified: 2009-05-20 22:50 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (3.29 KB, patch)
2009-04-26 12:20 UTC, Gleb Smirnoff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Smirnoff freebsd_committer 2009-04-26 12:20:00 UTC
	The graphics/mapnik port installs its shlib as libmapnik.so.0.5.0,
	while in FreeBSD it is common to use only major lib version for
	library file name.

	Now I am working on a port that will be linked to mapnik library,
	and I first need to get mapnik fixed to get my port committed.

How-To-Repeat: 	Install graphics/mapnik.
Comment 1 Edwin Groothuis freebsd_committer 2009-04-26 12:20:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->glebius

Submitter has GNATS access (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2009-04-26 12:20:13 UTC
Maintainer of graphics/mapnik,

Please note that PR ports/134015 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/134015

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2009-04-26 12:20:15 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 Gleb Smirnoff freebsd_committer 2009-04-26 13:22:15 UTC
Responsible Changed
From-To: glebius->freebsd-ports-bugs

Back to the pool, since I don't have ports commit bit.
Comment 5 wenheping 2009-04-26 14:45:21 UTC
I approve it.
Thank you!


Regards,
wen
Comment 6 Martin Wilke freebsd_committer 2009-05-17 09:43:05 UTC
State Changed
From-To: feedback->closed

6.0 is now in portstree.
Comment 7 Gleb Smirnoff freebsd_committer 2009-05-18 09:14:05 UTC
State Changed
From-To: closed->open

Well, 6.0 is now in portstree, but the problem is still here. I'll submit 
updated patch soon.
Comment 8 dfilter service freebsd_committer 2009-05-20 22:48:00 UTC
stas        2009-05-20 21:47:51 UTC

  FreeBSD ports repository

  Modified files:
    graphics/mapnik      Makefile pkg-plist 
  Added files:
    graphics/mapnik/files patch-src-SConscript 
  Log:
  - Use proper name for the shared library.
  
  PR:             ports/134015
  Submitted by:   glebius
  Approved by:    wen heping <wenheping@gmail.com> (maintainer)
  
  Revision  Changes    Path
  1.4       +1 -0      ports/graphics/mapnik/Makefile
  1.1       +41 -0     ports/graphics/mapnik/files/patch-src-SConscript (new)
  1.3       +1 -2      ports/graphics/mapnik/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Stanislav Sedov freebsd_committer 2009-05-20 22:48:09 UTC
State Changed
From-To: open->closed

Committed. Thanks!