Bug 134219 - Mark www/kompozer BROKEN for all
Summary: Mark www/kompozer BROKEN for all
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-05 04:10 UTC by Joseph S. Atkinson
Modified: 2009-06-08 07:50 UTC (History)
1 user (show)

See Also:


Attachments
kompozer_is_dead.diff (475 bytes, patch)
2009-05-05 04:10 UTC, Joseph S. Atkinson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph S. Atkinson 2009-05-05 04:10:01 UTC

The problems with KompoZer aren't limited to any specific architecture. Both i386 and amd64 also crash when menus are selected as well. This appears to be a known issue with more recent GTKs, and it doesn't look like upstream intends to fix it.

This port, however, is not dead, as they are actively working on an upcoming 0.8 which hypothetically will not not have any issue with modern GTK editions. Until some progress is made to fix this, or 0.8 comes along, mark BROKEN across the board to save people the headache and disappointment building/using and unstable product.

* "KompoZer 0.7 crashes with GTK 2.14" -- Kazé @ http://kazhack.org/?post/2009/04/02/KompoZer-0.8a

How-To-Repeat: 

Install kompozer (ports or packages, any arch), start playing with the menus. Crash will occur on nested menus, where the majority of features and usablity are.
Comment 1 Edwin Groothuis freebsd_committer 2009-05-05 04:10:18 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gecko

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Martin Wilke freebsd_committer 2009-05-11 12:15:11 UTC
Responsible Changed
From-To: gecko->freebsd-gecko

Over to maintainer.
Comment 3 dfilter service freebsd_committer 2009-06-08 07:46:08 UTC
miwi        2009-06-08 06:45:53 UTC

  FreeBSD ports repository

  Modified files:
    www/kompozer         Makefile 
  Log:
  - Mark BROKEN: KompoZer 0.7.10 is not compatible with
    GTK 2.14 and higher, hence the crashes.
  
  PR:             134219
  Submitted by:   "Joseph S. Atkinson" <jsa@wickedmachine.net>
  
  Revision  Changes    Path
  1.40      +2 -0      ports/www/kompozer/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Martin Wilke freebsd_committer 2009-06-08 07:46:09 UTC
State Changed
From-To: open->closed

Committed. Thanks!