Bug 135164 - [keyboard] UK currency key inactive
Summary: [keyboard] UK currency key inactive
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-01 22:40 UTC by Graham Bentley
Modified: 2018-05-21 00:02 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Bentley 2009-06-01 22:40:00 UTC
After loading up a minimal install of 7.2 and accepting the default shell, I noticed that the UK currency key is inactive [£] at the console. When the key is pressed the system beeps. Oddly at 'Login:' if I press the key I get the £ symbol but as soon as I am logged in as a user I get a beep. All the other keys are correct. If I plug in my 7.1 disc I get the £ symbol no problem. I have tried a re-install [minimal] with a different [full size ps2] keyboard to no avail. I have tried various keymaps and fonts and still no £ symbol.

The motherbaord is an ASUS M2N68-AM [not sure what the kb controller chip is]
Comment 1 Ian Goddard 2016-09-20 10:56:20 UTC
Problem still exists on 11.0 beta. The ¬ key is also inactive.  The unshifted 3 and ` are OK however.  All other punctuation seems OK.  Keyboard is Chesen USB, motherboard is Asrock Q1900TM-ITX
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-20 23:59:55 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"