Bug 135222 - [igb] low speed routing between two igb interfaces
Summary: [igb] low speed routing between two igb interfaces
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 7.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: Eric Joyner
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2009-06-03 19:30 UTC by Mishustin Andrew
Modified: 2018-05-29 15:03 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mishustin Andrew 2009-06-03 19:30:01 UTC
I made a FreeBSD multiprocesor server to act as simple gateway.
It use onboard Intel 82575EB Dual-Port Gigabit Ethernet Controller.
I observe traffic speed near 400 Kbit/s.
I test both interfaces separately -
ftp client work at speed near 1 Gbit/s in both directions.
Then I change NIC to old Intel "em" NIC - gateway work at speed near 1 Gbit/s.

Looks like a bug in igb driver have an effect upon forwarded traffic.

If you try
hw.igb.enable_aim=0
The speed is near 1 Mbit/s

hw.igb.rxd, hw.igb.txd, "ifconfig -tso" has no effect.

Nothing in messages.log

netstat -m
516/1674/2190 mbufs in use (current/cache/total)
515/927/1442/66560 mbuf clusters in use (current/cache/total/max)
515/893 mbuf+clusters out of packet secondary zone in use (current/cache)
0/44/44/33280 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/16640 9k jumbo clusters in use (current/cache/total/max)
0/0/0/8320 16k jumbo clusters in use (current/cache/total/max)
1159K/2448K/3607K bytes allocated to network (current/cache/total)
0/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

I use only IPv4 traffic.

How-To-Repeat: On machine with two igb interfaces
use rc.conf like this:

hostname="test.test"
gateway_enable="YES"
ifconfig_igb0="inet 10.10.10.1/24"
ifconfig_igb1="inet 10.10.11.1/24"

And try create heavy traffic between two networks.
Comment 1 Michael Gmelin 2009-06-04 08:41:22 UTC
Hello Andrew,

look at my post "Bug in igb driver" from two days ago.
We had exactly the same issues using this adapter (and presumambly the
same board, your bug description matches 100% our setup :)

The following should fix those issues:

echo "dev.igb.0.enable_lro=0" >>/etc/sysctl.conf
echo "dev.igb.1.enable_lro=0" >>/etc/sysctl.conf
reboot

(this disabled large receive offloading - tuning this while the machine
is running has no effect).

I suggested putting this into the release errata, but got no feedback on
this request so far.

cheers
Michael
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2009-06-12 06:46:45 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 3 Michael Gmelin 2009-06-12 10:45:47 UTC
The original poster reported that the suggested fix works for him:
---
Hello Michael,

Thank you. It's working.

I consider it necessary to put this into the release errata.
Comment 4 Michael Gmelin 2009-06-18 02:32:15 UTC
Barney Cordoba wrote:
> 
> 
> --- On Wed, 6/17/09, Michael <freebsdusb@bindone.de> wrote:
> 
>> From: Michael <freebsdusb@bindone.de>
>> Subject: Re: kern/135222: [igb] low speed routing between two igb interfaces
>> To: "Barney Cordoba" <barney_cordoba@yahoo.com>
>> Cc: freebsd-net@FreeBSD.org
>> Date: Wednesday, June 17, 2009, 5:28 PM
>> Barney Cordoba wrote:
>>>
>>> --- On Fri, 6/12/09, Michael <freebsdusb@bindone.de>
>> wrote:
>>>> From: Michael <freebsdusb@bindone.de>
>>>> Subject: Re: kern/135222: [igb] low speed routing
>> between two igb interfaces
>>>> To: freebsd-net@FreeBSD.org
>>>> Date: Friday, June 12, 2009, 5:50 AM
>>>> The following reply was made to PR
>>>> kern/135222; it has been noted by GNATS.
>>>>
>>>> From: Michael <freebsdusb@bindone.de>
>>>> To: Cc: freebsd-gnats-submit@FreeBSD.org
>>>> Subject: Re: kern/135222: [igb] low speed routing
>> between
>>>> two igb interfaces
>>>> Date: Fri, 12 Jun 2009 11:45:47 +0200
>>>>
>>>>   The original poster reported that the
>> suggested fix works
>>>> for him:
>>>>   ---
>>>>   Hello Michael,
>>>>   
>>>>   Thank you. It's working.
>>>>   
>>>>   I consider it necessary to put this into the
>> release
>>>> errata.
>>>>   
>>>>   
>>>>   Mishustin Andrew wrote:
>>>>   >> Number:     
>>>>     135222
>>>>   >> Category:   
>>    kern
>>>>   >> Synopsis:   
>>    [igb]
>>>> low speed routing between two igb interfaces
>>>>   >> Confidential:   no
>>>>   >> Severity:   
>>    serious
>>>>   >> Priority:   
>>    medium
>>>>   >> Responsible:   
>> freebsd-bugs
>>>>   >> State:       
>>   open
>>>>   >> Quarter:       
>>>>   >> Keywords:   
>>    
>>>>   >> Date-Required:
>>>>   >> Class:       
>>   sw-bug
>>>>   >>
>> Submitter-Id:   current-users
>>>>   >> Arrival-Date:   Wed
>> Jun 03
>>>> 18:30:01 UTC 2009
>>>>   >> Closed-Date:
>>>>   >> Last-Modified:
>>>>   >> Originator: 
>>    Mishustin
>>>> Andrew
>>>>   >> Release:       
>> FreeBSD
>>>> 7.1-RELEASE amd64, FreeBSD 7.2-RELEASE amd64
>>>>   >> Organization:
>>>>   > HNT
>>>>   >> Environment:
>>>>   > FreeBSD test.hnt 7.2-RELEASE FreeBSD
>> 7.2-RELEASE #12:
>>>> Thu Apr 30 18:28:15 MSD 20
>>>>   > 09     admin@test.hnt:/usr/src/sys/amd64/compile/GENERIC
>>>> amd64
>>>>   >> Description:
>>>>   > I made a FreeBSD multiprocesor server
>> to act as
>>>> simple gateway.
>>>>   > It use onboard Intel 82575EB Dual-Port
>> Gigabit
>>>> Ethernet Controller.
>>>>   > I observe traffic speed near 400
>> Kbit/s.
>>>>   > I test both interfaces separately -
>>>>   > ftp client work at speed near 1 Gbit/s
>> in both
>>>> directions.
>>>>   > Then I change NIC to old Intel "em" NIC
>> - gateway
>>>> work at speed near 1 Gbit/s.
>>>>   > 
>>>>   > Looks like a bug in igb driver have an
>> effect upon
>>>> forwarded traffic.
>>>>   > 
>>>>   > If you try
>>>>   > hw.igb.enable_aim=0
>>>>   > The speed is near 1 Mbit/s
>>>>   > 
>>>>   > hw.igb.rxd, hw.igb.txd, "ifconfig -tso"
>> has no
>>>> effect.
>>>>   > 
>>>>   > Nothing in messages.log
>>>>   > 
>>>>   > netstat -m
>>>>   > 516/1674/2190 mbufs in use
>> (current/cache/total)
>>>>   > 515/927/1442/66560 mbuf clusters in
>> use
>>>> (current/cache/total/max)
>>>>   > 515/893 mbuf+clusters out of packet
>> secondary zone in
>>>> use (current/cache)
>>>>   > 0/44/44/33280 4k (page size) jumbo
>> clusters in use
>>>> (current/cache/total/max)
>>>>   > 0/0/0/16640 9k jumbo clusters in use
>>>> (current/cache/total/max)
>>>>   > 0/0/0/8320 16k jumbo clusters in use
>>>> (current/cache/total/max)
>>>>   > 1159K/2448K/3607K bytes allocated to
>> network
>>>> (current/cache/total)
>>>>   > 0/0/0 requests for mbufs denied
>>>> (mbufs/clusters/mbuf+clusters)
>>>>   > 0/0/0 requests for jumbo clusters
>> denied (4k/9k/16k)
>>>>   > 0/0/0 sfbufs in use (current/peak/max)
>>>>   > 0 requests for sfbufs denied
>>>>   > 0 requests for sfbufs delayed
>>>>   > 0 requests for I/O initiated by
>> sendfile
>>>>   > 0 calls to protocol drain routines
>>>>   > 
>>>>   > I use only IPv4 traffic.
>>>>   > 
>>>>   >> How-To-Repeat:
>>>>   > On machine with two igb interfaces
>>>>   > use rc.conf like this:
>>>>   > 
>>>>   > hostname="test.test"
>>>>   > gateway_enable="YES"
>>>>   > ifconfig_igb0="inet 10.10.10.1/24"
>>>>   > ifconfig_igb1="inet 10.10.11.1/24"
>>>>   > 
>>>>   > And try create heavy traffic between
>> two networks.
>>>>   >> Fix:
>>>>   > 
>>>>   > 
>>>>   >> Release-Note:
>>>>   >> Audit-Trail:
>>>>   >> Unformatted:
>>>>   >
>> _______________________________________________
>>>>   > freebsd-bugs@freebsd.org
>>>
>>> This is not a bug. Unless you consider poorly written
>> drivers to be bugs. You need to provide your tuning
>> parameters for the card as well otherwise there's nothing to
>> learn.
>>> The issue is that the driver doesn't address the
>> purpose of the controller; which is to utilize
>> multiprocessor systems more effectively. The effect is that
>> lock contention actually makes things worse than if you just
>> use a single task as em does. Until the multiqueue drivers
>> are re-written to manage locks properly you are best advised
>> to save your money and stick with em.
>>> You should get similar performance using 1 queue as
>> with em. You could also force legacy configuration by
>> forcing igb_setup_msix to return 0. Sadly, this is the best
>> performance you will get from the stock driver.
>>> Barney
>>>
>>> Barney
>>>
>>>
>>>        
>> I tried using 1 queue and it didn't make things any better
>> (actually I'm
>> not sure if that worked at all). If it is considered a bug
>> or not
>> doesn't really matter, what actually matters for users (who
>> cannot
>> always chose which network controller will be on-board) is
>> that they get
>> a least decent performance when doing IP forwarding (and
>> not the
>> 5-50kb/s I've seen). You can get this out of the
>> controller, when
>> disabling lro through the sysctl. That's why I've been
>> asking to put
>> this into the release errata section and/or at least the
>> igb man page,
>> because the sysctl isn't documented anywhere. Also the
>> fact, that tuning
>> the sysctl only affects the behaviour when it's set on boot
>> might be
>> considered problematic.
>>
>> So at the very least, I think the following should be
>> done:
>> 1. Document the sysctl in man igb(4)
>> 2. Put a known issues paragraph to man igb(4) which
>> explains the issue
>> and what to put in sysctl.conf to stop this from happening
>> 3. Add an entry to the release errata page about this issue
>> (like I
>> suggested in one of my earlier emails) and stating
>> something like "see
>> man igb(4) for details)
>>
>> This is not about using the controller to its full
>> potential, but to
>> safe Joe Admin from spending days on figuring out why the
>> machine is
>> forwarding packages slower than his BSD 2.x machine did in
>> the 90s.
>>
>> cheers
>> Michael
> 
> None of the offload crap should be enabled by default. 
> 
> The real point is that "Joe Admin" shouldn't be using controllers that have bad drivers at all. If you have to use whatever hardware you have laying around, and don't have enough flexibility to lay out $100 for a 2 port controller that works to use with your $2000 server, than you need to get your priorities in order. People go out and buy redundant power supplies, high GHZ quad core processors and gobs of memory and then they use whatever crappy onboard controller they get no matter how poorly its suppo rted. Its mindless.
> 
> Barney
> 
> 
>       

How should anybody know that the controller is poorly supported if there
is nothing in the documentation, release notes, man pages or anywhere
else about this?

The fact of the matter is that "the offload crap" _is_ enabled by
default. The release is out, it claims to support the controller. There
_is_ a workaround and I'm asked if somebody could document this so users
will have a chance. I'm also not convinced that it is a crappy
controller per se, but just poorly supported. We used those a lot before
without any issues, unfortunately now we had touse IP forwarding in a
machine that has that controller (it has 6 interfaces in total, four em
ports and two igb ports, all of them are in use and I don't feel like
hooking up the sodering iron).

So bottomline:
I said, there is a problem with the driver, there is a workaround and it
should be documented.

You say, the driver is bad and nobody should use it and if they do it's
their own damn fault. We won't do anything about it and refuse to tell
anybody, because we are the only ones who should know. We don't care if
people can actually use our software and still claim the hardware is
actually supported.

Your attitude is really contra productive (actually googling around I
see  you made similar statements in the past about stupid people not
willing to spend xxx$ on whatever piece of hardware, so maybe you're
just trolling).

Michael
Comment 5 josh 2009-07-13 20:57:20 UTC
We had this same problem with our SuperMicro box and have been stumped  
since switching our interface to igb.  Thanks Michael for the work  
around... I hope they put this in the errata, it certainly would have  
helped us a great deal.



Best regards,

Joshua Reynolds
President
J-Tech Communications

jtechcommunications.com

406-586-7100 (ph)
406-586-1584 (fx)
888-586-3000 (tf)
Comment 6 Andre Oppermann freebsd_committer 2010-08-23 18:51:40 UTC
Responsible Changed
From-To: freebsd-net->jfv

Over to maintainer.
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2015-11-12 07:43:52 UTC
Reassign to erj@ for triage.  To submitter: is this issue still relevant?
Comment 8 Stefan B. 2017-12-04 17:59:02 UTC
Almost a year ago I tried to set up a PC using IGB board for usage as local network gateway and router etc using 11.0 Release.

I finally gave up that attempt because I seemed unable to achieve acceptable data transfer rate. Didn't do actual measurements, but it was probably not far away from the 400Kbit the OP reported.
I believed that this was the result of my incompetence, maybe some misconfiguration etc, although there was no configuration difference to PCs using em interfaces.

But that report and the confirmations, including my experience, suggest that the problem is still there.

I have to set up another machine using IGB board late this month.
I will do accurate measurements then.
Comment 9 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:42:53 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.