Bug 135593 - net-im/ejabberd: ram_file_io_server makes ejabberdevel to not run with R13B_logl
Summary: net-im/ejabberd: ram_file_io_server makes ejabberdevel to not run with R13B_logl
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-15 13:20 UTC by Bartosz Stec
Modified: 2009-07-28 08:20 UTC (History)
0 users

See Also:


Attachments
patch-src-dynamic_compile.erl (13.96 KB, text/plain; x-mac-type="0"; x-mac-creator="0")
2009-07-10 07:52 UTC, gwright
no flags Details
patch-src-ejabberd_loglevel.erl (2.29 KB, text/plain; x-mac-type="0"; x-mac-creator="0")
2009-07-10 07:52 UTC, gwright
no flags Details
patch-src-ram_file_io_server.erl (12.36 KB, text/plain; x-mac-type="0"; x-mac-creator="0")
2009-07-10 07:52 UTC, gwright
no flags Details
patch-src-ejabberd.app (257 bytes, text/plain; x-mac-type="0"; x-mac-creator="0")
2009-07-10 07:52 UTC, gwright
no flags Details
ejabberd.diff (41.20 KB, patch)
2009-07-22 13:35 UTC, Ulrich Spoerlein
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Stec 2009-06-15 13:20:03 UTC
Ejabberd won't run after ERLANG upgrade to newest release in ports and won't tell you why, because logging is the cause of the problem. Occasionaly it could drop core. Detailed description is here:
https://support.process-one.net/browse/EJAB-919

Fix: 

Applying patches from the bottom of https://support.process-one.net/browse/EJAB-919 fixed problem for me. Port should be updated to newer version from SVN with patches already merged or just need additional patches before 'make' for version 2.0.5
How-To-Repeat: #portupgrade lang/erlang
#pkg_info | grep erlang
erlang-r13b01_4,1   A functional programming language from Ericsson
#/usr/local/etc/rc.d/ejabberd restart
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2009-06-15 18:23:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->shaun

Over to maintainer.
Comment 2 takeda 2009-06-28 10:13:53 UTC
What's holding this?
I spent so much time today figuring out what did I broke in my
ejabberd just to realize that the problem was an upgrade...

Please, patch is already available just apply it to the ports to at
least save others the trouble.
Comment 3 Armin Pirkovitsch 2009-07-07 08:03:31 UTC
Had the same problem - ejabberd didn't work after the erlang update.

Those patches fixed it for me too (I could have saved some time by
looking here first, instead of looking for the solution myself...)

btw. maitainer timeout?

Armin
-- 
Armin Pirkovitsch
a.pirko@inode.at
Comment 4 gwright 2009-07-10 07:52:24 UTC
Attached are the patches that made ejabberd-2.0.5 work for me with 
erlang R13b01
(fixes PR135593).

Greg

-- 
Gregory Wright
Antiope Associates LLC
18 Clay Street
Fair Haven, New Jersey 07704
USA

gwright@antiope.com

+1 (732) 924-4549
+1 (732) 345-8378 [fax]
Comment 5 Bartosz Stec 2009-07-15 10:31:34 UTC
It's a month now, port is still broken, despite fixes was available from 
the beginning. Does anyone care ;)? I'm not sure if I really should 
bother with filling another PRs.

-- 
Bartosz Stec
Comment 6 Shaun Amott freebsd_committer 2009-07-22 03:27:27 UTC
Responsible Changed
From-To: shaun->freebsd-ports-bugs

No longer under my maintainership.
Comment 7 Ulrich Spoerlein 2009-07-22 13:35:20 UTC
Hello Bartosz,

providing a patch against the port, not some random patch against a
distfile usually improves the chances of someone comitting it.

Attached is a test patch against the current port, it works both with
the old erlang port (v12) and new current one (v13). It is the official
patch from https://support.process-one.net/browse/EJAB-919 and will come
out with ejaberd 2.1.0.

Regards,
Uli
Comment 8 dfilter service freebsd_committer 2009-07-28 08:11:10 UTC
miwi        2009-07-28 07:11:02 UTC

  FreeBSD ports repository

  Modified files:
    net-im/ejabberd      Makefile 
  Added files:
    net-im/ejabberd/files patch-919-fileioserver 
  Log:
  - Fix crash after latest erlang update
  
  PR:             135593
  Submitted by:   Bartosz Stec <admin@kkip.pl>
  
  Revision  Changes    Path
  1.32      +1 -0      ports/net-im/ejabberd/Makefile
  1.1       +1219 -0   ports/net-im/ejabberd/files/patch-919-fileioserver (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Martin Wilke freebsd_committer 2009-07-28 08:11:39 UTC
State Changed
From-To: open->closed

Committed. Thanks!