Bug 135828 - [patch] graphics/py-cairo: specify the version 1.8.4 needs Python >= 2.6
[patch] graphics/py-cairo: specify the version 1.8.4 needs Python >= 2.6
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gnome
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 11:40 UTC by rea-fbsd
Modified: 2009-06-19 12:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rea-fbsd 2009-06-19 11:40:02 UTC
py-cairo version 1.8.4 requires Python 2.6+ inside its configure script.
The following diagnostics is seen when one tries to build the port with
system Python being at 2.5:
-----
checking whether /usr/local/bin/python2.5 version >= 2.6... configure:
error: too old
-----

Fix: The following patch will require Python 2.6+:


From my experience, multiple Pythons in the system will coexist just
fine, but a general upgrade, say, from Python 2.5 to Python 2.6 is the
pain in the butt.--KJhsDT5RvV00CWMP1t0GYiMa5INHRS1FJV3GUDK7uDeP5zy3
Content-Type: text/plain; name="py-cairo-1.8.4-require-Python-2.6.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="py-cairo-1.8.4-require-Python-2.6.diff"

begin 644 py-cairo-1.8.4-require-Python-2.6.diff
M1G)O;2`W9C0X.3,T-F$S-C5B8F,S-C0X-#`X,V)D,CAF860R9#AC,F%D9&(S
M($UO;B!397`@,3<@,#`Z,#`Z,#`@,C`P,0I&<F]M.B!%>6=E;F4@4GEA8FEN
M:VEN(#QR96$M9F)S9$!C;V1E;&%B<RYR=3X*1&%T93H@1G)I+"`Q.2!*=6X@
M,C`P.2`Q-#HR,3HT-B`K,#0P,`I3=6)J96-T.B!;4$%40TA=(&=R87!H:6-S
M+W!Y+6-A:7)O.B!R97%U:7)E(%!Y=&AO;B`^/2`R+C8*"D-A:7)O(&)I;F1I
M;F=S(#$N."XT(')E<75I<F4@;6]D97)N(%!Y=&AO;B!I;G-I9&4@:71S(&-O
M;F9I9W5R92!S8W)I<'0L"G-O('!O<G0@8G5I;&1I;F<@=VEL;"!F86EL('=I
M=&@@86YY=&AI;F<@;&]W97(@=&AA;B`R+C8N"@I3:6=N960M;V9F+6)Y.B!%
M>6=E;F4@4GEA8FEN:VEN(#QR96$M9F)S9$!C;V1E;&%B<RYR=3X*+2TM"B!G
M<F%P:&EC<R]P>2UC86ER;R]-86ME9FEL92!\("`@(#(@*RT*(#$@9FEL97,@
M8VAA;F=E9"P@,2!I;G-E<G1I;VYS*"LI+"`Q(&1E;&5T:6]N<R@M*0H*9&EF
M9B`M+6=I="!A+V=R87!H:6-S+W!Y+6-A:7)O+TUA:V5F:6QE(&(O9W)A<&AI
M8W,O<'DM8V%I<F\O36%K969I;&4*:6YD97@@.#,Y.#$R92XN8C8V93)B."`Q
M,#`V-#0*+2TM(&$O9W)A<&AI8W,O<'DM8V%I<F\O36%K969I;&4**RLK(&(O
M9W)A<&AI8W,O<'DM8V%I<F\O36%K969I;&4*0$`@+3$X+#<@*S$X+#<@0$`@
M0T]-345.5#T)4'ET:&]N(&)I;F1I;F=S(&9O<B!#86ER;PH@"B!,24)?1$50
M14Y$4ST)8V%I<F\N,CHD>U!/4E131$E2?2]G<F%P:&EC<R]C86ER;PH@"BU5
M4T5?4%E42$]./0EY97,**U5315]0651(3TX]"3(N-BL*(%5315]'34%+13T)
M>65S"B!54T5?1TY/344]"6=N;VUE=&%R9V5T(&=N;VUE:&%C:PH@1TY57T-/
:3D9)1U5213T)>65S"BTM(`HQ+C8N,RXR"@H`
`
end
How-To-Repeat: 
Install only Python < 2.6 and try to build graphics/py-cairo.
Comment 1 Edwin Groothuis freebsd_committer 2009-06-19 11:40:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter freebsd_committer 2009-06-19 12:01:00 UTC
bland       2009-06-19 11:00:52 UTC

  FreeBSD ports repository

  Modified files:
    graphics/py-cairo    Makefile 
  Log:
  Require Python 2.6+
  
  PR:             135828
  
  Revision  Changes    Path
  1.27      +1 -1      ports/graphics/py-cairo/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Alexander Nedotsukov freebsd_committer 2009-06-19 12:01:09 UTC
State Changed
From-To: open->closed

My fault. 
Committed, thanks!