Bug 135911 - [MAINTAINER] security/gpgme: Update to version 1.2.0
[MAINTAINER] security/gpgme: Update to version 1.2.0
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Wesley Shields
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 09:10 UTC by bsdkaffee
Modified: 2009-07-15 17:52 UTC (History)
0 users

See Also:


Attachments
2009-06-22-gpgme.diff (19.59 KB, patch)
2009-06-22 09:10 UTC, bsdkaffee
no flags Details | Diff
ayttm-0.5.0.82_1.diff.txt (575 bytes, text/plain; charset=US-ASCII)
2009-07-03 13:49 UTC, unixmania
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bsdkaffee 2009-06-22 09:10:02 UTC
- Update security/gpgme to version 1.2.0.
- Shared library version bump from libgpgme*.so.17 -> libgpgme*.so.18.
- Use smaller bz2 distfiles instead
- Mark MAKE_JOBS_SAFE

Note: Changes to library were mostly additional functions, so there shouldn't
be any compatibility troubles.  I build-tested all ports that require gpgme by
default with no issues.  I also run-tested the library with kdepimlibs-4.2.4
and kdepim-4.2.4 with success.

How-To-Repeat: Use attached diff to update the security/gpgme port.
The following ports depend on security/gpgme and need a PORTREVISION bump:
deskutils/basket
deskutils/kdepim3
deskutils/kdepim4
deskutils/kdepimlibs4
devel/bazaar
finance/qhacc
mail/balsa
mail/claws-mail
mail/mutt-devel
mail/sylpheed
mail/sylpheed2
net-im/ayttm
net-im/centericq
net-im/centerim
net-im/centerim-devel
net-im/mcabber
security/gpa
security/openvas-libnasl
security/pecl-gnupg
security/py-pyme
security/seahorse

Some of the above ports specifically reference gpgme.17 and need to be updated
to gpgme.18; they are:
deskutils/basket
devel/bazaar
finance/qhacc
mail/balsa
mail/sylpheed
mail/sylpheed2
net-im/ayttm
net-im/centericq
net-im/centerim
net-im/centerim-devel
net-im/mcabber
security/openvas-libnasl
security/pecl-gnupg
security/seahorse
Comment 1 Wesley Shields freebsd_committer 2009-06-22 13:57:27 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wxs

I'll take it.
Comment 2 Udo.Schweigert 2009-07-02 15:59:43 UTC
The mail/mutt-devel patch is OK and can be committed.

Regards

Udo
Comment 3 bsdkaffee 2009-07-02 21:10:20 UTC
I thought I would post my patches as a follow-up since discussion regarding this
new version of gpgme is scattered about various lists and in private emails.

Here is the synopsis:  gpgme 1.2.0 requires that gpgme_check_version()  is
called before using gpgme_new().  Certain ports do not do this namely:
deskutils/kdepim3
deskutils/kdepim4
deskutils/kdepimlibs4
devel/bazaar
finance/qhacc
mail/mutt-devel
net-im/ayttm
net-im/centericq
net-im/centerim
net-im/centerim-devel
security/openvas-libnasl

The patches for deskutils/kde* came from upstream (thanks to makc@) that I 
reworked into our ports framework.  The rest of the patches I made myself.  I
did run-test deskutils/kdepim4, finance/qhacc, net-im/ayttm, and net-im/centerim
the best that I could and they seem fine.

These patches only patch the source files and pkg-plists.  Makefiles still need
to be updated with PORTREVISON bumps and bumping the shlib version of gpgme.

--- deskutils.kdepim3.patch begins here ---
diff -ruN kdepim3.orig/files/patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp kdepim3/files/patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp
--- kdepim3.orig/files/patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp	1969-12-31 19:00:00.000000000 -0500
+++ kdepim3/files/patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp	2009-07-01 19:51:10.000000000 -0400
@@ -0,0 +1,11 @@
+--- certmanager/lib/backends/qgpgme/qgpgmebackend.cpp.orig	2009-07-01 19:41:54.000000000 -0400
++++ certmanager/lib/backends/qgpgme/qgpgmebackend.cpp	2009-07-01 19:42:25.000000000 -0400
+@@ -54,7 +54,7 @@
+     mOpenPGPProtocol( 0 ),
+     mSMIMEProtocol( 0 )
+ {
+-
++  GpgME::initializeLibrary();
+ }
+ 
+ Kleo::QGpgMEBackend::~QGpgMEBackend() {
diff -ruN kdepim3.orig/files/patch-libkdenetwork-gpgmepp-Makefile.in kdepim3/files/patch-libkdenetwork-gpgmepp-Makefile.in
--- kdepim3.orig/files/patch-libkdenetwork-gpgmepp-Makefile.in	1969-12-31 19:00:00.000000000 -0500
+++ kdepim3/files/patch-libkdenetwork-gpgmepp-Makefile.in	2009-07-01 19:52:28.000000000 -0400
@@ -0,0 +1,11 @@
+--- libkdenetwork/gpgmepp/Makefile.in.orig	2009-07-01 19:33:31.000000000 -0400
++++ libkdenetwork/gpgmepp/Makefile.in	2009-07-01 19:39:35.000000000 -0400
+@@ -434,7 +434,7 @@
+ #   (Interfaces added/removed/changed:  CURRENT++, REVISION=0)
+ #   (Interfaces added:                  AGE++)
+ #   (Interfaces removed/changed:        AGE=0)
+-libgpgme___la_LDFLAGS = -no-undefined -version-info 3:0:3
++libgpgme___la_LDFLAGS = -no-undefined -version-info 4:0:4
+ libgpgme___la_LIBADD = $(GPGME_LIBS)
+ libgpgme___la_DEPENDENCIES = $(GPGME_LIBS_DEP)
+ all: all-recursive
diff -ruN kdepim3.orig/files/patch-libkdenetwork-gpgmepp-context.cpp kdepim3/files/patch-libkdenetwork-gpgmepp-context.cpp
--- kdepim3.orig/files/patch-libkdenetwork-gpgmepp-context.cpp	1969-12-31 19:00:00.000000000 -0500
+++ kdepim3/files/patch-libkdenetwork-gpgmepp-context.cpp	2009-07-01 19:52:05.000000000 -0400
@@ -0,0 +1,13 @@
+--- libkdenetwork/gpgmepp/context.cpp.orig	2009-07-01 19:33:09.000000000 -0400
++++ libkdenetwork/gpgmepp/context.cpp	2009-07-01 19:35:46.000000000 -0400
+@@ -53,6 +53,10 @@
+ 
+ namespace GpgME {
+ 
++  void initializeLibrary() {
++    gpgme_check_version( 0 );
++  }
++ 
+   const char * Error::source() const {
+     return gpgme_strsource( (gpgme_error_t)mErr );
+   }
diff -ruN kdepim3.orig/files/patch-libkdenetwork-gpgmepp-context.h kdepim3/files/patch-libkdenetwork-gpgmepp-context.h
--- kdepim3.orig/files/patch-libkdenetwork-gpgmepp-context.h	1969-12-31 19:00:00.000000000 -0500
+++ kdepim3/files/patch-libkdenetwork-gpgmepp-context.h	2009-07-01 19:52:16.000000000 -0400
@@ -0,0 +1,11 @@
+--- libkdenetwork/gpgmepp/context.h.orig	2009-07-01 19:33:50.000000000 -0400
++++ libkdenetwork/gpgmepp/context.h	2009-07-01 19:36:53.000000000 -0400
+@@ -287,6 +287,8 @@
+   //
+   //
+ 
++  KDE_EXPORT void initializeLibrary();
++
+   KDE_EXPORT GpgME::Error setDefaultLocale( int category, const char * value );
+ 
+   KDE_EXPORT Context * wait( GpgME::Error & e, bool hang=true );
diff -ruN kdepim3.orig/pkg-plist kdepim3/pkg-plist
--- kdepim3.orig/pkg-plist	2009-07-01 19:21:06.000000000 -0400
+++ kdepim3/pkg-plist	2009-07-02 15:24:09.000000000 -0400
@@ -594,7 +594,7 @@
 lib/libgpgme++.a
 lib/libgpgme++.la
 lib/libgpgme++.so
-lib/libgpgme++.so.3
+lib/libgpgme++.so.4
 lib/libgwsoap.a
 lib/libgwsoap.la
 lib/libgwsoap.so
--- deskutils.kdepim3.patch ends here ---

--- deskutils.kdepim4.patch begins here ---
diff -ruN kdepim4.orig/files/patch-kleopatra-main.cpp kdepim4/files/patch-kleopatra-main.cpp
--- kdepim4.orig/files/patch-kleopatra-main.cpp	1969-12-31 19:00:00.000000000 -0500
+++ kdepim4/files/patch-kleopatra-main.cpp	2009-07-01 18:59:31.000000000 -0400
@@ -0,0 +1,20 @@
+--- ../kleopatra/main.cpp.orig	2009-07-01 18:44:25.000000000 -0400
++++ ../kleopatra/main.cpp	2009-07-01 18:49:26.000000000 -0400
+@@ -75,6 +75,8 @@
+ #include <QEventLoop>
+ #include <QThreadPool>
+ 
++#include <gpgme++/global.h>
++
+ #include <boost/shared_ptr.hpp>
+ 
+ #include <cassert>
+@@ -153,6 +155,8 @@
+     QTime timer;
+     timer.start();
+ 
++    GpgME::initializeLibrary();
++
+   {
+       const unsigned int threads = QThreadPool::globalInstance()->maxThreadCount();
+       QThreadPool::globalInstance()->setMaxThreadCount( qMax( 2U, threads ) );
diff -ruN kdepim4.orig/files/patch-libkleo-backends-qgpgme-qgpgmebackend.cpp kdepim4/files/patch-libkleo-backends-qgpgme-qgpgmebackend.cpp
--- kdepim4.orig/files/patch-libkleo-backends-qgpgme-qgpgmebackend.cpp	1969-12-31 19:00:00.000000000 -0500
+++ kdepim4/files/patch-libkleo-backends-qgpgme-qgpgmebackend.cpp	2009-07-01 19:00:16.000000000 -0400
@@ -0,0 +1,11 @@
+--- ../libkleo/backends/qgpgme/qgpgmebackend.cpp.orig	2009-07-01 18:51:09.000000000 -0400
++++ ../libkleo/backends/qgpgme/qgpgmebackend.cpp	2009-07-01 18:57:10.000000000 -0400
+@@ -280,7 +280,7 @@
+     mOpenPGPProtocol( 0 ),
+     mSMIMEProtocol( 0 )
+ {
+-
++  GpgME::initializeLibrary();
+ }
+ 
+ Kleo::QGpgMEBackend::~QGpgMEBackend() {
--- deskutils.kdepim4.patch ends here ---

--- deskutils.kdepimlibs4.patch begins here ---
diff -ruN kdepimlibs4.orig/files/patch-gpgme++-CMakeLists.txt kdepimlibs4/files/patch-gpgme++-CMakeLists.txt
--- kdepimlibs4.orig/files/patch-gpgme++-CMakeLists.txt	1969-12-31 19:00:00.000000000 -0500
+++ kdepimlibs4/files/patch-gpgme++-CMakeLists.txt	2009-07-01 18:36:37.000000000 -0400
@@ -0,0 +1,11 @@
+--- ../gpgme++/CMakeLists.txt.orig	2009-07-01 18:28:08.000000000 -0400
++++ ../gpgme++/CMakeLists.txt	2009-07-01 18:28:36.000000000 -0400
+@@ -32,7 +32,7 @@
+         gpgadduserideditinteractor.cpp
+ )
+ 
+-set( _gpgmepp_version 2.0.2 )
++set( _gpgmepp_version 2.0.3 )
+ set( _gpgmepp_soversion 2 )
+ 
+ set( GPGMEPP_INCLUDE ${INCLUDE_INSTALL_DIR} ${GPGME_INCLUDES} ${Boost_INCLUDE_DIR} )
diff -ruN kdepimlibs4.orig/files/patch-gpgme++-context.cpp kdepimlibs4/files/patch-gpgme++-context.cpp
--- kdepimlibs4.orig/files/patch-gpgme++-context.cpp	1969-12-31 19:00:00.000000000 -0500
+++ kdepimlibs4/files/patch-gpgme++-context.cpp	2009-07-01 18:37:44.000000000 -0400
@@ -0,0 +1,13 @@
+--- ../gpgme++/context.cpp.orig	2009-07-01 18:28:59.000000000 -0400
++++ ../gpgme++/context.cpp	2009-07-01 18:30:51.000000000 -0400
+@@ -51,6 +51,10 @@
+ #include <cassert>
+ 
+ namespace GpgME {
++  void initializeLibrary() {
++      gpgme_check_version( 0 );
++  }
++
+   static inline gpgme_error_t makeError( gpg_err_code_t code ) {
+     return gpg_err_make( (gpg_err_source_t)22, code );
+   }
diff -ruN kdepimlibs4.orig/files/patch-gpgme++-global.h kdepimlibs4/files/patch-gpgme++-global.h
--- kdepimlibs4.orig/files/patch-gpgme++-global.h	1969-12-31 19:00:00.000000000 -0500
+++ kdepimlibs4/files/patch-gpgme++-global.h	2009-07-01 18:38:05.000000000 -0400
@@ -0,0 +1,11 @@
+--- ../gpgme++/global.h.orig	2009-07-01 18:26:50.000000000 -0400
++++ ../gpgme++/global.h	2009-07-01 18:27:58.000000000 -0400
+@@ -39,6 +39,8 @@
+ 
+ namespace GpgME {
+ 
++    GPGMEPP_EXPORT void initializeLibrary();
++
+     enum Protocol { OpenPGP, CMS, UnknownProtocol };
+ 
+     enum Engine { GpgEngine, GpgSMEngine, GpgConfEngine, UnknownEngine };
diff -ruN kdepimlibs4.orig/pkg-plist kdepimlibs4/pkg-plist
--- kdepimlibs4.orig/pkg-plist	2009-07-01 18:24:24.000000000 -0400
+++ kdepimlibs4/pkg-plist	2009-07-02 14:13:38.000000000 -0400
@@ -366,13 +366,13 @@
 lib/libakonadi-kmime.so.5.0.1
 %%WITH_PTH%%lib/libgpgme++-pth.so
 %%WITH_PTH%%lib/libgpgme++-pth.so.2
-%%WITH_PTH%%lib/libgpgme++-pth.so.2.0.2
+%%WITH_PTH%%lib/libgpgme++-pth.so.2.0.3
 lib/libgpgme++-pthread.so
 lib/libgpgme++-pthread.so.2
-lib/libgpgme++-pthread.so.2.0.2
+lib/libgpgme++-pthread.so.2.0.3
 lib/libgpgme++.so
 lib/libgpgme++.so.2
-lib/libgpgme++.so.2.0.2
+lib/libgpgme++.so.2.0.3
 lib/libkabc.so
 lib/libkabc.so.5
 lib/libkabc.so.5.0.1
--- deskutils.kdepimlibs4.patch ends here ---

--- devel.bazaar.patch begins here ---
diff -ruN bazaar.orig/files/patch-pfs-signatures.c bazaar/files/patch-pfs-signatures.c
--- bazaar.orig/files/patch-pfs-signatures.c	2009-07-01 21:01:30.000000000 -0400
+++ bazaar/files/patch-pfs-signatures.c	2009-07-01 21:10:59.000000000 -0400
@@ -9,3 +9,11 @@
  #include "libarch/pfs-signatures.h"
  
  
+@@ -1154,6 +1154,7 @@
+     gpgme_ctx_t context;
+     gpgme_data_t signature_data;
+     gpgme_data_t signed_content;
++    gpgme_check_version (NULL);
+     invariant (GPG_ERR_NO_ERROR == gpgme_new (&context));
+     invariant (GPG_ERR_NO_ERROR == gpgme_data_new_from_mem (&signature_data, *signed_message, str_length (*signed_message), 0));
+     invariant (GPG_ERR_NO_ERROR == gpgme_data_new (&signed_content));
--- devel.bazaar.patch ends here ---

--- finance.qhacc.patch begins here ---
diff -ruN qhacc.orig/files/patch-plugins::gpg::gpgplugin.cpp qhacc/files/patch-plugins::gpg::gpgplugin.cpp
--- qhacc.orig/files/patch-plugins::gpg::gpgplugin.cpp	1969-12-31 19:00:00.000000000 -0500
+++ qhacc/files/patch-plugins::gpg::gpgplugin.cpp	2009-06-30 00:59:43.000000000 -0400
@@ -0,0 +1,10 @@
+--- ./plugins/gpg/gpgplugin.cpp.orig	2009-06-30 00:55:33.000000000 -0400
++++ ./plugins/gpg/gpgplugin.cpp	2009-06-30 00:59:33.000000000 -0400
+@@ -56,6 +56,7 @@
+ const PluginInfo& GPGDBPlugin::info() const { return pinfo; }
+ 
+ bool GPGDBPlugin::iconnect( QHacc *, const QString&, QString& error ){
++	gpgme_check_version( NULL );
+ 	madectx=( GPG_ERR_NO_ERROR==gpgme_new( &gpgctx ) );
+ 	if( madectx ){
+ 		gpgme_set_passphrase_cb( gpgctx, GPGDBPlugin::passphrase_cb, 
--- finance.qhacc.patch ends here ---

--- mail.mutt-devel.patch begins here ---
diff -ruN mutt-devel.orig/files/patch-crypt-gpgme.c mutt-devel/files/patch-crypt-gpgme.c
--- mutt-devel.orig/files/patch-crypt-gpgme.c	1969-12-31 19:00:00.000000000 -0500
+++ mutt-devel/files/patch-crypt-gpgme.c	2009-07-01 21:33:06.000000000 -0400
@@ -0,0 +1,10 @@
+--- ./crypt-gpgme.c.orig	2009-07-01 21:28:51.000000000 -0400
++++ ./crypt-gpgme.c	2009-07-01 21:31:52.000000000 -0400
+@@ -342,6 +342,7 @@
+   gpgme_error_t err;
+   gpgme_ctx_t ctx;
+ 
++  gpgme_check_version (NULL);
+   if (!GpgmeLocaleSet)
+   {
+     gpgme_set_locale (NULL, LC_CTYPE, setlocale (LC_CTYPE, NULL));
--- mail.mutt-devel.patch ends here ---

--- net-im.ayttm.patch begins here ---
diff -ruN ayttm.orig/files/patch-modules__aycryption__aycryption.c ayttm/files/patch-modules__aycryption__aycryption.c
--- ayttm.orig/files/patch-modules__aycryption__aycryption.c	1969-12-31 19:00:00.000000000 -0500
+++ ayttm/files/patch-modules__aycryption__aycryption.c	2009-07-02 05:20:11.000000000 -0400
@@ -0,0 +1,11 @@
+--- ./modules/aycryption/aycryption.c.orig	2008-08-11 00:50:44.000000000 -0400
++++ ./modules/aycryption/aycryption.c	2009-07-02 04:06:35.000000000 -0400
+@@ -108,6 +108,8 @@
+ 
+ static int aycryption_init()
+ {
++	gpgme_check_version (NULL);
++
+ 	input_list *il = g_new0(input_list, 1);
+ 	plugin_info.prefs = il;
+ 
--- net-im.ayttm.patch ends here ---

--- net-im.centericq.patch begins here ---
diff -ruN centericq.orig/files/patch-src_impgp.cc centericq/files/patch-src_impgp.cc
--- centericq.orig/files/patch-src_impgp.cc	1969-12-31 19:00:00.000000000 -0500
+++ centericq/files/patch-src_impgp.cc	2009-07-01 23:21:51.000000000 -0400
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig	2009-07-01 23:19:00.000000000 -0400
++++ ./src/impgp.cc	2009-07-01 23:19:29.000000000 -0400
+@@ -12,6 +12,7 @@
+ string impgp::passphrase[];
+ 
+ impgp::impgp() {
++    gpgme_check_version(NULL);
+     if(gpgme_new(&ctx))
+ 	ctx = 0;
+ }
--- net-im.centericq.patch ends here ---

--- net-im.centerim-devel.patch begins here ---
diff -ruN centerim-devel.orig/files/patch-src__impgp.cc centerim-devel/files/patch-src__impgp.cc
--- centerim-devel.orig/files/patch-src__impgp.cc	1969-12-31 19:00:00.000000000 -0500
+++ centerim-devel/files/patch-src__impgp.cc	2009-07-01 23:28:12.000000000 -0400
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig	2009-07-01 23:27:35.000000000 -0400
++++ ./src/impgp.cc	2009-07-01 23:27:55.000000000 -0400
+@@ -13,6 +13,7 @@
+ string impgp::passphrase[];
+ 
+ impgp::impgp() {
++    gpgme_check_version(NULL);
+     if(gpgme_new(&ctx))
+ 	ctx = 0;
+ }
--- net-im.centerim-devel.patch ends here ---

--- net-im.centerim.patch begins here ---
diff -ruN centerim.orig/files/patch-src__impgp.cc centerim/files/patch-src__impgp.cc
--- centerim.orig/files/patch-src__impgp.cc	1969-12-31 19:00:00.000000000 -0500
+++ centerim/files/patch-src__impgp.cc	2009-07-01 23:25:47.000000000 -0400
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig	2009-07-01 23:25:08.000000000 -0400
++++ ./src/impgp.cc	2009-07-01 23:25:37.000000000 -0400
+@@ -13,6 +13,7 @@
+ string impgp::passphrase[];
+ 
+ impgp::impgp() {
++    gpgme_check_version(NULL);
+     if(gpgme_new(&ctx))
+ 	ctx = 0;
+ }
--- net-im.centerim.patch ends here ---

--- security.openvas-libnasl.patch begins here ---
diff -ruN openvas-libnasl.orig/files/patch-nasl__nasl_signature.c openvas-libnasl/files/patch-nasl__nasl_signature.c
--- openvas-libnasl.orig/files/patch-nasl__nasl_signature.c	1969-12-31 19:00:00.000000000 -0500
+++ openvas-libnasl/files/patch-nasl__nasl_signature.c	2009-07-01 23:10:14.000000000 -0400
@@ -0,0 +1,11 @@
+--- ./nasl/nasl_signature.c.orig	2009-07-01 23:08:30.000000000 -0400
++++ ./nasl/nasl_signature.c	2009-07-01 23:09:42.000000000 -0400
+@@ -131,6 +131,8 @@
+   gpgme_data_t sig = NULL, text = NULL;
+   char * gpghome = determine_gpghome();
+ 
++  gpgme_check_version (NULL);
++
+   err = gpgme_engine_check_version(GPGME_PROTOCOL_OpenPGP);
+   if (err)
+     {
--- security.openvas-libnasl.patch ends here ---
Comment 4 unixmania 2009-07-03 13:49:18 UTC
[resending to bug-followup]

I confirmed that  the patch provided by Jason works for ayttm. It is
also necessary to change ayttm/Makefile, because libgpgme has a new
version number, and set a port revision number. The corresponding
patch is attached.
Comment 5 dfilter freebsd_committer 2009-07-15 17:42:24 UTC
wxs         2009-07-15 16:42:07 UTC

  FreeBSD ports repository

  Modified files:
    security/gpgme       Makefile distinfo pkg-plist 
    security/gpgme/files patch-src-Makefile.in 
  Log:
  - Update to 1.2.0
  
  PR:             ports/135911
  Submitted by:   Jason E. Hale <bsdkaffee@gmail.com>
  
  Revision  Changes    Path
  1.59      +3 -1      ports/security/gpgme/Makefile
  1.19      +6 -6      ports/security/gpgme/distinfo
  1.2       +57 -39    ports/security/gpgme/files/patch-src-Makefile.in
  1.16      +7 -7      ports/security/gpgme/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 dfilter freebsd_committer 2009-07-15 17:47:56 UTC
wxs         2009-07-15 16:47:45 UTC

  FreeBSD ports repository

  Modified files:
    deskutils/kdepim3    Makefile pkg-plist 
    deskutils/kdepim4    Makefile 
    deskutils/kdepimlibs4 Makefile pkg-plist 
    devel/bazaar         Makefile 
    devel/bazaar/files   patch-pfs-signatures.c 
    finance/qhacc        Makefile 
    mail/mutt-devel      Makefile 
    net-im/ayttm         Makefile 
    net-im/centericq     Makefile 
    net-im/centerim      Makefile 
    net-im/centerim-devel Makefile 
    security/openvas-libnasl Makefile 
    deskutils/basket     Makefile 
    mail/balsa           Makefile 
    mail/claws-mail      Makefile 
    mail/sylpheed        Makefile 
    mail/sylpheed2       Makefile 
    net-im/mcabber       Makefile 
    security/gpa         Makefile 
    security/pecl-gnupg  Makefile 
    security/py-pyme     Makefile 
    security/seahorse    Makefile 
  Added files:
    deskutils/kdepim3/files 
                            patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp 
                            patch-libkdenetwork-gpgmepp-Makefile.in 
                            patch-libkdenetwork-gpgmepp-context.cpp 
                            patch-libkdenetwork-gpgmepp-context.h 
    deskutils/kdepim4/files patch-kleopatra-main.cpp 
                            patch-libkleo-backends-qgpgme-qgpgmebackend.cpp 
    deskutils/kdepimlibs4/files patch-gpgme++-CMakeLists.txt 
                                patch-gpgme++-context.cpp 
                                patch-gpgme++-global.h 
    finance/qhacc/files  patch-plugins::gpg::gpgplugin.cpp 
    mail/mutt-devel/files patch-crypt-gpgme.c 
    net-im/ayttm/files   patch-modules__aycryption__aycryption.c 
    net-im/centericq/files patch-src_impgp.cc 
    net-im/centerim/files patch-src__impgp.cc 
    net-im/centerim-devel/files patch-src__impgp.cc 
    security/openvas-libnasl/files patch-nasl__nasl_signature.c 
  Log:
  - Chase security/gpgme update.
  
  Most changes are just PORTREVISION and LIB_DEPENDS fixes. However, the
  following ports require a patch to use the new gpgme correctly:
  deskutils/kdepim3
  deskutils/kdepim3
  deskutils/kdepim3
  deskutils/kdepim3
  deskutils/kdepim4
  deskutils/kdepim4
  deskutils/kdepimlibs4
  deskutils/kdepimlibs4
  deskutils/kdepimlibs4
  finance/qhacc
  mail/mutt-devel
  net-im/ayttm
  net-im/centericq
  net-im/centerim
  net-im/centerim-devel
  security/openvas-libnasl
  
  These patches were submitted by various people and documented in ports/135911.
  
  PR:             ports/135911
  
  Revision  Changes    Path
  1.32      +2 -2      ports/deskutils/basket/Makefile
  1.85      +1 -1      ports/deskutils/kdepim3/Makefile
  1.1       +11 -0     ports/deskutils/kdepim3/files/patch-certmanager-lib-backends-qgpgme-qgpgmebackend.cpp (new)
  1.1       +11 -0     ports/deskutils/kdepim3/files/patch-libkdenetwork-gpgmepp-Makefile.in (new)
  1.1       +13 -0     ports/deskutils/kdepim3/files/patch-libkdenetwork-gpgmepp-context.cpp (new)
  1.1       +11 -0     ports/deskutils/kdepim3/files/patch-libkdenetwork-gpgmepp-context.h (new)
  1.36      +1 -1      ports/deskutils/kdepim3/pkg-plist
  1.94      +1 -0      ports/deskutils/kdepim4/Makefile
  1.1       +20 -0     ports/deskutils/kdepim4/files/patch-kleopatra-main.cpp (new)
  1.1       +11 -0     ports/deskutils/kdepim4/files/patch-libkleo-backends-qgpgme-qgpgmebackend.cpp (new)
  1.13      +1 -0      ports/deskutils/kdepimlibs4/Makefile
  1.1       +11 -0     ports/deskutils/kdepimlibs4/files/patch-gpgme++-CMakeLists.txt (new)
  1.1       +13 -0     ports/deskutils/kdepimlibs4/files/patch-gpgme++-context.cpp (new)
  1.1       +11 -0     ports/deskutils/kdepimlibs4/files/patch-gpgme++-global.h (new)
  1.5       +3 -3      ports/deskutils/kdepimlibs4/pkg-plist
  1.15      +2 -2      ports/devel/bazaar/Makefile
  1.2       +8 -0      ports/devel/bazaar/files/patch-pfs-signatures.c
  1.71      +2 -2      ports/finance/qhacc/Makefile
  1.1       +10 -0     ports/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp (new)
  1.139     +2 -1      ports/mail/balsa/Makefile
  1.149     +1 -0      ports/mail/claws-mail/Makefile
  1.304     +1 -1      ports/mail/mutt-devel/Makefile
  1.1       +10 -0     ports/mail/mutt-devel/files/patch-crypt-gpgme.c (new)
  1.117     +2 -2      ports/mail/sylpheed/Makefile
  1.165     +2 -1      ports/mail/sylpheed2/Makefile
  1.57      +2 -1      ports/net-im/ayttm/Makefile
  1.1       +11 -0     ports/net-im/ayttm/files/patch-modules__aycryption__aycryption.c (new)
  1.116     +2 -2      ports/net-im/centericq/Makefile
  1.1       +10 -0     ports/net-im/centericq/files/patch-src_impgp.cc (new)
  1.29      +2 -1      ports/net-im/centerim-devel/Makefile
  1.1       +10 -0     ports/net-im/centerim-devel/files/patch-src__impgp.cc (new)
  1.14      +2 -1      ports/net-im/centerim/Makefile
  1.1       +10 -0     ports/net-im/centerim/files/patch-src__impgp.cc (new)
  1.36      +2 -1      ports/net-im/mcabber/Makefile
  1.33      +1 -1      ports/security/gpa/Makefile
  1.6       +2 -2      ports/security/openvas-libnasl/Makefile
  1.1       +11 -0     ports/security/openvas-libnasl/files/patch-nasl__nasl_signature.c (new)
  1.9       +2 -2      ports/security/pecl-gnupg/Makefile
  1.2       +1 -0      ports/security/py-pyme/Makefile
  1.79      +2 -1      ports/security/seahorse/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Wesley Shields freebsd_committer 2009-07-15 17:52:28 UTC
State Changed
From-To: open->closed

Committed. Thanks!