Bug 135928 - [new port] lang/mono-basic: VisualBasic.NET support for Mono
Summary: [new port] lang/mono-basic: VisualBasic.NET support for Mono
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-mono (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-22 19:20 UTC by freebsd-mono (Nobody)
Modified: 2009-06-23 13:05 UTC (History)
1 user (show)

See Also:


Attachments
mono-basic.sh (3.98 KB, text/plain)
2009-06-22 19:20 UTC, freebsd-mono (Nobody)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd-mono (Nobody) freebsd_committer 2009-06-22 19:20:03 UTC
mono-basic is the Visual Basic Compiler and Runtime for lang/mono.

While some regressions tests fails when `make tests` is run the first time:

| Summary:
|     NotRun: 0 tests.
|     Running: 0 tests.
|     Failed: 18 tests.
      ^^^^^^^^^^^^^^^^
|     Regressed: 0 tests.
|     Success: 1663 tests.
|     KnownFailureSucceeded: 17 tests.
|     Skipped: 0 tests.
|     KnownFailureFailed: 52 tests.
|     Total: 1750 tests.
|     Duration: 00:48:06.9150700

... the second attempt passes:

| Summary:
|     NotRun: 0 tests.
|     Running: 0 tests.
|     Failed: 0 tests.
      ^^^^^^^^^^^^^^^^
|     Regressed: 0 tests.
|     Success: 1681 tests.
|     KnownFailureSucceeded: 17 tests.
|     Skipped: 0 tests.
|     KnownFailureFailed: 52 tests.
|     Total: 1750 tests.
|     Duration: 00:52:21.7712420


This is due to some inconsistencies in the test infrastructure. This port is
therefore considered stable enought to be pushed to the FreeBSD ports tree.
Comment 1 Edwin Groothuis freebsd_committer 2009-06-22 19:20:18 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mono

Submitter has GNATS access (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2009-06-23 12:46:12 UTC
flz         2009-06-23 11:46:02 UTC

  FreeBSD ports repository

  Modified files:
    lang                 Makefile 
  Added files:
    lang/mono-basic      Makefile distinfo pkg-descr 
    lang/mono-basic/files patch-configure 
                          patch-vbruntime_Test_Makefile 
  Log:
  Add lang/mono-basic 2.4, VisualBasic.NET support for Mono.
  
  PR:             ports/135928
  Submitted by:   Romain Tartiere
  
  Revision  Changes    Path
  1.647     +1 -0      ports/lang/Makefile
  1.1       +30 -0     ports/lang/mono-basic/Makefile (new)
  1.1       +3 -0      ports/lang/mono-basic/distinfo (new)
  1.1       +14 -0     ports/lang/mono-basic/files/patch-configure (new)
  1.1       +14 -0     ports/lang/mono-basic/files/patch-vbruntime_Test_Makefile (new)
  1.1       +3 -0      ports/lang/mono-basic/pkg-descr (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Florent Thoumie freebsd_committer 2009-06-23 13:05:41 UTC
State Changed
From-To: open->closed

Committed. Thanks!