Bug 136645 - Add a line to the devel/allegro-devel port
Summary: Add a line to the devel/allegro-devel port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Beat Gaetzi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-10 22:20 UTC by Eitan Adler
Modified: 2009-07-16 20:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eitan Adler freebsd_committer freebsd_triage 2009-07-10 22:20:01 UTC
Apply this diff to the allegro-devel port.
More fixes and updates coming soon.

--- Makefile.old        2009-07-10 17:17:17.000000000 -0400
+++ Makefile    2009-07-10 17:17:39.000000000 -0400
@@ -158,4 +158,6 @@
 .   endfor
 .endif
 
+PORTSCOUT=^0\.3.[0-9]*
+
 .include <bsd.port.post.mk>
Comment 1 Beat Gaetzi freebsd_committer 2009-07-11 11:03:54 UTC
Responsible Changed
From-To: freebsd-ports-bugs->beat

I'll take it.
Comment 2 Beat Gaetzi freebsd_committer 2009-07-11 11:35:20 UTC
State Changed
From-To: open->feedback

Shouldn't the PORTSCOUT-variable be set to limit:^4.3.[0-9]* ?
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2009-07-13 13:14:24 UTC
After looking at some other ports here is the current diff (with some
more recent portlint changes)

--- Makefile.old	2009-07-10 17:17:17.000000000 -0400
+++ Makefile	2009-07-13 08:10:43.000000000 -0400
@@ -75,10 +75,10 @@
 .endif

 .if !defined(WITHOUT_DEVEL)
-INSTALL_TARGET=	full-install install-man install-info
+INSTALL_TARGET=	full-install install-man
 PLIST_SUB+=	DEVEL=""
 .else
-INSTALL_TARGET=	mini-install install-man install-info
+INSTALL_TARGET=	mini-install install-man
 PLIST_SUB+=	DEVEL="@comment "
 .endif

@@ -158,4 +158,6 @@
 .   endfor
 .endif

+PORTSCOUT=limit:^0\.3.[0-9]*
+
 .include <bsd.port.post.mk>

-- 
Eitan Adler
"Security is increased by designing for the way humans actually behave."
-Jakob Nielsen
Comment 4 Beat Gaetzi freebsd_committer 2009-07-15 22:46:34 UTC
Eitan Adler wrote:
>  After looking at some other ports here is the current diff (with some
>  more recent portlint changes)
>  
>  --- Makefile.old	2009-07-10 17:17:17.000000000 -0400
>  +++ Makefile	2009-07-13 08:10:43.000000000 -0400
>  @@ -75,10 +75,10 @@
>   .endif
>  
>   .if !defined(WITHOUT_DEVEL)
>  -INSTALL_TARGET=	full-install install-man install-info
>  +INSTALL_TARGET=	full-install install-man
>   PLIST_SUB+=	DEVEL=""
>   .else
>  -INSTALL_TARGET=	mini-install install-man install-info
>  +INSTALL_TARGET=	mini-install install-man
>   PLIST_SUB+=	DEVEL="@comment "
>   .endif
>  
>  @@ -158,4 +158,6 @@
>   .   endfor
>   .endif
>  
>  +PORTSCOUT=limit:^0\.3.[0-9]*
>  +
>   .include <bsd.port.post.mk>

Port fails to build with the removal of install-info:
http://people.freebsd.org/~beat/logs/136645/allegro-devel-4.3.1_3.log

Should I back out the portlint change and commit the PORTSCOUT variable
or would you like to take a look at this problem?

Beat
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2009-07-16 03:31:59 UTC
Beat Gaetzi wrote:
> Eitan Adler wrote:
>>  After looking at some other ports here is the current diff (with some
>>  more recent portlint changes)
>>  
>>  --- Makefile.old	2009-07-10 17:17:17.000000000 -0400
>>  +++ Makefile	2009-07-13 08:10:43.000000000 -0400
>>  @@ -75,10 +75,10 @@
>>   .endif
>>  
>>   .if !defined(WITHOUT_DEVEL)
>>  -INSTALL_TARGET=	full-install install-man install-info
>>  +INSTALL_TARGET=	full-install install-man
>>   PLIST_SUB+=	DEVEL=""
>>   .else
>>  -INSTALL_TARGET=	mini-install install-man install-info
>>  +INSTALL_TARGET=	mini-install install-man
>>   PLIST_SUB+=	DEVEL="@comment "
>>   .endif
>>  
>>  @@ -158,4 +158,6 @@
>>   .   endfor
>>   .endif
>>  
>>  +PORTSCOUT=limit:^0\.3.[0-9]*
>>  +
>>   .include <bsd.port.post.mk>
> 
> Port fails to build with the removal of install-info:
> http://people.freebsd.org/~beat/logs/136645/allegro-devel-4.3.1_3.log
> 
> Should I back out the portlint change and commit the PORTSCOUT variable
> or would you like to take a look at this problem?
Do the first for now. I must say that It Works For Me (tm) when I remove
the install-info line. I will however read the logs and see what the
difference between my ports and your logs are.
> 
> Beat
> 


-- 
Eitan Adler
"Security is increased by designing for the way humans actually behave."
-Jakob Nielsen
Comment 6 dfilter service freebsd_committer 2009-07-16 20:42:52 UTC
beat        2009-07-16 19:42:39 UTC

  FreeBSD ports repository

  Modified files:
    devel/allegro-devel  Makefile 
  Log:
  - Add PORTSCOUT variable
  
  PR:             ports/136645
  Submitted by:   Eitan Adler <EitanAdlerList AT gmail.com> (maintainer)
  
  Revision  Changes    Path
  1.36      +2 -0      ports/devel/allegro-devel/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Beat Gaetzi freebsd_committer 2009-07-16 20:43:09 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!